LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-02-2004, 05:08 PM   #1
christophe.dr
LQ Newbie
 
Registered: Aug 2003
Location: Paris
Distribution: mandrake 9.1
Posts: 26

Rep: Reputation: 15
kernel2.6.3-19mdkcustom : version? -> No module


I run mandrake 10.0 official.
I upgraded to kernel-2.6.3-19mdksmp.
For some reason (cpudyn/cpufreq...) i need to recompile this kernel into a new kernel called : kernel2.6.3-19mdkcustom
So, i made :

make xconfig

I chose everything i needed.
I ran :

make
make modules_install
make install
mkinitrd /boot/initrd-2.6.3-19mdkcustom.img 2.6.3-19mdkcustom

No problem until there.
When i boot, choosing my new kernel, 2.6.3-19mdkcustom, when it has to load some modules it insults me with bad words like (found in /var/log/messsages) :

Dec 2 22:20:38 descartes modprobe: WARNING: Error inserting soundcore (/lib/modules/2.6.3-19mdksmp/kernel/sound/soundcore.ko.gz): Invalid module format

The line before in this log says :

Dec 2 22:20:37 descartes kernel: No module symbols loaded - kernel modules not enabled.

Strange ! Because i had enabled loadable module support in the make xconfig...
If i leave init finish its boot, i type :

uname -r

and it answers :

2.6.3-19mdksmp

When it is supposed to be 2.6.3-19mdkcustom. Yet lilo.conf is correctly written, as it was written automatically by kernelinstall. Anyway i checked it and it has no errors...

I had the same problem with 2.6.3-16mdksmp which i finally managed to turn into a very good 2.6.3-16mdkcustom. But i don't remember how i succeeded.
So i tried every thing all day long.
I tried every orders, make modules before and after the kernel, lilo -v, mandrake control center for lilo, mkinitrd before and after, and so on...
I checked the lilo.conf and it it is perfectly written.
I tried to google the net but found nothing really linked to my case.
So now at the end of such a tiring day, i say : i need a kernel that works and that loads its modules.
Please help.
 
Old 12-04-2004, 03:36 PM   #2
christophe.dr
LQ Newbie
 
Registered: Aug 2003
Location: Paris
Distribution: mandrake 9.1
Posts: 26

Original Poster
Rep: Reputation: 15
Now, the REAL problem is :
Why does the kernel 2.6.3-19mdkcustom thinks he is 2.6.3-19mdksmp ???
Because, as i wrote, when i boot 2.6.3-19mdkcustom, there are these modprobe errors :
WARNING: Error inserting soundcore (/lib/modules/2.6.3-19mdksmp/kernel/sound/soundcore.ko.gz): Invalid module format
But it succeeds to boot without these modules. And then, when i type :
uname -r
it answers :
2.6.3-19mdksmp
Isn't it weird ?!? It is supposed to be 2.6.3-19mdkcustom... And it happens when install is made automatically by make install and also when copy by myself the vmlinuz in the /boot...
Really strange.
Why does this kernel thinks he is 2.6.3-19mdksmp when he is 2.6.3-19mdkcustom and, therefore, refuses to load any 2.6.3-19mksmp modules because they are not made for him...
I think there is a bug here. Otherwise, i made a mistake. And i'd like to know where.
 
Old 12-05-2004, 01:34 PM   #3
christophe.dr
LQ Newbie
 
Registered: Aug 2003
Location: Paris
Distribution: mandrake 9.1
Posts: 26

Original Poster
Rep: Reputation: 15
Yes !!!
I made a
make mrproper and followed http://doc.mandrakelinux.com/Mandrak...ng-module.html
stepe by step and my new kernel and is running all right !!!
Yes !!!!
This thread can be closed
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Perl Module Version on AS RH 3.0 brendskina Linux - Enterprise 2 06-13-2005 07:52 AM
Kernel-module Version Mismatch !!! lionking_x Linux - Newbie 1 02-02-2004 01:01 PM
Xfree Error (EE) module ABI minor version (7) is newer than the server's version (6) jimdaworm Slackware 0 10-17-2003 05:26 PM
Xfree prob radeon.o kernel module version is 1.1.1 but version 1.5.0 or newer needed. jimdaworm Slackware 0 10-01-2003 06:27 PM
Sample Driver Module incompatibility with Kernel version (or gcc version) jvs Linux - General 1 06-07-2002 01:40 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration