LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-31-2006, 09:35 AM   #1
bassey
LQ Newbie
 
Registered: Aug 2006
Posts: 3

Rep: Reputation: 0
kernel panic: scsi_free: Bad offset ...


Hi,
Would really really appreciate you help here.

My system suddenly hung with a:
"kernel panic: scsi_free: bad offset in interrupt handler - not syncing" message.

I restarted it and it wont boot up. I get

megaraid: v1.19.7
megaraid: no bios enabled
/lib/megaraid.o: init_module:
...
...
Error: /bin/insmod exited abnormally
loading jbd module
journalled block device driver loaded
Loading ext3 module
mounting /proc filesystem
creating root device
mounting root filesystem
.
.
.
enter runlevel:

When I do enter a runlevel (like 3 for instance), I get:

Init: Entering runlevel: 3
Init: No more processes left in this runlevel.

Please how do I resolve this. I suspect that I should update the kernel, but I can't even get the system to boot.

I tried to boot from cdrom in rescue mode, but for some reason the disk isn't being read. I ran system tests and got "the cd in your cdrom drive does not contain any digital data!";

Thank you and please hurry!

Last edited by bassey; 08-31-2006 at 09:44 AM.
 
Old 08-31-2006, 10:55 AM   #2
bassey
LQ Newbie
 
Registered: Aug 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Ok, I figured out what was wrong with my cdrom drive. I have now booted into rescue mode. Hmm, what next...
 
Old 08-31-2006, 12:54 PM   #3
bassey
LQ Newbie
 
Registered: Aug 2006
Posts: 3

Original Poster
Rep: Reputation: 0
Okay, I am now able to access my disk. I noticed that the module megaraid.o was not in the /lib/ dir. I found it in /lib/modules/2.4.9-e.3smp/kernel/drivers/scsi/megaraid.o.

So my next question is: How do I change the module parameters so that my kernel looks in the correct directory for this module.
 
  


Reply

Tags
megaraid


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel panic: scsi_free:Bad offset error cereal83 Slackware 1 03-06-2006 06:41 PM
ubuntu, kernel panic and bad EIP value. Psychobiker Ubuntu 1 11-16-2005 02:01 PM
Bad EIP value - Kernel Panic macarthor Programming 1 11-12-2005 11:34 AM
Code: Bad EIP Value <0>Kernal panic oprogue DamnSmallLinux 5 01-28-2005 08:27 AM
Kernel Panic? That's bad right? omegaworks Linux - General 6 08-29-2004 05:27 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 11:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration