LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   kernel panic: scsi_free: Bad offset ... (https://www.linuxquestions.org/questions/linux-software-2/kernel-panic-scsi_free-bad-offset-479142/)

bassey 08-31-2006 09:35 AM

kernel panic: scsi_free: Bad offset ...
 
Hi,
Would really really appreciate you help here.

My system suddenly hung with a:
"kernel panic: scsi_free: bad offset in interrupt handler - not syncing" message.

I restarted it and it wont boot up. I get

megaraid: v1.19.7
megaraid: no bios enabled
/lib/megaraid.o: init_module:
...
...
Error: /bin/insmod exited abnormally
loading jbd module
journalled block device driver loaded
Loading ext3 module
mounting /proc filesystem
creating root device
mounting root filesystem
.
.
.
enter runlevel:

When I do enter a runlevel (like 3 for instance), I get:

Init: Entering runlevel: 3
Init: No more processes left in this runlevel.

Please how do I resolve this. I suspect that I should update the kernel, but I can't even get the system to boot.

I tried to boot from cdrom in rescue mode, but for some reason the disk isn't being read. I ran system tests and got "the cd in your cdrom drive does not contain any digital data!";

Thank you and please hurry!

bassey 08-31-2006 10:55 AM

Ok, I figured out what was wrong with my cdrom drive. I have now booted into rescue mode. Hmm, what next...

bassey 08-31-2006 12:54 PM

Okay, I am now able to access my disk. I noticed that the module megaraid.o was not in the /lib/ dir. I found it in /lib/modules/2.4.9-e.3smp/kernel/drivers/scsi/megaraid.o.

So my next question is: How do I change the module parameters so that my kernel looks in the correct directory for this module.


All times are GMT -5. The time now is 04:29 AM.