-   Linux - Software (
-   -   Kernel Panic on Dual Processor Motherboard with only 1 Processor (

olar 10-13-2001 10:12 AM

Kernel Panic on Dual Processor Motherboard with only 1 Processor
Well, I've been trying to get a successful install (and boot) on my desktop machine...I've tried Redhat and Mandrake...But I'm chiefly interested in getting Redhat to run. I have a Tyan Tomcat IV Dual processor socket 7 motherboard occupied with one AMD k6-2+ (which doesn't support adding another CPU wouldn't help). I've tried installing in expert mode and tried jumpering to both single and dual processor settings on my MB with the same result. Redhat 7.0 installs fine and recognizes all my hardware, but when it reboots to execute the OS for the first time, it detects hardware fine until it comes to my processor. It finds the AMD k6-2+ (400MHz) just fine, but it tries to talk to a second processor and doesn't get a responce, goes into a kernel panic, and shuts down Linux.

What command line parameter do I need to add to disable the SMP mode of the kernel...or what do I need to specify during install? I re-installed using expert mode a few times and couldn't find any options pertaining to this. I've installed Redhat fine on other computers using the same CDs, but no luck with my motherboard in this one. Any help will be greatly appreciated. :)

isajera 10-13-2001 04:57 PM

the smp support is a kernel option. the kernel itself needs to be recompiled without any smp support.

All times are GMT -5. The time now is 08:29 AM.