LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Kernel Panic from debian to fedora... (https://www.linuxquestions.org/questions/linux-software-2/kernel-panic-from-debian-to-fedora-309817/)

vidski 04-05-2005 01:11 AM

Kernel Panic from debian to fedora...
 
so i was running debian just fine with my custom compiled 2.6.11.6 kernel.

I switch to fedora core 2, downloaded and unpacked 2.6.11.6 from kernel.org and compiled it using the same .config from my custom debian kernel, the compile went smoothly. (as i expected)

but now when i reboot i get...
Kernel Panic - Not Syncing: VFS: Unable to mount root fs on unknown-block(0,0)

i looked in /boot/grub/menu.lst and from whan i can tell everything seems to be correct but i still get this error when trying to boot the new kernel.

I changed NO hardware, i simply switched from debian to fedora core 2, which is why i dont understand why this happened.

i dont know if paths are pointing to incorrect places or if fedora needs something special in the kernel that debian dosent but its getting frustrating because it makes no sence to me, any help would be greatly appreciated.

masand 04-05-2005 02:06 AM

hi there

i would recommewnd that u use the config file from ur fedora core installaton
u can find it in the /boot

regards

vidski 04-05-2005 03:03 AM

I dont really want to use the origional config fedora comes with because it is a bloated, precompiled kernel that is not specific to my hardware. And besides, FedoraC2 comes stock with 2.6.5 so its older anyways. Thats why im using the 2.6.11 sources along with the custom config I made. Worked fine with debian running on the same computer, but not FedoraC2. Im just trying to figure out if I need to add something to the kernel to make it work in Fedora that just wasnt necessary for Debian, or if my kernel is fine like I had assumed it would be and troubleshoot elsewhere.

masand 04-05-2005 03:26 AM

do u have the filesysten support in fedora also built in the kernel same as for debian and also u need support for ext2 FS no matter what FS u use

regards


All times are GMT -5. The time now is 01:11 PM.