Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 08-21-2002, 08:41 AM   #1
LQ Newbie
Registered: Aug 2002
Location: malaysia
Posts: 21

Rep: Reputation: 15
kernel panic

im running dual boot system for almost 1 year no problem,but now im facing the problem when i booting from linux,the error is

mount:error6 mounting ext3
freeing unused kernel memory:220k freed
kernel panic:no init found.try passing init=option to kernel
Old 08-21-2002, 09:54 AM   #2
Registered: May 2002
Location: Essex, UK
Distribution: Debian, Redhat, AIX 5L
Posts: 512

Rep: Reputation: 30
what is happening is that mount is failing because the fstab entry
is saying that the filesystem is ext3, but since the ext3 mount is
failing, the root filesystem is never mounted, which makes the
pivotroot operation fail, and that's why you're getting the "no init
found" error message.

One of way of making things more robust is to use an /etc/fstab entry
which looks like this:

/dev/hda1 / ext3,ext2 defaults 1 1

This will cause mount and fsck to first try ext3, and then ext2, so
that in the case where the filesystem is converted back to ext2 due to
a filesystem error, the system will actually come back up cleanly.
The only gotcha here is that the code to support having a list of
filesystems in /etc/fstab is relatively new, and I don't know what
version of Red Hat youre running; if it's too old, it might not have a
sufficiently new enough version of mount and fsck (in the util-linux
and e2fsprogs packages, respectively).

Another way of solving the problem would be to add something like the
following to the Red Hat's initrd linuxrc, before it tries to mount
the real root partition:

ext3root=`awk '{ if (($2 == "/") && ($3 == "ext3")) {print $1;}}' /etc/fstab`
if test -n "$ext3root" ; then
tune2fs --j $ext3root > /dev/null
Old 08-21-2002, 08:02 PM   #3
Registered: Jun 2002
Location: NY
Distribution: Gentoo,RH
Posts: 333

Rep: Reputation: 40
I think the problem is that the kernel doesn't have the ext3 driver compiled in. Do it and it should work.

Old 08-21-2002, 08:08 PM   #4
Senior Member
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Debian + Ubuntu
Posts: 4,358

Rep: Reputation: 57
If you have your /boot section on a seperate partition, then you could mount it as ext2 even though it may be formatted as ext3... they're basically the same fs.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel 2.4 in Zipslack (Waring: unable to open an initial console | Kernel Panic...) kurtamos Linux - General 2 05-10-2006 01:58 PM
kernel panic: try passing init= option to kernel...installation with Red Hat 9 kergen Linux - Hardware 1 09-30-2004 04:28 AM
Kernel panic puts me in a panic theeeg Linux - Software 2 07-31-2004 05:46 PM
kernel panic (narius panic) narius Linux - Newbie 3 06-20-2002 04:56 PM
Kernel panic making me panic! Linux_N0oby Linux - Software 19 05-29-2002 01:31 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:08 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration