LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-23-2010, 02:54 PM   #1
brianpbarnes
Member
 
Registered: Dec 2005
Posts: 143

Rep: Reputation: 15
Kernel Disabling IRQ #16 =-> rsync speed slowed by 10x ??


Hi,
Like a dutiful system administrator, I am using rsync to backup my junk across the network. Suddenly, I get this error message:
Message from syslogd@trex at Jun 23 14:04:06 ...
kernel:[19994.877482] Disabling IRQ #16

My rsync process was running at between 26 and 31 mb/s over the network. After the error, it is running at 2.5 MB/s. That's a real handicap on HD video files and system images. D'oh!

I looked at my interrupts and found them all bunched up on a few IRQs with other IRQs empty. I have (had) 4 pieces of hardware on IRQ 16 and none on 2, 3, 4, 5, 7, 10, 11, 13, 14, 15, 17, 20, 22, 24-27, ...
root@trex:/r5/bak# cat /proc/interrupts | grep 16:
16: 2197893 701 697 725 IO-APIC-fasteoi uhci_hcd:usb3, pata_marvell, pata_sil680, 3w-9xxx

Why would anybody in their right mind put USB3, PATA drives, a fake raid controller and a real raid controller on the same interrupt when many others are available. Isn't that like everybody sharing one bathroom when there are 17 others available?

There is a BIOS setting for PNP OS. I should have this set to YES to let Linux (suse 11.2/64), not the Asus mobo set the IRQs, right?

The 3w-9xxx is my 8 drive, hardware XOR, caching RAID controller. It's hdparm speed is down to 2.68 MB/s. Normally, it is well above 100 MB/s

Is there any way other than rebooting to fix this? Last time I rebooted SUSE treated me to an hour long, mandatory FSCK on a 3TB partition on this RAID controller.

Thank you,
BrianP
 
Old 06-24-2010, 09:27 AM   #2
business_kid
LQ Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 10,128

Rep: Reputation: 1111Reputation: 1111Reputation: 1111Reputation: 1111Reputation: 1111Reputation: 1111Reputation: 1111Reputation: 1111Reputation: 1111
I would suggest trying a reboot with noapic on the boot line, but . . .

Can you get busy as folloes: Write carefully crafted instructions for each offending thing in /etc/modprobe.d, then get busy with rmmod -f and modprobe to see if you can sort it that way.The kernel documentation provides useful modprobe options. Otherwise schedule the reboot for the world cup final :-)).
 
Old 06-24-2010, 10:03 AM   #3
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291Reputation: 1291
Actually instead of 'noapic' you should try 'noioapic' or 'nolapic' first.

I have a Gigabyte board where the internet would go out because of similar IRQ problems, it was putting everything on one IRQ, I eventually had to disable all SATA and PATA drivers (all on that one IRQ with the ethernet card) and use AHCI instead, that seemed to use a different IRQ. I don't really understand how it works, but the internet has been on ever since. I suspect a bug in one of the many PATA and SATA drivers. To switch the AHCI you also have to change it in the BIOS for the SATA controller.

Anyway, it may be hard to find an answer, but keep trying, there are many BIOS options you can try as well.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
rhel kernel: Disabling IRQ #233 _linux Linux - Newbie 1 05-18-2010 10:06 AM
kernel: Disabling IRQ #19 shogun1234 Linux - Kernel 1 11-21-2008 10:29 AM
kernel: Disabling IRQ #177 centosian Debian 2 02-27-2006 10:58 AM
kernel: Disabling IRQ specman Mandriva 2 10-21-2005 07:35 AM
localhost kernel: Disabling IRQ #7 ? fabre Mandriva 2 08-30-2005 06:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration