-   Linux - Software (
-   -   Kernel 2.6.81 Won't Boot with LILO under Slackware 10.0 (

pwo 10-20-2004 03:14 PM

Kernel 2.6.81 Won't Boot with LILO under Slackware 10.0
I just got around to getting and compiling kernel 2.6.81. I followed all the instructions on (summarily: download kernel, configure, make, change all the symbolic links in boot, change lilo), rebooted, and I immediately noticed LILO was broken; it was still displaying my old menu options. I chose my old Linux option anyway (thinking that when I ran /sbin/lilo during the kernel compile process and it gave me an error message about hda3 (my bootable partition) not being active and I stupidly ignored it, it didn't load the new lilo.conf). This SHOULD have worked, because I made the vmlinuz, config, and links to the new kernel files in /boot, but it said something about "BIOS Data Checking" and the screen went black, keyboard unresponsive.

I booted from the Slackware CD and tried to figure out what was going on. I booted the bare.i kernel from the CD, mounted hda3, and checked lilo.conf, nothing seemed odd, so I ran /mnt/sbin/lilo, but it tells me all my files needed don't exist (because i am running it from /mnt). First question, how do I trick it into thinking /mnt is root, so I don't have to make links all over the place? (or should I just make links all over the place)? Second question is, even with the strange LILO behaviors, the kernel still doesn't boot properly. I changed all the symbolic links to the old 2.4.26 kernel files, and the screen continues to go black.

Thanks for your help!

guardian653 10-20-2004 03:54 PM

Not too sure about the lilo part but as for running /mnt as / thats simple

# chroot [mount point] [shell]
# chroot /mnt/hda3 /bin/bash

You might want to mount proc before you chroot it too:
# mount -t proc none [mount point]/proc

Hope that helps

jschiwal 10-22-2004 01:40 AM

Did you remember to run /sbin/lilo before you rebooted? That will write the changed information.
You can do as Guardian653 suggests and chroot before trying to run lilo.

Using the ' -l ' option will load in your normal paths.

All times are GMT -5. The time now is 02:40 PM.