-   Linux - Software (
-   -   Keep having to run startx twice for it to find the mouse (

Khang 10-23-2004 04:46 PM

Keep having to run startx twice for it to find the mouse
Hi there... I don't know if this problem is common, but I haven't been able to find much on it. Seems some people are having problems with their mouse device not being found when they run startx, but my problem is a bit different. You see, if I boot my system and run startx, I get the following:

xf86OpenSerial: Cannot open device /dev/psaux
No such device

(Typed from memory so I can't guarantee that's accurate to the letter)

However, if I run startx a second time, I get no errors, and everything works perfectly - including the mouse.

The device Mouse1 defined in my XF86Config-4 is as follows:

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "auto"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/psaux"

And in the appropriate line in my ServerLayout section is just:

InputDevice "Mouse1" "CorePointer"

My mouse is a Microsoft wireless one. It's plugged into a PS/2 port, but the actual mouse cable has a USB plug on it. I'm using an adapter that came with it to connect it to the PS/2 port. I'm not sure if that's of any importance.

Any ideas why this is happening, and how to fix it? Thanks :)

UsualTuxpect 10-23-2004 09:02 PM

Comment out what u have by putting a hash(#) in front of the lines

and put the following and try....

Section "InputDevice"

# Identifier and driver

Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Device" "/dev/mouse"
Option "Emulate3Buttons"


Khang 10-23-2004 09:19 PM

I don't have a /dev/mouse so I don't see that working :/

As for the change from auto to ImPS/2, judging by the logs it's was detecting ImPS/2 already.

I've tried having Emulate3Buttons on already, and it didn't make any difference.

Thanks for the reply though :)

If I type 'cat /dev/psaux' at the command line, then move the mouse, I get lots of characters being printed, so I know that device is the one. Having said that, it also works with /dev/input/mice and /dev/input/mouse0. I've tried using both of those devices in my XF86Config-4 and they didn't work (not even when I run startx a second time), so I changed it back to /dev/psaux.

All times are GMT -5. The time now is 08:01 PM.