-   Linux - Software (
-   -   "kdesu" daemon gives contradictory error message & all terminal emulators hang (

hari_seldon99 07-21-2004 12:01 PM

"kdesu" daemon gives contradictory error message & all terminal emulators hang

I'm running Mandrake Linux 10.0 with the 2.6.3-7mdk kernel. I recently got a new HDD and used qtparted to migrate my linux partitions to the new drive. After booting into it from cd, doing "chroot" to the partitions in the new HDD and then building a new ramdisk that had the drivers for my newSCSI controller and rewriting the bootloader in my MBR accordingly, I booted into the "new" linux partitions. Everything seems to work fine same as before but for 2 things (so far).

1. Whenever I log in as a normal user and start KDE, and try to access root priviledges by using "kdesu -c 'blabla'" I get the following error:

"su not found, set your path correctly"

I ran "which su" and ""echo "$PATH" "" in console mode ("ctrl-alt-F2") and their outputs are below respectively:

/bin/su & /usr/local/bin:/bin:/usr/bin:/usr/X11R6/bin:/usr/games

seems fine, the path to "su" is there. That's what's so odd.

2. I can't start up any terminal emulators like "xterm" or "konsole". Whenever I do , the window opens but no shell prompt shows. However, when I log in graphically as "root" (a bad thing to do, I admit), the terminal emulators start up fine. Thus, I am thinking that maybe some file somewhere has the permissions set all wrong and normal users that need to read that file to start up "xterm" can't do so.

How do I find out what that file is?

I tried to look at stdin/out messages using xconsole but no luck there either. Currently, the only way I can access shells is to "ctrl-alt-F2" to console mode without X.

I also tried to reinstall the kdebase package rpm (where the kdesu binary is located) but no luck there either.

I's be grateful for any advoce on how to diagnose this.

All times are GMT -5. The time now is 07:05 AM.