LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   KDE4 Konqueror (https://www.linuxquestions.org/questions/linux-software-2/kde4-konqueror-812157/)

oddball 06-04-2010 09:53 AM

KDE4 Konqueror
 
Is there a way to set up KDE4 Konqueror so that middle click opens a file like in KDE3? In KDE3 Konqueror, middle clicking on a particular file would have the same effect as double clicking on it.

frankbell 06-04-2010 12:32 PM

In my Slack 13.0 with Fluxbox, Konqueror by default opens files with the middle button/mouse wheel.

But, thanks to your question, I fired up KDE and finally found where they hid the settings in KDE four.

Menu--->Computer--->System Settings--->Window Behavior--->Window Actions.

Why they didn't put it under "Mouse" I will never figure out. One of my beefs about KDE4 is that they moved a bunch of stuff around for, as far as I can tell, no good reason other than to make it look different.

Now I'm going back to Fluxbox, where I'm in control and that Akonadi thingee isn't nagging me.

oddball 06-07-2010 06:34 PM

Thanks, but that doesn't work for me.

frankbell 06-07-2010 09:39 PM

Just for grins and giggles, what distro and windows manager or desktop environment are you using (I know that KDE seems obvious, but it's not--I run KDE on my Ubuntu netbook under Gnome without a full KDE installed).

oddball 06-08-2010 08:47 PM

KDE 4.4.4 on openSUSE 11.2

damgar 06-08-2010 09:12 PM

Wheel click=open file is apparently the default in KDE 4.4.3 in Slackware, and 4.4.4 built with the Slackware 4.4.3 slackbuilds.

frankbell 06-10-2010 10:14 PM

I was just experimenting on my Ubuntu box. I have both KDE and Gnome installed and use Fluxbox for a window manager.

Running Konqueror under Fluxbox, middle-clicking the mouse wheel opens a file in a new background tab in Konqueror, but it does not open the file (I tested a *.txt and a *.jpg file) in a new window in the normally associated application (Gedit and what's it called Eye of Gnome).

I would guess that's the default setting, because I haven't tinkered with it in the year or so I've had the computer (heck I'm the guy who waited months to update his Xorg config file to make a three-button mouse work under Slackware because I really didn't care all that much).

I glanced at the Konqueror settings and didn't find anything about the middle button/mouse wheel.

Looking in Gnome Control Center-->Mouse, I can't find anything about the middle button in any of the tabs.

It's been a couple of years since I ran Open Suse. I might load it up on a computer just to see what happens.

Aside to damgar: Love the Ike quote.

damgar 06-10-2010 10:31 PM

Thanks :)


All times are GMT -5. The time now is 05:58 PM.