LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-02-2003, 06:08 PM   #1
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
KDE3.1/ konqueror (super user mode) FIX


there is a bug in the arts package that causes konq. super user mode to crash instantly. there has been several hacks / work arounds posted to this and other sites/mailing lists, here is the actual fix.

get this patch http://bugs.kde.org/attachment.cgi?id=566&action=view
get the arts source code http://ftp.du.se/pub/mirrors/kde/sta...ts-1.1.tar.bz2

unpack and appliy the patch, then do the ./configure, make, make install dance. if your distro puts kde in a directory other than /usr/local run configure with a prefix specifier eg. on SuSE it would be ./configure --prefix=/opt/kde3

this has been applied to the CVS tree, and will be in KDE 3.1.1.

Last edited by rshaw; 03-03-2003 at 12:10 PM.
 
Old 03-03-2003, 12:32 PM   #2
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Original Poster
Rep: Reputation: 45
going to bump this up to give non-regulars a look, if you never launch konq. via kdesu, you probably haven't noticed a problem.
 
Old 08-21-2003, 09:37 AM   #3
amos
Member
 
Registered: Dec 2002
Location: Manchester, UK
Distribution: LMDE
Posts: 224

Rep: Reputation: 30
I'm not sure why but when I tried to run

patch -p1 </path to/patch.diff

from inside the arts-1.1 directory it would only apply the first hunk, the second one failed.

I've manually applied the patch and am currently waiting for "make" to run its course.

I'm just wondering why the patch failed?

Cheers
Amos
 
Old 08-21-2003, 09:49 AM   #4
amos
Member
 
Registered: Dec 2002
Location: Manchester, UK
Distribution: LMDE
Posts: 224

Rep: Reputation: 30
Even though the patch failed, manually applying it and recompiling arts seems to have done the trick, as Konqueror now loads with no problems in Super User Mode.

Cheers
Amos
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
File Manager Super User mode Hans Troost Mandriva 3 08-19-2005 02:03 PM
File Browser Super User Mode Enigmus Linux - General 1 04-24-2004 11:31 PM
file manager - super user mode ?? im_ka Fedora 3 02-05-2004 09:50 PM
File Manager - Super User Mode iNFERiON Linux - Newbie 1 12-23-2003 08:19 AM
SuSE 8.0 and kfm super-user mode? rodda Linux - Software 3 05-14-2002 08:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration