-   Linux - Software (
-   -   kde prefix error when running ./configure (

hoopyfrood 04-24-2004 09:10 PM

kde prefix error when running ./configure
Hi All,

I've been using Linux for a long time, but I've never had this problem. I suspect the culprit is Mandrake 10.0 Community, which has turned out to be a lot buggier than I had anticipated. Oh well, SuSE 9.1 is due soon.

Anyway, whenever I run ./configure, it fails with the error:


checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!

This problem is universal: no matter what source I try to configure, it throws up this error.

I've tried "./configure --prefix=/usr", and a lot of other path variations. It still fails.

Any idea what's going on here? When I first installed MDK10 I didn't have this problem. It only cropped up after a re-install. But I don't really wanna reinstall again:(


hoopyfrood 04-25-2004 05:40 PM


Turns out, I decided to upgrade to KDE 3.2.2 last night, cause KDE 3.2 seemed really unstable on MDK10.0 CE. After installing the new packages, I update my KDE-devel packages and it fixed the problem.

The problem always seemed to be link to headers, even though I had the 3.2 headers installed. Now that it recognises the 3.2.2 headers, everything is compiling fine.

Btw, KDE 3.2.2. packages for MDK10.0 are here:

Use at own risk! (it went really well for me)


All times are GMT -5. The time now is 03:29 AM.