LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-30-2003, 12:17 AM   #16
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 46

install back the previous version of glibc, glib and those thing you might have changed, I suppose you are having the old version somewhere on your installation CD.
Never try to update or to mess with glibc, I done that weird error, some time ago, too
 
Old 06-30-2003, 12:48 AM   #17
broxys
Member
 
Registered: Jun 2003
Location: nj
Distribution: slack10
Posts: 46

Original Poster
Rep: Reputation: 15
not in posession of that cd but i'm sure it'll be easy enough on rpmfind.net.

thx
 
Old 06-30-2003, 01:02 AM   #18
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 46
you'll need to eaxt version you were using, installing another different version will create the same disaster.
 
Old 06-30-2003, 01:14 AM   #19
broxys
Member
 
Registered: Jun 2003
Location: nj
Distribution: slack10
Posts: 46

Original Poster
Rep: Reputation: 15
i'm sorry.. eaxt?
 
Old 06-30-2003, 09:43 AM   #20
Half_Elf
LQ Guru
 
Registered: Sep 2001
Location: Montreal, Canada
Distribution: Slackware; Debian; Gentoo...
Posts: 2,163

Rep: Reputation: 46
oups
my typing is horrible.
I meant "exact"
 
Old 06-30-2003, 02:09 PM   #21
broxys
Member
 
Registered: Jun 2003
Location: nj
Distribution: slack10
Posts: 46

Original Poster
Rep: Reputation: 15
trying to downgrade glibc:
error: Failed dependencies:
libpthread.so.0(GLIBC_2.3.2) is needed by (installed) qt-3.1.1-6

or

#rpm -ivh --force glibc-*
error: Failed dependencies:
glibc > 2.2.93 conflicts with glibc-common-2.2.93-5


so i tried to downgrade to qt-3.0.5 but i get:
error: qt-3.0.5-17.i386.rpm: V3 DSA signature: BAD, key ID db42a60e
error: qt-3.0.5-17.i386.rpm cannot be installed


any suggestions?

Last edited by broxys; 06-30-2003 at 02:29 PM.
 
Old 06-30-2003, 06:44 PM   #22
broxys
Member
 
Registered: Jun 2003
Location: nj
Distribution: slack10
Posts: 46

Original Poster
Rep: Reputation: 15
SOLVED

i finally got a good QT reinstall (qt 3.0.5) and i can now run those programs again!! what a relief. i found rpms that worked at http://ftp.redhat.com/pub/redhat/lin...6/RedHat/RPMS/
so i think that's it!? thx everyone for the help!
 
Old 06-30-2003, 07:06 PM   #23
broxys
Member
 
Registered: Jun 2003
Location: nj
Distribution: slack10
Posts: 46

Original Poster
Rep: Reputation: 15
Any ideas as to why i cannot upgrade to qt 3.1??
 
Old 07-01-2003, 04:35 PM   #24
cropcircle
Member
 
Registered: Jun 2003
Location: Netherlands
Distribution: Red Hat Linux 9, FreeBSD 4.8, Knoppix 3.2
Posts: 182

Rep: Reputation: 30
You probably cannot upgrade to Qt 3.1 because Qt is a 'multiplatform, C++ application framework', as seen on the site :

http://www.trolltech.com/products/index.html

The programs (for example KDE, Licq, etc ... ) which you use, and also external (not included with Red Hat 8.0) programs like Opera, are build for the version of Qt as supplied with Red Hat 8.0.

A solution (which is not recommended) is to remove all traces of KDE and Qt < 3.1 on your system and to install Qt 3.1. Then you must recompile the packages you want to run with Qt 3.1 against the Qt 3.1 library.

This way the packages will make use of the new features, enhancements and bugfixes of the newer version of Qt 3.1.

Building software from source like KDE requires a lot of patience because it is a big package of software and will take several hours to complete.

Perhaps you'll find some RPMS though which make these steps somewhat simpler.

If you really must, you can also choose Red Hat Linux 9, which contains Qt 3.1.1 and other new packages.

Last edited by cropcircle; 07-04-2003 at 01:55 PM.
 
Old 08-03-2003, 09:26 PM   #25
Picomp314
LQ Newbie
 
Registered: Aug 2003
Posts: 1

Rep: Reputation: 0
In response to opera question

There are several versions of Opera available from the webpage, I was having the same problem as you were due to the fact that I had also reinstalled qt to version 3.1. The version of Opera you are using is apparently suited for qt v. 3.05 bundled with RH 8. Simply download and install one of the Qt static versions and all should be fixed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Executing web based Perl programs in userdirs markham82 Linux - General 3 12-15-2004 07:49 PM
ncurses based programs in Slack 10.0 superandrzej Slackware 3 08-08-2004 04:58 PM
running windows based programs in linux gambit Linux - Newbie 3 05-17-2004 08:49 PM
need help on running windows-based programs nrjeromene Linux - Newbie 6 01-14-2004 09:23 PM
DOS based configuration programs rwelch Linux - Networking 2 03-06-2003 02:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration