-   Linux - Software (
-   -   KDE 4.8 effects don't work. (

Geremia 02-27-2012 01:04 PM

KDE 4.8 effects don't work.
2 Attachment(s)
After upgrading to KDE 4.8, I get the follow error when trying to get the desktop effects that worked in my previous KDE version working again:

Failed to activate desktop effects using the given configuration options. Settings will be reverted to their previous values.

Check your X configuration. You may also consider changing advanced options, especially changing the compositing type.

Attachment 9147
And these effects are disabled:
Attachment 9148
So, I added the following to my /etc/X11/xorg.conf:

Section "Extensions"
    Option "Composite" "Enable"

But that didn't help. I still get this message in my ~/.xsession-errors:

OpenGL vendor string:                  Tungsten Graphics, Inc
OpenGL renderer string:                Mesa DRI Intel(R) Ironlake Mobile 
OpenGL version string:                  2.1 Mesa 7.9.2
OpenGL shading language version string: 1.20
Driver:                                Intel
GPU class:                              i965
OpenGL version:                        2.1
GLSL version:                          1.20
Mesa version:                          7.9.2
X server version:                      1.9.5
Linux kernel version:                  3.2.2
Direct rendering:                      yes
Requires strict binding:                yes
GLSL shaders:                          yes
Texture NPOT support:                  yes
kwin(2751): KWin requires at least Mesa 7.10 for OpenGL compositing.
kwin(2751): Failed to initialize compositing, compositing disabled
kwin(2751): Consult

For some reason KWin thinks I have an older OpenGL version.

Interestingly, switching my compositing type from OpenGL to XRender is a small improvement, but many desktop effects still don't work.

Also, I get a KWin segmentation fault occasionally, too, which is related to this.

Thanks for the help

Geremia 02-28-2012 03:52 PM

Installed Mesa again
So, I re-installed Mesa, and now it works...

All times are GMT -5. The time now is 11:56 PM.