-   Linux - Software (
-   -   Kde 4.4.5: Use custom Alsa device in Phonon (

Vookimedlo 01-15-2011 01:15 PM

Kde 4.4.5: Use custom Alsa device in Phonon

I'd like to ask you how to configure Phonon in Kde 4.4.5 to use custom Alsa device specified in my ~/.asoundrc.


pcm.duplicate {
type route
slave.pcm surround51
slave.channels 6
ttable.0.0 1
ttable.1.1 1
ttable.0.2 1
ttable.1.3 1
ttable.0.4 0.5
ttable.1.4 0.5
ttable.0.5 0.5
ttable.1.5 0.5

  hint {
    show on
    description "Duplicate"


Device is working correctly for mplayer, XMMS, .... However, I'd like to use this device in Amarok 2.x which unlike Amarok 1.4 uses only Phonon. :(

Thanks a lot.

serafean 01-27-2011 04:59 PM

Hi, which phonon backend are you using? Did you enable "show advanced devices"?
Under 4.4 I had very good experience with ALSA "hints" and the xine backend.


Vookimedlo 01-29-2011 01:28 PM

My backend is xine, and I have enabled "show advanced devices".
However, I can only choose "SB Live! EMU10k1 Analog stereo" device.

Could you show me your asoundrc file? Maybe I have wrong "hint" section.


serafean 01-29-2011 03:21 PM

Actually, what I do is create the device systemwide in /etc/asound.conf

        type dmix
        ipc_key 1024
                pcm "optical"
                period_size 2048
                buffer_size 8192
                rate 44100
        ipc_key_add_uid false
        ipc_perm 0666
                0 0
                1 1

and then put the hint into my ~/.asoundrc

        type plug
        slave.pcm "dmixer"
        hint{  show on
                description "Dmix plugin for optical"

I think that you need to have the hint in the config of a plug device, just my $0.02 (btw, just checked and it alsoo works with the VLC backend)

Vookimedlo 01-30-2011 04:14 PM

Still no luck even I use hinting in PCM having "plug" type.

BTW: My original content of .asoundrc works flawlessly with mplayer and audacious. But KDE is a devil. :(

What's you version of KDE, Phonon and Alsa?

serafean 01-30-2011 04:25 PM

2 Attachment(s)
Right now, I'm using KDE-4.6, phonon 4.4.4 with the VLC backend. But up to a month ago, I was using KDE-4.4, phonon 4.4.3 with the xine backend, and it was also working. Yes, I've been there, with CLI apps getting the device correctly, and kde not. At the beginning I worked around it by making the device I wanted phonon to use the pcm.!default :)
Dumb question : you do log out an back in after every change to .asoundrc? I know that made me loose some hair.


Edit : attaching my working asound.rc and my system asound.conf

Vookimedlo 01-30-2011 04:39 PM

Got it. Now it works.

It was pulseaudio which suppressed my devices even no pulseaudio daemon was running. I removed whole 'pa' and now I see all SB Live HW Devices including my self defined PCMs.

Thank you for your help.

All times are GMT -5. The time now is 01:23 AM.