LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-09-2006, 10:01 PM   #1
tisource
Member
 
Registered: Feb 2002
Posts: 322

Rep: Reputation: 30
KDE 3.5 and icon placement


I have KDE 3.5.1 installed (OPENSUSE 10.0) and was wondering if anyone is having problems with icon placement on the desktop.

I know icon placement has been a problem for KDE for a long time. Icons just won't stay where they are supposed to. Although I absolutely love KDE, the icon placement problem has been my biggest gripe, and it is a very big gripe at that.

I know KDE 3.5 introduced a "icon lock" feature which is supposed to keep your icons where you put them. It successfullly prevents me from accidentally moving them, but KDE rearranges the icons on every login, which is extremely annoying (regardless of auto-arrange or icon lock settings).

I prefer to put my icons in border fashion, along the outer perimeter of my monitor - along the top, bottom and sides. I tend to group them, i.e. Internet apps on the top, office apps along the bottom, multimedia apps along the right side, etc.

KDE takes the icons along the left side, and crams them into the upper-left corner, like its trying to auto-arrange them for me... but only the left side is affected. The icons everywhere else on the desktop stay put as they are supposed to.

If you are having a similar problem, have you found a temporary fix or possible solution?
 
Old 02-10-2006, 05:17 AM   #2
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
Right-click on the desktop
choose Icons and uncheck everything except 'Lock in place'.
My icons stays where they are at every start of KDE. I have no problem with this even since KDE 3.3.x
 
Old 02-10-2006, 11:41 AM   #3
tisource
Member
 
Registered: Feb 2002
Posts: 322

Original Poster
Rep: Reputation: 30
When I take off auto-arrange, the icons don't dramatically slide all over the screen, like they were doing - icons on the left edge stay on the left edge. However, the icons do lose alignment with each other - they aren't vertically and horizontally aligned. The exact position of the icons are still not in place.

So, in other words, this fixes one issue and presents another alltogether bad issue.

I truly love KDE, but they've gotta nail this bug, as it is very, very annoying!!!!
 
Old 02-10-2006, 11:51 AM   #4
tisource
Member
 
Registered: Feb 2002
Posts: 322

Original Poster
Rep: Reputation: 30
Is there a dcop call to tell KDE to align the icons, then turn it off again (so I get the aligned icons, but alignment isn't checked for reboot issues)
 
Old 02-10-2006, 12:00 PM   #5
tisource
Member
 
Registered: Feb 2002
Posts: 322

Original Poster
Rep: Reputation: 30
Got it...
dcop kdesktop KDesktopIface lineupIcons

I'll just run this upon login, without the icon lock or auto arrange ON, and I think it will do me well.

Thanks
 
Old 02-10-2006, 12:58 PM   #6
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
Good you found a way to solve this issue.
But I don't think it's a bug in KDE.
Here is the method I use to have my icons staying in place:
Uncheck 'Lock in place' and everything else.
Put your icons where you want on the desktop.
After that check 'Align to grid'
Your icons should now be well aligned, you may yet correct their position if necessary.
When everything is OK, uncheck 'Align to grid', and everything else.
Finally check 'Lock in place'. (KDE 3.5.x only)
This works for me, even without the new 'Lock in place' option!
My icons go to their place at every start of KDE.
 
Old 02-10-2006, 05:49 PM   #7
tisource
Member
 
Registered: Feb 2002
Posts: 322

Original Poster
Rep: Reputation: 30
No, I'm adament it is a bug. I was doing just that, and they would stay in place for the given login session. Upon reboot (or even a logoff) the icons shuffle around and rearrange.

If you search google for the issue, you'll find lots of people complaining about it. It has been a problem for some time.
 
Old 02-11-2006, 05:47 AM   #8
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
I forgot to mention one important point:
in Control Center/KDE Components/Session Manager you should check 'Restore previous session' rather than 'Start with an empty session'.
That's logical if you start every time with an empty session you lose your previous icons placement.
I affirm that with the option 'Restore previous session' and the method described above I have no problem with the icons positions on the desktop at every start, since KDE 3.2.x
You tell KDE to keep the session and not to touch the icons and that's it. It seems logical to me.
Where is a bug there?
Regards.
 
Old 02-11-2006, 08:34 PM   #9
tisource
Member
 
Registered: Feb 2002
Posts: 322

Original Poster
Rep: Reputation: 30
I have KDE restore a manually saved session, not start with an empty session. I had saved the session when I had the icon placement I wanted.

There's no doubt in my mind that it's a bug. I have a co-worker who uses KDE at home, and he has the same problem (he uses the 'restore previous session' option).

Besides, it doesn't make sense when only one quadrant of the desktop icons shuffle around, and the others don't, regardless of session settings. The behavior is anything but expected.

Regarding the auto-arrange feature - it isn't intended to be turned on and then quickly turned off again. If that were the case, it wouldn't mark as "ON" (checked) when used. In other words, it would be an action that is invoked, not a feature that is turned on and off. It is a setting that is supposed to maintain grid alignment, it isn't meant to be a one-time action.

Last edited by tisource; 02-11-2006 at 08:42 PM.
 
Old 02-12-2006, 12:57 PM   #10
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
After some further research I admit that I use the 'Align to grid' option as a one time action rather than a permanent feature as it seems to be the intent of the KDE developers. But I use it like that because it works in this way only.
Furthermore the 'Restore previous session' and 'Restore manually saved session' options look to have been designed to restart or not the running programs at the log out time, and not to have anything to do with the desktop icons. But as the desktop is a part of a session, it can be implicit that the icons are also concerned in the case of the 'Start with an empty session' option. But it's not very clear though.
In all these senses I can concede that this issue may be regarded as a KDE bug :
to find only a work-around is not satisfying in a development sense.

Nevertheless I reaffirm that the method I use with my icons placement works since many KDE versions backwards. My desktop icons stay always at their place on the desktop at avery start of KDE. I write it again here for those who may be interested :
in Control Center/KDE Components/Session Manager
Restore previous session checked
in Control Center/Desktop/Behavior (I omitted this one in the previous posts)
File Icons tab
Automatically line up icons unchecked
in the right-click menu/Icons on the desktop
everything unchecked except 'Lock in place' (for KDE 3.5.x)
in the 'Sort Icons' sub-menu
'Directories First' is checked
I use only the 'Align to grid' option after I manually placed the icons on the desktop, and I uncheck it immediately after.
(It seems from posts about experiences by other KDE users that this method may sometimes work and sometimes not work, though I cannot understand why. I cannot figure out why this works for me and not for some others).

I hope we will be now on a common ground about this subject and that your solution with a dcop command will give you a "work-around" solution.
I hope also that KDE 4 will solve this issue.
Best wishes to you and your co-workers.
 
Old 02-12-2006, 01:33 PM   #11
tisource
Member
 
Registered: Feb 2002
Posts: 322

Original Poster
Rep: Reputation: 30
I'm sure the bug is hard to nail down, primarily because it probably isn't 100% reproducible - obviously you aren't having problems with it, and I am, so it isn't there all the time.

In older versions of KDE, I did like you did - turned the auto-arrange on and then off again when I added a new icon. That way, the icon was aligned, but the align feature wasn't "on" because it would misappropriately arrange the icons upon reboot. For some reason, KDE 3.5 doesn't behave that way for me.

Thanks for your all of your responses!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Window Button Placement in KDE under Xandros strake Linux - Distributions 2 11-21-2005 06:34 AM
Gnome 2.8 Icon Placement kemis Linux - Software 0 08-26-2005 08:18 AM
KDE forgets icon placement every login?? registering Mandriva 5 04-21-2005 08:53 AM
KDE Window Placement Frustration David the H. Linux - General 1 09-27-2004 04:05 PM
kde icon problems frankprogramer Linux - Software 1 10-13-2002 08:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration