LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-11-2007, 11:02 AM   #1
vangelis
Member
 
Registered: Nov 2004
Location: Hellas
Distribution: Zenwalk 6.4
Posts: 337
Blog Entries: 4

Rep: Reputation: 30
KDE 3.5.5 or Xorg 7.1 makes desktop really slow


Hello people,

Right now I'm facing this problem with Kubuntu Edgy x86_64 (after the upgrade from Dapper), but I have it also with OpenSuse 10.2 so I'm not posting it at the distro sub-forum. Also both are using the newest Xorg 7.1

The problem is that my desktop and I think my whole system is really slow. When I try to scroll down with Konqueror it takes 5 seconds to scroll 1 page. When I try drag a window it leaves many mirrors as a trail behind and restores after some seconds. This didn't happen when I used distros with older kde and xorg.

I have a decent desktop setup with a fast amd64 processor, 1gb ram and ati x1600 video card.

I'm kinda out of places to search, I tried the changelogs from kde 3.5.2 to 3.5.5 but nothing helpful there.

In KSystemLog I found an error saying:
Code:
kdm_greet[4721] Internal error: memory corruption detected
and also Xorg uses 80% of my system resources which it shouldn't(found that on KSysGuard)

Is there any other place I should search for something useful?
 
Old 02-11-2007, 12:13 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 335Reputation: 335Reputation: 335Reputation: 335
Try using a generic video driver.

I found that when I got my ATI Radeon running with OpenGL using the ATI driver my system slowed down enormously.
 
Old 02-11-2007, 12:31 PM   #3
vangelis
Member
 
Registered: Nov 2004
Location: Hellas
Distribution: Zenwalk 6.4
Posts: 337

Original Poster
Blog Entries: 4

Rep: Reputation: 30
I'm already using vesa and before the upgrade too on both systems (suse,ubuntu) cause I have a buggy combination for the binary ati driver (64bit + x1X00 radeon + xorg6.9). I'm starting to feel that xorg is causing this cause I found many problems on other forums for 7.1 but I'm lost, totally.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xorg translucency makes kde menus hard to see notapplicable Linux - Desktop 4 09-29-2006 06:05 PM
running dclient makes gnome and kde slow Steve Mading Linux - Wireless Networking 0 11-11-2004 04:13 PM
fc1 kde desktop refresh too slow cucmi Linux - General 0 06-21-2004 10:36 PM
Very slow desktop (KDE) in Mandrake 10.0 RUG Mandriva 13 03-29-2004 01:21 AM
Slow KDE Desktop count_nikon Linux - Newbie 4 11-30-2001 02:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration