-   Linux - Software (
-   -   KDE 3.2 Logout Freeze Issue (

R0c4 10-30-2004 08:55 PM

KDE 3.2 Logout Freeze Issue
Ok, here's the the problem, I can boot Mandrake Linux 10.0 and login
using KDE 3.2 on my home computer just fine but when I
logout/halt/reboot on any user including root, my system crashes. It
goes to a completely black screen and does nothing and pressing the
power button on my system does nothing also at that stage. At this point
I have to pull the plug on my system to shutdown/reboot. Does anyone
know how to solve this?

There's a way I can logout without using the end session by using
ctrl+alt+backspace and that will bring my system to the Linux login
and from there I can shutdown properly. But still, I would like to have
the logout function to work properly.

I've been using that ctrl+alt+backspace to logout for a while, but now that the official 10.1 edition came I decided to download and install the Powerpack 10.1 edition from my university distribution. Guess what? My system still freezes on logout with Mandrake Linux 10.1 Powerpack(which still uses KDE 3.2). I've tried all the display manager(kdm, mandrakedm, xdm) and the same problem. I prefer to use kde over gnome so I don't have gnome installed on my system, but it has IceWM and I get the same logout problem when using that also.

I posted this on my university's linux forum, but none of my professors or collegues have replied. Can anyone here help me?

UsualTuxpect 10-30-2004 09:07 PM

Did you check your logs ???
Are you using Xfree86 or Xorg as Xserver

check your /var/log/XFree86.0.log or Xorg.log

also do #dmesg and see if anythings wrong..

UsualTuxpect 10-30-2004 09:12 PM

I have sort of faced the same problem as you..
Check this link -->

R0c4 10-30-2004 09:27 PM

I'm using Xorg.

I just checked my '/var/log/' folder and I had several Xorg.#.log files I checked all of them and each had about ~1000 lines of stuff in it. I don't know where to start.

UsualTuxpect 10-30-2004 09:41 PM

Check for line which have (EE) is the start of the line as they indicate error's.

R0c4 10-30-2004 09:50 PM

This is the last line that had an (EE):

(EE) R128(0): No DFP detected

(WW) R128(0): config file hsync range 31.5-37.9kHz not within DDC hsync ranges.
(WW) R128(0): config file vrefresh range 50-70Hz not within DDC vrefresh ranges.

Those were then followed by a bunch of (II) lines.

R0c4 10-30-2004 10:16 PM

Ok, I've tried fiddling around with my screen resolution and set them up to be exactly the same as the resolution on my windows partion. Still doesn't work.

R0c4 10-30-2004 10:28 PM

Found another error on my Xorg.9.log file

(II) R128(0): [drm] drmOpen failed
(EE) R128(0): [dri] DRIScreenInit failed. Disabling DRI.
(II) R128(0): Memory manager initialized to (0,0) (800,8191)
(II) R128(0): Reserved area from (0,600) to (800,602)
(II) R128(0): Largest offscreen area available: 800 x 7589
(II) R128(0): Using XFree86 Acceleration Architecture (XAA)

What does these all mean?

Thanks in advance.

R0c4 10-30-2004 10:34 PM

Here's the last entry on the kdm.log:

(==) Using config file: "/etc/X11/xorg.conf"
Using vt 7
(EE) Failed to load module "/usr/X11R6/lib/modules/extensions/libglx.a" (once-only module, 135962511)
(WW) R128(0): Failed to set up write-combining range (0xd4000000,0x2000000)
(EE) R128(0): No DFP detected
(WW) R128(0): Failed to set up write-combining range (0xd4000000,0x2000000)
SetClientVersion: 0 8

I have no idea what any of this means. Any enlightment would be very much appreciated.

UsualTuxpect 10-30-2004 10:43 PM

try commenting the module glx by putting a #
In the -->Section "Module"
#Load "glx"

And try restarting the system

I think u have problem's with your graphics accelaration drivers..

R0c4 11-01-2004 10:13 PM

Alright I commented out that line in the xorg.conf file and I still have problems. Here's the new entry from the kdm.log after the change in the xorg.conf file:

(==) Using config file: "/etc/X11/xorg.conf"
Using vt 7
(WW) R128(0): Failed to set up write-combining range (0xd4000000,0x2000000)
(EE) R128(0): No DFP detected
(WW) R128(0): Failed to set up write-combining range (0xd4000000,0x2000000)
SetClientVersion: 0 8

R0c4 11-02-2004 10:01 AM

Are there demons near by?

R0c4 11-02-2004 06:06 PM

Ready for action.
Say the word.

R0c4 11-03-2004 01:39 PM

Locked and loaded.

UsualTuxpect 11-03-2004 02:02 PM

Try changing your horizontal sync and vertical refresh rates and also your resolution's [I know you said you've done this ] according to your monitor spec sheet..

All times are GMT -5. The time now is 05:59 PM.