LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-08-2002, 03:55 AM   #1
dai
Member
 
Registered: May 2002
Location: Wales
Distribution: Slack 8.1, Gentoo 1.3a, Red Hat 7.3, Red Hat 7.2, Manrake 8.2
Posts: 328

Rep: Reputation: 30
Kde 3.0


Hi I have finally managed to get KDE compiled and installed from source.

I have installed the following in order: -

Qt 3.05
Arts 1.0
KDElibs-3.0
KDEBase-3.0

When I ran KDE I got the KDE 3.0 splash screen up but also Kicker crashed, which left me with no panel.

I then tried recompiling kdelibs and make install>No effect repeated this for KDEBase>No effect

I tried installing the Rh RPM for KDELibs and hey presto it worked (no more crashes on boot)

However now I am having problems opening the Rh package manager and get errors appearing when opening text files telling me prog doesent exist but then the file opens.

Also I cant get into KDE via my user account unless I set the Init Level to 5 (GUI) and logon and select KDE from there, this doesnt happen when Im logged in as root

WHat do I need to do to solve these problems??

Reinstall package manager from rh cd??? If so whats the name of the rpm and what cd is it on

Install all other KDE 3.0 packages i.e. those that were installed for KDE 2.2????

Reinstall Rh 7.2 without any Gui's then install and compile from command line????

Last edited by dai; 08-08-2002 at 04:05 AM.
 
Old 08-08-2002, 08:42 AM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,575

Rep: Reputation: 181Reputation: 181
I had a similar program (with crashing KDE apps) when KDE3 was compiled using gcc from MDK8.0 . I replaced it with gcc 3.1.1, compiled again and it works fine now.
 
Old 08-08-2002, 10:24 AM   #3
dai
Member
 
Registered: May 2002
Location: Wales
Distribution: Slack 8.1, Gentoo 1.3a, Red Hat 7.3, Red Hat 7.2, Manrake 8.2
Posts: 328

Original Poster
Rep: Reputation: 30
really could be the same prob, Im using rh 7.2 and gcc 2.9.6(I think) at the mo

Im also thinking of binning rh and going over to slack 8.1

Last edited by dai; 08-08-2002 at 10:33 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!!! Installed kde 3392 rpms keyboard dead inside kde, working in shell hansschmucker SUSE / openSUSE 1 02-13-2005 09:01 PM
Why wont my KDE 3.2 FC2 setup run make commands w/KDE 1.x packages? rusty_slacker Linux - Newbie 1 09-19-2004 06:40 PM
dpi font | gdm | kde DE | xinitrc.kde | Slackware 10 acummings Slackware 2 07-28-2004 11:28 PM
couple of qs, gnome ftp, removing kde or improving speed of kde, startup modprobe darkleaf Linux - Software 2 07-20-2004 10:54 AM
[REDHAT KDE] Disable KDE boot? Apache down after 10min losing monitor signal bjwesselink Linux - Software 2 08-11-2003 02:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration