LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-24-2016, 02:28 PM   #1
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,535

Rep: Reputation: Disabled
Kate with openSUSE leap42.1 uses chinese(?) characters in a sddm.conf


I edited /etc/sddm.conf with kate on openSUSE leap42.1, adding some parameters. Everything looked alright, in particular I could read what I was entering...

Those new parameters didn't work. So I went back and opened /etc/sddm.conf with kate again -- getting a message, that kate had opened the file with UTF8 encoding but there were characters contained with a different encoding and alright, anything I had entered showed up as chinese(?). I tried it with cat, kwrite and vim, they all confirmed chinese(?) entries.

So, how / why could this happen? (How) Can I re-convert my entries to UTF8? And to add to this confusion, /etc/sddm.conf looks now (one evening later) like this

Code:
Current=breeze
CursorTheme=breeze_cursors

[XDisplay]
ServerPath=/usr/bin/X
SessionCommand=/etc/X11/xdm/Xsession
DisplayCommand=/etc/X11/xdm/Xsetup
MinimumVT=7

[Users]
HideShells=/usr/sbin/nologin,/bin/false 
MaximumUid=65000
MinimumUid=0
HideUsers=?Ę
...all chinese(?) characters gone. What the...
 
Old 02-25-2016, 03:17 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,534

Rep: Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622
are you SURE that they are now in Chinese pictographs
-- the above line in traditional
Quote:
你確定他們現在在中國的象形文字

Korean is very different in looks
Quote:
당신은 그들이 중국의 상형 문자에있다 확실하다
reset your language

or

is it the normal ascii block that looks like a domino's tile

Last edited by John VV; 02-25-2016 at 03:21 PM.
 
Old 02-26-2016, 02:43 AM   #3
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,535

Original Poster
Rep: Reputation: Disabled
No it is not Korean, but certainly asian. I'm not an expert there, I don't know which language they really belong to, they just looked like chinese (your first example) or japanese (kanji).

How do I "reset my language"?

It is (was) definitely not smeared ascii.
 
Old 08-02-2016, 08:34 AM   #4
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,535

Original Poster
Rep: Reputation: Disabled
I tried also editing under windows both with word and the little text editor. No luck. I typed it into a newly opened document in windows (the whole shebang in sddm.conf). No luck again. I used dos2unix on the files. Still no luck. I filed a bug in april on openSUSE's bugzilla. No reaction either. I guess sddm not only reads but also alters sddm.conf, but that is way over my head to solve.

*sigh*

Really nobody with an idea how to circumvent this?

Last edited by JZL240I-U; 08-02-2016 at 08:35 AM.
 
Old 08-03-2016, 12:38 AM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,534

Rep: Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622
as above i asked is it really Chinese "simple" or "traditional "
or
like this " ⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲ "
like a domino tile

for the domino tiles it is a missing language

this is my "sddm.conf"
Code:
[Autologin]
Relogin=false
User=

[General]
HaltCommand=
RebootCommand=

[Theme]
Current=breeze
CursorTheme=crystalgreen

[Users]
MaximumUid=65000
MinimumUid=1000

[XDisplay]
DisplayCommand=/etc/X11/xdm/Xsetup
MinimumVT=7
ServerPath=/usr/bin/X
SessionCommand=/etc/X11/xdm/Xsession

Last edited by John VV; 08-03-2016 at 12:45 AM.
 
Old 08-03-2016, 02:23 AM   #6
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,535

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by John VV View Post
as above i asked is it really Chinese "simple" or "traditional"
Ah, my error. But how do I discern simple from traditional Chinese?

Quote:
Originally Posted by John VV View Post
or like this "⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲⛲" like a domino tile for the domino tiles it is a missing language
It is definitely not like this, there are different symbols of an asian (Chinese, Japanese,...) origin. And Kate is set to UTF8.

Quote:
Originally Posted by John VV View Post
this is my "sddm.conf"
...
Thanks for this example, I changed MinimumUid=0 (not 1000) and added system daemons to HideUsers=at,avahi... and then the problems start.

Just noticing: is MinimumUid=0 too low? What number is root? But still, this should not create symbols of another language.

Last edited by JZL240I-U; 08-03-2016 at 02:27 AM.
 
Old 08-03-2016, 12:09 PM   #7
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,534

Rep: Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622
root is 500 or 1000
i dual boot with scientificlinux so both are set to 1000
 
Old 08-03-2016, 01:19 PM   #8
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,535

Original Poster
Rep: Reputation: Disabled
Okay, jut to test for buffer-underrun or some such I set MinimumUid=1 -- same problem.

New is, that after logging in with the edited sddm.conf I get a mixture of asian characters, symbols and latin letters. I try to copy that as an example from the console:
Code:
HideUsers=at,audio,퍄,☠딀,틕羕,e,KQ,▒羕▒
I hope this will be displayed in your browser as in mine -- firefox shows it "correct".

Last edited by JZL240I-U; 08-03-2016 at 01:20 PM.
 
Old 08-03-2016, 01:37 PM   #9
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,534

Rep: Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622
try using 500 or 1000 as the min
root IS the very first user so

and system processes use lower id's

systemd is uuid 1
 
Old 08-03-2016, 02:04 PM   #10
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,535

Original Poster
Rep: Reputation: Disabled
I'm trying to enable graphical login for root -- without the whole bunch of daemons cluttering the login window. That is what HideUsers should do...
 
Old 08-03-2016, 03:03 PM   #11
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,534

Rep: Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622Reputation: 2622
Quote:
I'm trying to enable graphical login for root
that will CAUSE problems

kdm blocks that

i take it you are using plasma 5

there is NO text login option any more ( kde4 did have that )
but you can change the target to do a text only boot
then login as root in the terminal and then run "startx " or "kdm"
 
Old 08-04-2016, 09:56 AM   #12
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE Tumbleweed-KDE, Mint 18.3+19.3, MX-18, Mandrake
Posts: 4,535

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by John VV View Post
that will CAUSE problems
It won't. I do that for more than 16 years with never any problem -- and I know the discussion about how dangerous it is deemed. Funny as it seems, I know what I do and why .

Quote:
Originally Posted by John VV View Post
kdm blocks that
No, it won't do that -- since it isn't running anymore, it is sddm now.

Quote:
Originally Posted by John VV View Post
i take it you are using plasma 5
Yes.

Quote:
Originally Posted by John VV View Post
...
but you can change the target to do a text only boot
then login as root in the terminal and then run "startx " or "kdm"
Not necessary. I can already log in as root in graphic mode, it is just that big bunch of daemons bothering me in the login panel, which I want to suppress with the HideUsers= parameter. Doing that results in the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] GUI login for root with sddm on openSUSE Leap42.1 JZL240I-U Linux - Software 7 01-02-2016 04:20 PM
Webcam not found - Lenovo Thinkpad E550 (OpenSuse Leap42.1) gonzovaldez Linux - Desktop 6 01-02-2016 12:33 PM
[SOLVED] where to set to display chinese chinese characters vitalstrike82 Slackware 4 11-17-2012 03:38 AM
Can't open grub.conf/lilo.conf with kate being root cola Slackware 6 09-28-2009 08:26 AM
problem with some Chinese characters shockers_jm Linux - Software 0 03-10-2005 05:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:36 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration