LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-09-2012, 08:43 PM   #1
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Mint 20.1 on workstation, Debian 11 on servers
Posts: 1,207

Rep: Reputation: 49
Kate very choppy


After trying several editors I am liking Kate the most for coding, however I noticed at times it can be very choppy. For example holding down a key such as - to make a long line actually takes a good minute before it reaches the end of the page. In Windows using notepad++ this is a matter of seconds. All my code is on a remote server using NFS so there may be some slight latency, but it was the same when using Windows and it was fine.

I can't seem to find much online when googling given "kate" is actually a common name for a person, so I'm finding nothing having to do with the actual program. Has anyone ever run into this before and is there a way to make it more responsive? I have 12GB of ram, so perhaps a way to force it to load the entire file in ram and only touch the disk when I'm actually saving?

I'm using Xubuntu.
 
Old 08-10-2012, 04:56 PM   #2
jefro
Moderator
 
Registered: Mar 2008
Posts: 21,227

Rep: Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448
I have used Kate off and on for a long time. Never noticed that issue.

You can make a ram drive or ram file system to move your work to and see if that is in fact what the issue is. 12G ought to be enough to make a 4G or so size.
 
Old 08-10-2012, 05:32 PM   #3
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Mint 20.1 on workstation, Debian 11 on servers
Posts: 1,207

Original Poster
Rep: Reputation: 49
I tested it on my SSD and it is indeed disk related. It seems like every single character press is accessing the disk and generating I/O. So the network latency is making it very choppy because it's accessing the network for every single key stroke. Is there a way to stop it from doing that?
 
Old 08-10-2012, 08:32 PM   #4
jefro
Moderator
 
Registered: Mar 2008
Posts: 21,227

Rep: Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448
Boot to a live cd or usb and see if that happens also. How large is this file you are working on?
 
Old 08-10-2012, 09:14 PM   #5
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Mint 20.1 on workstation, Debian 11 on servers
Posts: 1,207

Original Poster
Rep: Reputation: 49
Live CDs don't seem to work well with nvidia cards. They flicker like mad so I want to avoid going through that again, the install process was bad enough. I think I have epilepsy just from going through that LOL.

It does it with any file, even a new file that I create.

If I run tcpdump locally and hold down a key in kate, it generates tons of packets. About 300 packets to make a line that is 100 characters.

It's very brutal when using kate over VPN too. omg. I just hope there's some kind of setting I can turn on/off to stop it from constantly accessing the disk like that. (without having to keep copying files all over)

Last edited by Red Squirrel; 08-10-2012 at 09:29 PM.
 
Old 08-11-2012, 12:42 PM   #6
jefro
Moderator
 
Registered: Mar 2008
Posts: 21,227

Rep: Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448
I just loaded up opensuse on a usb flash and then added in Kate. Worked smoothly. The entire OS and apps worked well.

If it is only kate then maybe uninstall it and then reinstall it.
 
Old 08-11-2012, 01:24 PM   #7
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Mint 20.1 on workstation, Debian 11 on servers
Posts: 1,207

Original Poster
Rep: Reputation: 49
Just figured it out, in the settings under open/save and advanced tab, I clicked the checkbox for "disable swap files syncing". It's no longer trying to write to disk for every character. It's no longer choppy now. I can actually code when a backup job is running.

Last edited by Red Squirrel; 08-11-2012 at 01:30 PM.
 
Old 08-11-2012, 04:53 PM   #8
jefro
Moderator
 
Registered: Mar 2008
Posts: 21,227

Rep: Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448Reputation: 3448
Thanks for the update, good catch. Now I have to go back and look to see what happens on mine.

Mark the post as solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Getting Started With the Kate Text Editor: Kate For Coders LXer Syndicated Linux News 0 04-02-2009 12:40 AM
kate in gnome radiodee1 Linux - Newbie 1 01-05-2007 08:11 AM
Kate and ASCII laserlight Ubuntu 4 07-07-2006 02:47 PM
Kate, I love you! Robhogg General 22 05-07-2006 05:15 PM
Kate Is Not Working, Kate editor is not starting in Redhat 9 apur Linux - General 4 05-11-2004 10:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:29 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration