LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-22-2013, 12:05 AM   #1
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Kubuntu 20.04 on workstation, CentOS 6.x on servers
Posts: 1,206

Rep: Reputation: 49
Kate running really choppy - keeps writing to disk for each character!


I had this problem before and was able to solve it by checking a box to disable file swapping.

https://www.linuxquestions.org/quest...py-4175421313/

However with my new distro (Kubuntu) this option no longer fixes the issue. I can see a huge increase in NFS traffic when I hold down a key with tcpdump running. Local files edit fine, but remote ones are very slow.

Is there a way to stop it from always writing to the file and only write to the file when I actually save? Moving files back and forth is not an option I need to be able to edit directly on the NFS share. Oddly, I have a gigabit link to the server and we're talking KB worth of traffic not even MB so I don't know why it's even slow to begin with.

I'm also open to an alternative editor if there's no way to stop this behavior, but I do like Kate compared to all the other ones I tried.

I also see a .kate-swp file that gets created as soon as I touch a key, so it almost seems like it's not honoring that setting.

Last edited by Red Squirrel; 09-22-2013 at 12:08 AM.
 
Old 09-22-2013, 06:19 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,523

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
open kate
click settings / configure kate
click on the "open / save" option in the left window
click the Advanced tab
put a check in " Disable file swap syncing "
 
Old 09-23-2013, 07:59 PM   #3
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Kubuntu 20.04 on workstation, CentOS 6.x on servers
Posts: 1,206

Original Poster
Rep: Reputation: 49
Yep tried that, that USED to fix the issue, but for some reason in this version (3.10.5) it's not. If I show hidden file I can see the swap file be created as soon as I hit any key.
 
Old 10-19-2013, 04:34 PM   #4
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Kubuntu 20.04 on workstation, CentOS 6.x on servers
Posts: 1,206

Original Poster
Rep: Reputation: 49
Bump, anyone know a fix for this?
 
Old 03-07-2014, 11:44 PM   #5
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Kubuntu 20.04 on workstation, CentOS 6.x on servers
Posts: 1,206

Original Poster
Rep: Reputation: 49
Bump in case anyone happens to know a fix for this. Still an issue. Since I moved to my new file server I don't see the issue as much since it has faster controllers, but if it's bogged down I see the issue. The real problem here is that it should NOT be trying to write to the file server while editing, there is no reason for this, it should only read or write if I click save. It creates a "swap" file despite that option being off. Is there a way I can at least move the location of those swap files locally?

Is there another editor that is as intuitive to use as Kate? This issue is very irritating. I can barely code anything if there's any kind of job going on that's accessing the file server. This is a retarded "feature" especially considering they changed it so the check box to disable it does not disable it anymore. I'm not going to start coping all my files locally back and forth that's a pain in the ass. I use NFS so I can centralize everything and make backups easier.

Last edited by Red Squirrel; 03-08-2014 at 01:30 AM.
 
Old 08-07-2014, 12:20 AM   #6
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Kubuntu 20.04 on workstation, CentOS 6.x on servers
Posts: 1,206

Original Poster
Rep: Reputation: 49
Bump, anyone?

I suppose I can just download the source and fix this myself but a proper solution would be better so I don't have to try to mess with making a custom version integrate with the system. I'll lose any GUI related stuff like having it show up in a list so I can set a file type to open with it by default, and other stuff like that.
 
Old 08-28-2014, 11:34 PM   #7
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Kubuntu 20.04 on workstation, CentOS 6.x on servers
Posts: 1,206

Original Poster
Rep: Reputation: 49
Ended up just switching to Gedit. It's too bad though that such a silly little thing has crippled Kate. Making that checkbox for disabling file syncing actually do what it says it does would fix the issue.
 
Old 11-20-2015, 11:13 PM   #8
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Kubuntu 20.04 on workstation, CentOS 6.x on servers
Posts: 1,206

Original Poster
Rep: Reputation: 49
This is STILL an issue. Why is this not fixed? I can't be the only one that uses NFS to store data and code directly off the share. I tend to work on code related projects on and and off and often find myself giving up because of this, it's completely ridiculous. I have 3 backup jobs running right now on my file server and I can't even code because the disk I/O is crippled (that's another issue I've been fighting with... it should not cripple the I/O that badly). The ability to type in a text editor should not be dependent on disk I/O. That's what ram is for. It should at least store chunks of the open document in ram, but really, for documents in the KB there's no reason why it can't just store it in ram and keep it in ram and work on it in ram.

Is there a way to fix this issue? Like I said before, the option to disable file syncing does not work. I have proven this out with a packet sniffer. Holding down a key generates TONS (100's of pages) of NFS packets.

I cannot find an alternative text editor that is as usable as Kate, the others all have quirks or lack certain features. How do I get into contact with someone to actually get the ball rolling to fix this issue?
 
Old 02-12-2017, 07:07 PM   #9
andrewlorien
LQ Newbie
 
Registered: Jan 2004
Location: sydney .AU
Posts: 25

Rep: Reputation: 15
Update : This is fixed in version 16
And are two new settings: how often to sync, so if you do want a backup but you don't want every keystroke clogging your network, you can just update every x seconds; and sync to a different folder, so if you're working on a remote file you can keep your backup local.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Kate very choppy Red Squirrel Linux - Software 7 08-11-2012 03:53 PM
Writing a file character by character with a bash builtin command (script). stf92 Linux - Newbie 4 06-30-2012 08:41 PM
Writing to tty causes writing to disk? (in ancient 2.2.x kernel) borsburn Linux - Kernel 0 12-17-2008 12:47 PM
Kate - Writing Python programs PEP-8 Phyrexicaid Linux - Software 2 12-08-2008 01:03 PM
error after running kate.. resego Linux - Newbie 1 04-18-2005 11:19 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration