LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-18-2005, 11:46 AM   #1
zirtik
Member
 
Registered: Jul 2005
Posts: 33

Rep: Reputation: 15
K3b writing extremely slow


Hello, I'm using Fedora Core 1 ona a Pentium III 550 mhx cpu with a 256 mb memory. I connect to this machine through network using tightvnc. Actually, this is because this machine doesn't have a monitor.

Now the question is, I tried to burn a dvd-r with k3b today and the speed didn't exceed 0.5 k/s which is extremely slow. Is that because I'm consuming too much cpu power for tigtvnc or do you think I should make some arrengements in order to boost the speed.

I know that the burner is ok cause I've used it on other machines before, any ideas?

Any help will be aprreciated, thanks in advance.
 
Old 10-18-2005, 12:46 PM   #2
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
Did you enable DMA?
 
Old 10-18-2005, 12:48 PM   #3
zirtik
Member
 
Registered: Jul 2005
Posts: 33

Original Poster
Rep: Reputation: 15
I don't know how to enable DMA, can you please tell me?
 
Old 10-18-2005, 06:13 PM   #4
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
... o bother, clicked the wrong button...

Last edited by linmix; 10-18-2005 at 06:17 PM.
 
Old 10-18-2005, 06:15 PM   #5
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
From the xine website:

#

Make sure the hard drive (or cdrom/dvd drive) which supplies the video data is in DMA mode (if supported).

On most linux-based systems, you can use hdparm to check this:

hdparm /dev/hda
[...]
using_dma = 1 (on)
[...]

You can enable DMA mode with the following command:

hdparm -d1 device_of_your_drive_that_supplies_video_data

In some cases where this fails it helps to specify the dma mode to use, for example:

hdparm -d1 -X 66 device_of_your_drive_that_supplies_video_data

In RedHat 8.0 an additional entry in /etc/modules.conf

options ide-cd dma=1

should help (reboot for this change to take effect).

More information about this may be found here: http://oreilly.linux.com/pub/a/linux...29/hdparm.html .
 
Old 10-19-2005, 01:57 PM   #6
zirtik
Member
 
Registered: Jul 2005
Posts: 33

Original Poster
Rep: Reputation: 15
I already have DMA enabled and it's still extremely slow, any more ideas?
 
Old 10-19-2005, 05:34 PM   #7
linmix
Senior Member
 
Registered: Jun 2004
Location: Spain
Distribution: FC5
Posts: 1,993
Blog Entries: 1

Rep: Reputation: 46
There are a number of possible reasons... I have no experience with dvd burning, but the same basic principles apply as with cd-burning.

I had problems writing cds at high speed because k3b thought my drive supported 40X no matter how often I told it it didn't. However, the app itself would tell me it was reducing the burn speed at the beginning of each sesion.

Are you burning data 'as is' or are you compressing it (or decompressing like when you burn an audio cd from mp3 tracks)? Maybe that's where your cdu power goes istead of to the drive. In my case when k3b tried to burn too fast there would be a data lag. Buffer underrun control would kick in, put the cd in 'pause' fill the buffer and start writing again (for at least 2 seconds) resulting in an overall speed of about 2x instead of the announced 32x. The sollution was using 16x speed. That way tere were no buffer underruns and the burn process went smoothly and a lot faster.

I've also found that burning is a lot stabler and more secure when I don't do it 'on the fly', but let k3b make an image file first.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wine extremely slow!!!!!!!!!!!! augu2000 Linux - Software 3 11-01-2005 07:18 PM
OpenGL is extremely slow stonehurstX11 Linux - General 2 05-26-2005 07:33 PM
Writing CD's using k3b too slow..? redrobin77 SUSE / openSUSE 3 12-03-2004 04:23 AM
sdl games are slow extremely slow linksocc Linux - Software 7 01-17-2004 04:53 PM
K3B Extremely Slow Startup K3yMaster Linux - Software 0 10-10-2003 04:00 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration