LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-27-2004, 08:13 PM   #1
w0lv3rin3
Member
 
Registered: Mar 2004
Location: Barrie, ON
Distribution: Slackware 9.1, 10.0, 10.1, 11.0
Posts: 102

Rep: Reputation: 15
k3b problems


when i installed k3b on slackware, then run it, i recieve errors:

w0lv3rin3@darkstar:~$ k3b
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
kbuildsycoca running...
kdecore (KLibLoader): WARNING: library=libk3bflacdecoder: file=/opt/kde/lib/kde3/libk3bflacdecoder.la: libid3-3.8.so.3: cannot open shared object file: No such file or directory
kdecore (KLibLoader): WARNING: library=libk3bmaddecoder: file=/opt/kde/lib/kde3/libk3bmaddecoder.la: libid3-3.8.so.3: cannot open shared object file: No such file or directory
mcop warning: user defined signal handler found for SIG_PIPE, overriding
k3b: WARNING: KGenericFactory: instance requested but no instance name passed to the constructor!
k3b: relocation error: k3b: undefined symbol: _ZN11KMainWindow4showEv

Last edited by w0lv3rin3; 03-27-2004 at 08:16 PM.
 
Old 03-27-2004, 08:18 PM   #2
vi0lat0r
Member
 
Registered: Aug 2003
Location: Lewisville, TX
Distribution: Kubuntu
Posts: 295

Rep: Reputation: 30
What kind of graphics card do you have?
 
Old 03-27-2004, 08:21 PM   #3
w0lv3rin3
Member
 
Registered: Mar 2004
Location: Barrie, ON
Distribution: Slackware 9.1, 10.0, 10.1, 11.0
Posts: 102

Original Poster
Rep: Reputation: 15
Radeon 7000

I did install the fglx drivers

i just had to load the glx in the XFree86Config:
load "glx"

but now i remvoed the glx errors now, i just recieve
w0lv3rin3@darkstar:~$ k3b
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
kbuildsycoca running...
kdecore (KLibLoader): WARNING: library=libk3bflacdecoder: file=/opt/kde/lib/kde3/libk3bflacdecoder.la: libid3-3.8.so.3: cannot open shared object file: No such file or directory
kdecore (KLibLoader): WARNING: library=libk3bmaddecoder: file=/opt/kde/lib/kde3/libk3bmaddecoder.la: libid3-3.8.so.3: cannot open shared object file: No such file or directory
mcop warning: user defined signal handler found for SIG_PIPE, overriding
k3b: WARNING: KGenericFactory: instance requested but no instance name passed to the constructor!
k3b: relocation error: k3b: undefined symbol: _ZN11KMainWindow4showEv
 
Old 03-30-2004, 05:31 AM   #4
zlamma
LQ Newbie
 
Registered: Mar 2004
Location: Poland
Posts: 3

Rep: Reputation: 0
same :P

I get more or less the same errors :P & I got Radeon with fglrx on Slackware 9.1 too
I get the "QPixmap: Cannot create a QPixmap when no GUI is being used" Wonder what's this And sth about constuctor. Anyone knows how to get rid of it?
 
Old 03-30-2004, 10:09 AM   #5
doralsoral
Member
 
Registered: Aug 2003
Location: raleigh
Distribution: Gentoo 2005.1 x86_64
Posts: 931

Rep: Reputation: 31
does k3b start all for you guys? im on slack 9.1 and i get the same qpixmap cant start if no gui is being used or whatever that error is but mine starts and works fine. but i have a geforce 4
 
Old 03-30-2004, 09:55 PM   #6
w0lv3rin3
Member
 
Registered: Mar 2004
Location: Barrie, ON
Distribution: Slackware 9.1, 10.0, 10.1, 11.0
Posts: 102

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by doralsoral
does k3b start all for you guys? im on slack 9.1 and i get the same qpixmap cant start if no gui is being used or whatever that error is but mine starts and works fine. but i have a geforce 4
thats the same issue with me
 
Old 03-31-2004, 12:48 AM   #7
doralsoral
Member
 
Registered: Aug 2003
Location: raleigh
Distribution: Gentoo 2005.1 x86_64
Posts: 931

Rep: Reputation: 31
well if it works then dont worry about it
 
Old 03-31-2004, 01:26 AM   #8
w0lv3rin3
Member
 
Registered: Mar 2004
Location: Barrie, ON
Distribution: Slackware 9.1, 10.0, 10.1, 11.0
Posts: 102

Original Poster
Rep: Reputation: 15
but it doesent
 
Old 03-31-2004, 02:34 AM   #9
Onemessedupjedi
Member
 
Registered: Sep 2003
Location: Oregon
Distribution: Slackware 9.1
Posts: 194

Rep: Reputation: 30
1)k3b is just a front-end, try others since it isn't that great.
2)No, I don't know of any. I use k3b
3)If you actually think it's your video drivers you should boot with the vesa driver and see if it goes.
 
Old 04-09-2004, 07:03 PM   #10
ruipb
LQ Newbie
 
Registered: Aug 2003
Location: Portugal
Distribution: Debian
Posts: 16

Rep: Reputation: 0
I get the same message for Kteatime !!!!

Damn there's go my water for tea again ...
 
Old 04-09-2004, 11:57 PM   #11
w0lv3rin3
Member
 
Registered: Mar 2004
Location: Barrie, ON
Distribution: Slackware 9.1, 10.0, 10.1, 11.0
Posts: 102

Original Poster
Rep: Reputation: 15
I wish some1 had a solution for this problem
 
Old 04-10-2004, 12:30 PM   #12
CBlue
Member
 
Registered: Mar 2004
Location: South Carolina, USA
Distribution: Mepis
Posts: 287

Rep: Reputation: 30
I have Mepis/Debian and KDE 3.2.2 and I use a ATI Radeon 9000 video card. K3b works great for me. Just make sure you have the most up to date cdrecord and associated modules because k3b uses those to run it.
 
Old 04-11-2004, 03:45 AM   #13
w0lv3rin3
Member
 
Registered: Mar 2004
Location: Barrie, ON
Distribution: Slackware 9.1, 10.0, 10.1, 11.0
Posts: 102

Original Poster
Rep: Reputation: 15
hummmm, can u make me a list of required MODULES that k3b uses so I can find it and install the MODULES so k3b can work properly
 
Old 04-11-2004, 07:59 AM   #14
CBlue
Member
 
Registered: Mar 2004
Location: South Carolina, USA
Distribution: Mepis
Posts: 287

Rep: Reputation: 30
Here is the k3b home page/requirements list. Just read this and it will tell you all you need to have and provide links to download the other modules. http://k3b.plainblack.com/index.pl/requirements

Download the optional modules too to give k3b the power to handle more for you.

Last edited by CBlue; 04-11-2004 at 08:02 AM.
 
Old 04-11-2004, 11:49 PM   #15
w0lv3rin3
Member
 
Registered: Mar 2004
Location: Barrie, ON
Distribution: Slackware 9.1, 10.0, 10.1, 11.0
Posts: 102

Original Poster
Rep: Reputation: 15
gunna try it, thx for info
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
2.6.3 + KDE 3.2 + K3b 0.11.4 = PROBLEMS (K3b) svarreby Slackware 2 02-08-2005 10:16 PM
problems installing k3b-mp3 for FC3 and k3b-0.11.18 Rockgod2099 Linux - Software 8 01-09-2005 07:38 PM
K3B problems ksd Slackware 3 01-08-2004 12:23 PM
k3b problems dtheorem Mandriva 1 12-11-2003 01:39 PM
k3b problems the anti-riced Linux - Software 19 06-22-2003 07:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration