LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   k3b only works as root: can't determine size of resulting image file (https://www.linuxquestions.org/questions/linux-software-2/k3b-only-works-as-root-cant-determine-size-of-resulting-image-file-298452/)

c-- 03-06-2005 06:04 PM

k3b only works as root: can't determine size of resulting image file
 
I'm running k3b 0.11.18 on ubuntu warty warthog and can't get it to work. If I run it as root, it can burn just fine, but if I run it from my user, when I go to burn it says "cannot determine size of resulting image file". Ive found posts about this here, but none of them are very helpful. It has to be a permission problem, but I've checked and I have rw access to both my drives. I can burn cds and dvds just fine from root, but not my account.

This is driving me crazy, thanks in advance to anyone who can tell me whats going on.

Wartz 03-06-2005 06:11 PM

I changed my fstab to read

Code:

/dev/cdrom      /mnt/cdrom      iso9660    noauto,user,ro  0  0
from
Code:

/dev/cdrom      /mnt/cdrom      iso9660    noauto,owner,ro  0  0
when I had a problem similar to yours. Seemed to work.

If you have done that already, maybe you didnt setup k3b properly.

c-- 03-06-2005 06:17 PM

I tried that and it didn't seem to make any difference. It works fine as root, so it has to be something permission related. is there anything other than the cd drives themselves that k3b needs access to? does anyone have a link to a good tutorial on k3b? I just apt-got it and ran the setup, should there have been more to it than that?

Not now, John! 03-07-2005 02:50 PM

Have you run k3bsetup?
Are you a member of burning group?

c-- 03-07-2005 08:13 PM

Quote:

I just apt-got it and ran the setup, should there have been more to it than that?
so yes, I have run the setup program (k3bsetup).

I just changed my config using k3bsetup to "use burning group" and created/added myself to the group burning, and now when I try to burn from my user, it just crashes and I get the kde error about how my computer exploded or whatever.

It still works fine when run as root.

Any ideas people? whats the difference between running it as root and my user? what does it need access to?

c-- 03-07-2005 08:28 PM

when it crashes it says the program had a signal 11 sigsegv and gives me this, which it says is useless.... does it at least contain some clue where to start?
Code:

This backtrace appears to be useless.
This is probably because your packages are built in a way which prevents creating of proper backtraces, or the stack frame was seriously corrupted in the crash.

(no debugging symbols found)...Using host libthread_db library "/lib/tls/i686/cmov/libthread_db.so.1".
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(n debugging symbols found)...(no debugging symbols found)...[Thread debugging using libthread_db enabled]
[New Thread 1110195552 (LWP 829)]
(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...(no debugging symbols found)...0xffffe410 in __kernel_vsyscall ()
#0  0xffffe410 in __kernel_vsyscall ()
#1  0x418c3403 in __waitpid_nocancel () from /lib/tls/i686/cmov/libpthread.so.0
#2  0x40ee58cc in KCrash::defaultCrashHandler () from /usr/lib/libkdecore.so.4
#3  <signal handler called>
#4  0x40712082 in K3bWriterSelectionWidget::slotRefreshWriterSpeeds ()
  from /usr/lib/libk3bproject.so.2
#5  0x40711b92 in K3bWriterSelectionWidget::init ()
  from /usr/lib/libk3bproject.so.2
#6  0x407117bb in K3bWriterSelectionWidget::K3bWriterSelectionWidget ()
  from /usr/lib/libk3bproject.so.2
#7  0x40721e8e in K3bProjectBurnDialog::prepareGui ()
  from /usr/lib/libk3bproject.so.2
#8  0x4073d336 in K3bDataBurnDialog::K3bDataBurnDialog ()
  from /usr/lib/libk3bproject.so.2
#9  0x4074efeb in K3bDataDoc::newBurnDialog () from /usr/lib/libk3bproject.so.2
#10 0x4074f0f5 in K3bDataDoc::slotBurn () from /usr/lib/libk3bproject.so.2
#11 0x4074f3b3 in K3bDataDoc::qt_invoke () from /usr/lib/libk3bproject.so.2
#12 0x4129faf1 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#13 0x4129f938 in QObject::activate_signal () from /usr/lib/libqt-mt.so.3
#14 0x415ac476 in QButton::clicked () from /usr/lib/libqt-mt.so.3
#15 0x41329b84 in QButton::mouseReleaseEvent () from /usr/lib/libqt-mt.so.3
#16 0x412d2959 in QWidget::event () from /usr/lib/libqt-mt.so.3
#17 0x41248454 in QApplication::internalNotify () from /usr/lib/libqt-mt.so.3
#18 0x41247bab in QApplication::notify () from /usr/lib/libqt-mt.so.3
#19 0x40e64e72 in KApplication::notify () from /usr/lib/libkdecore.so.4
#20 0x411e362d in QETWidget::translateMouseEvent () from /usr/lib/libqt-mt.so.3
#21 0x411e0f5b in QApplication::x11ProcessEvent () from /usr/lib/libqt-mt.so.3
#22 0x411f6612 in QEventLoop::processEvents () from /usr/lib/libqt-mt.so.3
#23 0x4125ae04 in QEventLoop::enterLoop () from /usr/lib/libqt-mt.so.3
#24 0x4125acc6 in QEventLoop::exec () from /usr/lib/libqt-mt.so.3
#25 0x4124865f in QApplication::exec () from /usr/lib/libqt-mt.so.3
#26 0x080a15cb in QPtrList<K3bPluginFactory>::deleteItem ()
#27 0x41aaa7b6 in __libc_start_main () from /lib/tls/i686/cmov/libc.so.6
#28 0x41bc4edc in ?? () from /lib/tls/i686/cmov/libc.so.6

also, when I run it from the command line, I get lots of errors about missing icons, but I get that when I run it as root and it works too. This is the output when I start it from root, but matches what I get when I run it from my user
Code:

kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 36x36/stock/form not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 36x36/stock/generic not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 36x36/stock/image not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 36x36/stock/io not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 36x36/stock/media not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 36x36/stock/navigation not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 36x36/stock/net not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 36x36/stock/object not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 36x36/stock/table not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 36x36/stock/text not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 48x48/stock/chart not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 48x48/stock/code not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 48x48/stock/data not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 48x48/stock/document not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 48x48/stock/form not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 48x48/stock/generic not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 48x48/stock/image not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 48x48/stock/io not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 48x48/stock/media not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 48x48/stock/navigation not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 48x48/stock/net not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 48x48/stock/object not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 48x48/stock/table not valid.
kdecore (KIconLoader): WARNING: Icon directory /usr/share/icons/hicolor/ group 48x48/stock/text not valid.
k3b: WARNING: KGenericFactory: instance requested but no instance name passed to the constructor!



All times are GMT -5. The time now is 11:50 AM.