LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 02-01-2008, 06:12 AM   #1
boney-
LQ Newbie
 
Registered: Jan 2008
Posts: 5

Rep: Reputation: 0
Join linux machine to windows AD - help


Hi,

Im trying to join my linuxmachine to windows AD.

I've joined the AD so far, and can list users and groups with:
wbinfo -u and wbinfo -g.

However wbinfo -a user%password does not work, i get the following:

Code:
plaintext password authentication failed
error code was NT_STATUS_NO SUCH_USER (0x0000064)
error message was: No such user
Could not authenticate user user%password with plaintext password
challenge/respone password authentication succeeded
and when i do gentent passwd i only get the local users and not the ones that are member of the domain.

Any help appreciated!

// boney
 
Old 02-01-2008, 11:13 PM   #2
waelaltaqi
Member
 
Registered: Sep 2005
Location: USA, TN
Distribution: CentOS & Ubuntu for Desktop
Posts: 454

Rep: Reputation: 31
i'm not sure what you setup but you probably need to change the authentication method from plain text to NTLM or Kerberous
 
Old 02-02-2008, 12:14 AM   #3
Doug52392
Member
 
Registered: Jul 2007
Distribution: Fedora 7, Ubuntu 7.04
Posts: 34

Rep: Reputation: 15
I've gotten similar error messages trying to get Fedora Linux and OpenSuSE Linux to join Windows Server 2008 domains. I'm still trying to figure out why it won't work though.
 
Old 02-04-2008, 04:04 AM   #4
boney-
LQ Newbie
 
Registered: Jan 2008
Posts: 5

Original Poster
Rep: Reputation: 0
solved it by using wbinfo -a MYDOMAIN\\user%password.


Ive done the kinit administrator@MYDOMAIN.SE and verifyed it with klist (i have a ticket)

And ive also joined the domain (net ads join -U administrator@MYDOMAIN.SE)
which worked fine.

wbinfo -u, wbinfo -g, wbinfo -t, wbinfo a MYDOMAIN\\user%password works fine.

but getent passwd shows the local users.

Any help on this is greatly appreciated

// boney
 
Old 02-04-2008, 06:34 AM   #5
boney-
LQ Newbie
 
Registered: Jan 2008
Posts: 5

Original Poster
Rep: Reputation: 0
solved

add: winbind use default domain = yes smb.conf and it all works fine.
after i edited a few pam modules i could succesfuly ssh to my linuxmachine using my windows account information.

//boney
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to join fc6 machine to windows server 2003 domain vikram_shiva2006 Linux - Server 1 08-25-2007 11:16 AM
Windows virtual machine can't join domain using bridging on Linux host (RPC failed) bgottesman Linux - Networking 0 07-10-2007 06:09 PM
How a linux machine join Microsoft Active Directory mskingdom Linux - Networking 2 11-06-2006 03:05 PM
Join Multicast group from Linux machine. vineeth_thampi Linux - Networking 0 01-02-2006 07:53 AM
Join W2K machine to Linux domain mediocrity Linux - Networking 3 04-03-2005 12:44 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:49 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration