-   Linux - Software (
-   -   Jetbrowser not starting missing '/opt/webarena/Browser-icon.png' (

moises 01-15-2013 11:51 AM

Jetbrowser not starting missing '/opt/webarena/Browser-icon.png'
I did this:

Added rpm-sphere.repo to /yum.repos.d:


name=RPM Sphere

And updated it in terminal.

Then I did this:


su -c 'yum install jetbrowser'
It installed with no problems.

When go to Applications>Internet>Jetbrowser nothing happens.

I enter jetbrowser in terminal and get this:


~]$ jetbrowser
Welcome and thank you for downloading and using JetBrowser       
You will soon be prompted to the welcome screen, where you       
can find out more about JetBrowser and what you can do with       
it. The web is fun, let's keep it that way.                       
No given arguments...
Going to homepage.
Traceback (most recent call last):
  File "./webarena", line 1102, in <module>
    webbrowser = WebBrowser()
  File "./webarena", line 844, in __init__
glib.GError: Failed to open file '/opt/webarena/Browser-icon.png': No such file or directory

I tried to install again, but got this:


~]$ su -c 'yum install jetbrowser'
Loaded plugins: langpacks, presto, refresh-packagekit
Package jetbrowser-6.0.425-2.2.noarch already installed and latest version
Nothing to do
[moises@dandy ~]$

I browse to /opt and is empty no hidden files either.

goggle, duckduckgo don't give me any other ideas, help, tutorials than those mentioned above.

knudfl 01-15-2013 04:24 PM

There are some "///opt/" in the "source" package scripts.
( The "source" actually looks like a binary package.
> jetbrowser-6.0.425-2.2.src.rpm ).

A quick fix to provide the required files :
1) # mkdir -p /opt/webarena/modules/newtab
2) # cp /usr/share/webarena/images/Browser-icon.png /opt/webarena/
3) # cp /usr/share/webarena/aboutpage.html /opt/webarena/
4) # cp /usr/share/webarena/modules/newtab/webkitpage.html /opt/webarena/modules/newtab/
5) # chmod 0755 /opt/webarena/modules/newtab/webkitpage.html
6) .... There are a couple more missing "/opt files" : To use the Apps buttons.

( This command will show all jetbrowser files : $ rpm -ql jetbrowser ).


moises 01-16-2013 07:46 AM

thank you knudfl,

Just tried your suggestions and here I am using Jetbrowser to reply. I will make an attempt to browser through all the folders listed with "rpm -ql jetbrowser" to see if I can find the missing buttons. Now all I have is "add tab", "refresh", "editor" and "about" And, of course, the address bar.

By the way, I visited Copenhagen a long time ago and I love it. That city is beautiful.

knudfl 01-16-2013 08:55 AM


I will make an attempt to browser through all the folders listed
with "rpm -ql jetbrowser" to see if I can find the missing buttons.
Actually no buttons are missing, but their connected files.
Buttons : a) YouTube, b) Twitter, c) Maps

a) Asks for : /opt/webarena/modules/core/support/apps/youtube/index.html
b) /opt/webarena/modules/core/lib/layout/list/twitter/index.html
c) /opt/webarena/modules/core/lib/onyx/examples/Maps/index.html


moises 01-16-2013 10:26 AM

I see, those are all links located on the "new tab" window. Once again, thanks knudfl. I will mark this thread as closed.


All times are GMT -5. The time now is 09:26 PM.