LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-17-2009, 11:25 AM   #1
java_ascii
LQ Newbie
 
Registered: Sep 2009
Posts: 2
Blog Entries: 1

Rep: Reputation: 0
jdk1.5.0_08 install - can not execute binary file - x86_64 versus ia64


I have java jdk1.5.0_08 installed on linux x86_64 architecture and I can execute java -version no problem.

I took the same binaries and installed on ia64 architecture and the command java -version gives and error "cannot execute binary file"

The Linux OS versions are 2.6.18-128.1.10.el5 on x86_64 and 2.6.18-128.4.1.el5 on ia64

Do you know whether the jdk1.5.0_08 binaries are compatible between x86_64 and ia64 architecture. The answer may be no, but I may be wrong and there could be some other issue.

Thanks for your response.

Where can I get the jdk1.5.0_08 specific to ia64 architecture for Linux version 2.6.18-128.4.1.e15

Thanks again

Last edited by java_ascii; 09-17-2009 at 12:41 PM. Reason: updated to get download info
 
Old 09-17-2009, 11:52 AM   #2
lutusp
Member
 
Registered: Sep 2009
Distribution: Fedora
Posts: 835

Rep: Reputation: 102Reputation: 102
Quote:
Originally Posted by java_ascii View Post
I have java jdk1.5.0_08 installed on linux x86_64 architecture and I can execute java -version no problem.

I took the same binaries and installed on ia64 architecture and the command java -version gives and error "cannot execute binary file"

The Linux OS versions are 2.6.18-128.1.10.el5 on x86_64 and 2.6.18-128.4.1.el5 on ia64

Do you know whether the jdk1.5.0_08 binaries are compatible between x86_64 and ia64 architecture. The answer may be no, but I may be wrong and there could be some other issue.

Thanks for your response.
Have you considered acquiring the correct binaries for the target platform? They exist, it is a matter of installing them.

Code:
I took the same binaries and installed on ia64 architecture and the command java -version gives and error "cannot execute binary file"
For some reason, the wheels off my Mack truck won't fit on my bicycle. I intend to complain.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't execute binary install file... djbon2112 Linux - Software 5 01-29-2009 07:08 PM
Is Posible Install Enterprise Red Hat 4.6 (X86_64) on Itanium (ia64)? fsoteloh Linux - Software 3 12-31-2008 12:35 PM
/jdk1.5.0_11/bin/java: cannot execute binary file philosophia Programming 3 12-20-2007 09:20 AM
"cannot execute binary file" when install j2sdk jin007 Linux - Software 3 06-27-2005 02:05 PM
Cannot execute binary file pbagda Linux - General 4 01-19-2004 01:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration