LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   jdk 1.3.1_06 not working in mandrake 9.2 (https://www.linuxquestions.org/questions/linux-software-2/jdk-1-3-1_06-not-working-in-mandrake-9-2-a-124342/)

zho40 12-09-2003 04:14 PM

jdk 1.3.1_06 not working in mandrake 9.2
 
I'm trying to install two different versions of jdk 1.4.1 which works and 1.3.1_06 which gives me an error on the most basic command java -version. I know both the rpms are good because I installed the same ones on a box I have running SuSE and everything works fine. If I do a java -version in the /usr/java/jdk1.3.1_06/bin dir i get the /usr/java/jdk1.3.1_06/bin/i386/native_threads/jav following: a: error while loading shared libraries: libstdc -libc6.1-1.so.2: cannot open shared object file: No such file or directory
Any help would be great.

sirpelidor 12-09-2003 04:26 PM

do you have both 1.3.1 and 1.4 in the system? because java needs you uninstall the older verson ....

2 version of java shouldn't be appear on the same system.
if you got 1.4 running, you shouldn't need to install 1.3.1 (is it because u try to learn j2ee, jsp and servelt? and the book recommand you use 1.3?)

1.4 has all the function that is needed, if you want to do jsp, servlets , etc. just go ahead and get tomcat. delete 1.3 if u got 1.4

regard,

lazat 12-14-2003 10:00 AM

I can't run java -version. PAX is killing it.
WHY and how can I get it to work?

sirpelidor 12-14-2003 12:49 PM

Quote:

Originally posted by lazat
I can't run java -version. PAX is killing it.
WHY and how can I get it to work?




are there's error msg? what verson java u got? where u downloaded? how u installed? .... there can be alot of things go wrong if u don't have detail...

lazat 12-15-2003 12:09 PM

I fund a good FAQ. I try to follow it first.
othervise i will be back with the anwnsers.


All times are GMT -5. The time now is 02:14 PM.