-   Linux - Software (
-   -   Java Virtual Machine ? J2re? installation & plug in trouble (

moridon77 06-18-2004 02:01 PM

Java Virtual Machine ? J2re? installation & plug in trouble
I i pretty new to linux i think i may be going on my 4th month. the distro i will be using the answers to these questions in application too are mandrake 10 official.

i have gone here to get Java. i have also successfully installed this version of java on my machine. the file i ended up downloading and installing was titled j2re-1_4_2_04-linux-i586.bin . My difficulty now lies in the fact that i cant get this to enable and configure (as per the directions listed on the earlier website). i either must get this to enable and work globally or this isnt the Jave Virtual Machine i should have downloaded in the first place. i say this because the reason i am working on java is to install LimeWire. and each time i try and install LimeWire my terminal tells me there are no VM's on my machine.

So my questions are
#1 is this file i have installed but not enabled the right java to allow the functioning and installation of LimeWire?
#2 if this isnt the correct file but is another reasonably up to date installation of Java will i be able to keep this and get it working in addition to the JVM without conflict?
#3 if this is the incorrect file where can i get the right Java Virtual Machine? and of course i am going to need the directions that come with it (this is of course only if it isnt located somewhere on the site the actual software is located).
#4 finally if this is the correct file then all i need to know is how to get it enabled and working. my difficulty with this seems to lie in the fact that i dont quite understand the linux file system yet and thus am not sure about its working in relation to the directions from the site i downloaded the forementioned site.

thanks for reading this and i hope you guys have the answers.

aaa 06-18-2004 02:11 PM

Type 'java' in a terminal and see what happens. If you get 'command not found, you will need to inlcude the java directory in the PATH:
export PATH=/path/to/java

moridon77 06-18-2004 02:21 PM

i have now typed java into my terminal. it did say command not found. now could i impose to get you to break down the rest of what you said into a more detailed explanation please?


aaa 06-18-2004 02:35 PM

Where'd you install the Java? As what user?

moridon77 06-18-2004 02:57 PM

file:/home/necrosaber/j2re1.4.2_04 java is installed here. this is also the home directory of the user. (i am currently testing variations of the previous command with this path included maybe i'll strike upon it).

thankx .....again

aaa 06-18-2004 03:01 PM

export PATH=/home/necrosaber/j2re1.4.2_04/bin

Edit: see this link on the PATH:

moridon77 06-18-2004 03:15 PM

from that i get the following

[necrosaber@localhost necrosaber]$ export PATH=/home/necrosaber/j2re1.4.2_04/bin
[necrosaber@localhost necrosaber]$ java
Usage: java [-options] class [args...]
(to execute a class)
or java [-options] -jar jarfile [args...]
(to execute a jar file)

where options include:
-client to select the "client" VM
-server to select the "server" VM
-hotspot is a synonym for the "client" VM [deprecated]
The default VM is client.

-cp <class search path of directories and zip/jar files>
-classpath <class search path of directories and zip/jar files>
A : separated list of directories, JAR archives,
and ZIP archives to search for class files.
set a system property
enable verbose output
-version print product version and exit
-showversion print product version and continue
-? -help print this help message
-X print help on non-standard options
enable assertions
disable assertions
-esa | -enablesystemassertions
enable system assertion
-dsa | -disablesystemassertions
disable system assertions

this is more than i have gotten before. with anything in any of the combinations i have tried it. however as soon as i close the terminal this is in it goes back to normal (assuming i actually changed anything by doing this). another possible failure i have just noticed is i may have opened this terminal in the incorrect location for this export. i have now tried it in 4 different locations and each get the same results. i think my failure here is the same one i thought it was, i dont really understand the linux file system yet.

aaa 06-18-2004 03:20 PM

see the link posted for how to make it permanent.

moridon77 06-18-2004 03:52 PM

i have read and reread what that was saying. i dont get it!

what i am understanding is that i am suposed to create a file called ~/.bashrc in the home directory or in the directory java was installed in? is this just a text file? is anything specific supposed to be in this text file or is simply naming it that name good enough? or am i completely on the wrong track as i now have text files by that name is both locations and nothing happened.

mrcheeks 06-18-2004 06:12 PM

look at this tutorial

moridon77 06-18-2004 07:52 PM

this looks very promising. now how when logged in as the non root user do i get permission to insert or create these files in place. even in the event this fails to solve my problems here this was a useful tutorial, i have learned more from it so thanks.

so any idea how to create in place or create the file in a folder the user has permissions for and move into a root only access folder?

moridon77 06-19-2004 04:20 PM

i spent the entire night and now most of today working on this issue and haven't for any real purpose or effect solved anything. i can see that i did install the SDK version as root. however i am not even sure root can use it but i do know my user cant. my user doesn't seem to have permission to do anything to any directory but the home directory of said user. and logging in as root and then installing the SDK didn't allow the user to have access to it or use the program. also under the tutorial i followed from the previous link it gave directiong to uninstall the Kaffe. this program doesnt even show up no matter where i open the terminal, and doesnt register or uninstall. i have tried this also when logged in as root, and tried it by modifying the command to test it on the J2RE instead of just kaffe. in both cases on both user and root my effect is that the package doesnt exsist. then last difficulty was in the last command from the tutorial when it states that i should then install it as root with the said command. this failed. now this may have failed because i got a GUI type installer that opened up once i executed the file from the previos direction in the tutorial.

so there is where i stand, still no java!
so if anyone knowws anything please let me know.

moridon77 06-19-2004 10:04 PM

maybe if i could actually get permission as my user and didnt have to log in as root to do everything?

ExoZagNoid 06-20-2004 01:40 AM

Looks like java is installed properly. All you need to do is make the path permanent for your user. You shouldn't have to mess around as root.

.bashrc is a hidden file (files beginning with a period are hidden) that might already be in your users HOME directory. When you're in a terminal, in your home directory, type 'ls -a' and it should show you ALL the files there. If it's already there (probably is), open it and add this line from the link.

export PATH=$PATH:/home/necrosaber/j2re1.4.2_04/bin

BTW, there is an option in most file managers to display hidden files or not. In Konqueror it's under the "View" menu.


moridon77 06-20-2004 02:19 PM

Wow and thanks allot!!! i can't believe it was that simple. I did change the command a little to this :
export PATH=$PATH:/home/necrosaber/j2sdk-1_4_2_04
But that was easy to figure out due to my having change which installation i was going to use. Though i do have both installed now and whatever was the default installed Java that came with Mandrake 10. Next mission for me is to figure out how to uninstall them.

i totally apreciate the help so thanks again to everyone who has helped!!

All times are GMT -5. The time now is 07:07 PM.