LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Java SDK in Fedora Core 3 (64 bit) (https://www.linuxquestions.org/questions/linux-software-2/java-sdk-in-fedora-core-3-64-bit-263877/)

uphu 12-07-2004 11:11 PM

Java SDK in Fedora Core 3 (64 bit)
 
Ok, I'm running on an AMD 64 so to install the java sdk I downloaded j2sdk-1_4_2_06-linux-ia64-rpm.bin. Next, I followed the instuctions located here: http://java.sun.com/products/archive...ml#install-pkg

This is what my terminal looked like:

Code:

[uphu@localhost ~]$ chmod a+x j2sdk-1_4_2_06-linux-ia64-rpm.bin
[uphu@localhost ~]$ ./j2sdk-1_4_2_06-linux-ia64-rpm.bin
              Sun Microsystems, Inc.
          Binary Code License Agreement
[agreement here, blah blah blah]
Do you agree to the above license terms? [yes or no]
yes
Unpacking...
Checksumming...
0
0
Extracting...
./j2sdk-1_4_2_06-linux-ia64-rpm.bin: line 370: ./install.sfx.3913: cannot execute binary file
Done.
[uphu@localhost ~]$

So any ideas whats wrong?

uphu 12-08-2004 06:51 AM

...um, no one knows?

dr_zayus69 12-08-2004 07:03 AM

did you try doing it as root?

uphu 12-08-2004 03:16 PM

Yes, and I tried doing it in the directory its located too. Its always the same result.

csfalcon 12-08-2004 03:45 PM

do it as root as in you login as a super user. do

Code:

su -
it will ask for you root password, after that you prompt will turn to "#" instead of "$". And then try installing JDK again.

Use this as a reference: http://www.csfalcon.com/wiki/csfalcon/JavaSDK

uphu 12-08-2004 03:54 PM

Yes, I already did that and it gives the same error.

rhimbo 12-08-2004 05:24 PM

Might be a permissions probelem
 
Hi,
I had this problem and it was a permissions problem. After I solved the permissions problem, I still had the same error.
The second time it turned out to be that I had the i386 .bin archive file instead of the amd64 .bin file. I was installing remotely on an AMD Opteron 64-bit SMP server (and didn't know it at the time). :-)
I fetched the correct version from the developer.sun.com web site and it all deflated perfectly.

uphu 12-08-2004 05:47 PM

Well, its funny because I'm running on an AMD 64 but I cannot install the ia64 while I can, and have in the past, installed i586. The problem then was that I couldn't install bluej. It was a .jar and I typed

Code:

java -jar bluej*.jar
...and there was some error.

when you say the the amd64 .bin file you mean is64 .bin, right?

Edit: Nevermind I got it all working. I installed the wrong one. Apparently they don't have a 1.4.2 for AMD 64's so I had to get JDK 1.5.0 for AMD 64


All times are GMT -5. The time now is 05:17 PM.