-   Linux - Software (
-   -   java in slackware 12.2 (

ghartl1 01-02-2009 01:52 PM

java in slackware 12.2
i use slackware 12.2 on a notebook (T42)

i already posted the problem in a german forum...

so far no solution..

maybe i have more luck here around.
to make it short....firefox (seamonkey as well)doesnt show me content of the following site..

try for registration necessary..>spiel auswählen>american roulette>öffentlicher tisch>
just click on a the java machine should start...after 2 seconds the window disappears and a white screen is there instead..

i also use "about:plugins" there is my java machine recognized as my flashplayerplugin too..

also installed no avail

so i use now vectorlinux..there it is no problenm to view the site..

otherwise i love slackware...
so maybe there is a workaround available somewhere...

thanks for your time and efforts in advance

greets günter

XavierP 01-02-2009 02:00 PM

Which version of Java do you have installed (open a terminal and type "java -version" minus the quotes). It works fine for me.

SqdnGuns 01-02-2009 04:36 PM

Did you do a fresh 12.2 install or an upgrade?

ghartl1 01-02-2009 05:57 PM


i did an fresh install

i know tht in other distris this issue works fine..except in slackware (same in 11 and 12.0, 12.1..)

@xavierp: does it work on your slackware box??i mean
the site ""
if yes..what have you done

to get me videos and other stuff works
great with flashplayer too
the only issue ist this one gamingsite...
try for yourself...with slackware

btw: java machne is the default with slackware 12.2..
i am not sitting in front of a slackwarebox now...

but i recall the version of 1.6. whatever..
looked up in "about: plugins" in firefox

btw: i did a full install...

any hints..

regards günter

XavierP 01-02-2009 06:56 PM

I'm currently on Debian Lenny - I don't think I've had Slackware running on this laptop before and I want to make sure I have the time and energy to pick up on any "gotchas" that Dell might have for me :)

Can you run us through the steps you took to install? Which file did you symlink to the plugin folder?

ghartl1 01-02-2009 07:33 PM

Can you run us through the steps you took to install? Which file did you symlink to the plugin folder?

hmmm..usually its not necessary to symlink anythink...
i dont know now where java is stored in slackware...because i am right now sitting in front of a vector-box..

i did an normal full install...

then i installed adobe flashplayer(automatically installs in mozilla directory in home...

firefox recognice the java machine...

but thats for sure: neither in 11,12, or 12.1 this site worked..(a friend of mine tried with his 11 slack too..

knudfl 01-03-2009 06:06 AM

1) How about providing a link to the site :
">spiel auswählen>american roulette>öffentlicher tisch> "
This line gives no result, also not with http:// written
into the text.
EDIT..this is it

2) Some sites use "odd javascript" , then try the
'Opera browser' , might work.

XavierP 01-03-2009 10:00 AM

The "spiel auswählen" bit is a drop down menu to the right of the page. Then select American Roulette from the list.

knudfl 01-03-2009 02:38 PM

I think you need as well flashplayer as javaplugin.

install_flash_player_10_linux.tar.gz > install_flash_player_10_linux
and install to /usr/lib/firefox-3.0.4

# ln -s /usr/lib/java/plugin/i386/ns7/ \
/usr/lib/firefox-3.0.4/plugins ( There isn't made any link by default )

> > Then I have a working roulette table in Slackware 12.2

ghartl1 01-03-2009 06:50 PM

doesnt work...

häf ä nais dei-$ ls -l
total 9828
drwxr-xr-x 14 root root 4096 2008-11-15 00:24 ..
-rwxr-xr-x 1 root root 15792 2008-10-30 05:25
lrwxrwxrwx 1 root root 50 2009-01-04 00:13 -> /usr/lib/java/plugin/i386/ns7/

häf ä nais dei-$ ls -l
total 148
drwxr-xr-x 4 root root 4096 2008-11-10 12:41 ..
-rwxr-xr-x 1 root root 137021 2008-11-10 10:59
drwxr-xr-x 2 root root 4096 2008-11-10 12:41 .
zerst denkn,dann tippn-# ls -l
total 9798
drwxr-xr-x 2 wachbirn users 128 2009-01-04 00:54 .
drwx------ 5 wachbirn users 128 2009-01-04 00:20 ..
lrwxrwxrwx 1 root root 50 2009-01-04 00:54 -> /usr/lib/java/plugin/i386/ns7/
-rwxr-xr-x 1 wachbirn users 10022452 2009-01-04 00:20

do you have any another plugins installed?

XavierP 01-03-2009 07:53 PM

I find the best way to install Flash is to install to /usr/lib/firefox as that is a symlink to whichever your current version is. If you install to the current version's folders you have to move the plugins when you update. Installing to the symlinked folder means that the plugins follow the installs.

So my plugin directory is:

spinelli:~$ cd /usr/lib/firefox/plugins/
ray@spinelli:/usr/lib/firefox/plugins$ ls -l
total 12500
-rwxr-xr-x 1 root root 10022452 2009-01-03 15:10*
-rwxr-xr-x 1 root root    15792 2008-12-02 06:07*
-rwxr-xr-x 1 root root  541313 2009-01-03 16:54*
-rwxr-xr-x 1 root root  541537 2009-01-03 16:54*
-rwxr-xr-x 1 root root  541609 2009-01-03 16:54*
-rwxr-xr-x 1 root root  541889 2009-01-03 16:54*
-rwxr-xr-x 1 root root  543265 2009-01-03 16:54*

knudfl 01-03-2009 08:31 PM

# 10 . No, I have the same 3. Make sure that Firefox 3.0.4
is the version, you are using. See # 11.

ghartl1 01-03-2009 09:01 PM

i use firefox 3.0.4

default in slackware

i also have the mplayerplugins installed...
but it doesnt work...

all the files are correct linked..

and you have full access to this site (win2day...gamingtable)??

after 2 seconds the flashmachine turns off and leaves a white frame behind...

headscratch...i run out of options..

XavierP 01-04-2009 08:15 AM

Works fine for me - the Java is the Java that is installed by Slackware during the OS installation. No extra tweaking or configuring required.

ghartl1 01-04-2009 05:16 PM

what a pity...

i installed 3.0.5 firefox with the same result...

all plugins are recognices from firefox...
links are set..

but java doesnt start...

All times are GMT -5. The time now is 01:45 PM.