LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   java (https://www.linuxquestions.org/questions/linux-software-2/java-105616/)

only1gameguru 10-18-2003 01:40 PM

java
 
i have mandrake 9.1 and i am having a real hard time installing java help me plz

megaspaz 10-18-2003 01:57 PM

http://java.sun.com/j2se/1.4.2/download.html

did you download the right package? try grabbing this one: "Linux RPM in self-extracting file". also decide whether you want to start learning how to write java programs or not. if so, grab the SDK package. if not grab the JRE package.

the file is a .bin file, so you'll have to extract it from the command line. open up a shell terminal and use the 'cd' command to navigate to where you downloaded the *.bin file and use this command:

./*.bin

use that only if you know for sure that's the only .bin file in the current directory. else use the whole filename.

an rpm will be extracted from that .bin file. just click on the rpm to install it. then you'll want to add java to your path. i use pathmunge in /etc/profile to make the path global.

Code:

# Path manipulation
if [ `id -u` = 0 ]; then
        pathmunge /sbin
        pathmunge /usr/sbin
        pathmunge /usr/local/sbin
fi

pathmunge /usr/X11R6/bin after

JAVA_HOME=/usr/java/j2sdk1.4.2_01
pathmunge $JAVA_HOME/bin after
export JAVA_HOME

it's the last 3 lines you want to insert into /etc/profile. also change j2sdk1.4.2_01 to whatever the folder name is in /usr/java if using the JRE package.

then you'll need to create a link to the java plugin in all your browser's plugins folder. you can use the command line as root. i don't use the jre package so i don't know what the full correct path is to the java plugin for the JRE package. you'll have to dig around in your java install. all i know is the last part of the file path should be:
...../plugin/i386/ns610-gcc32/libjavaplugin_oji.so

only1gameguru 10-23-2003 04:12 PM

ah... i followed what was said above (to the word) and well at the
"./*.bin"
part i this
"bash: ./j2sdk-1_4_2_02-linux-i586-rpm.bin: Permission denied"
what do i do a bout that

Nimoy 10-23-2003 04:55 PM

To the word... sure about being root??? - the permission thing sounds fishy

Redbone981sl 10-23-2003 05:13 PM

The user that downloaded the file has to do a chmod 777 (file name) then you should be able to install.

only1gameguru 10-23-2003 06:18 PM

that worked thank you Redbone981sl

codec 10-23-2003 07:52 PM

remember to link this file to mozilla plugin directory:

/usr/java/j2re1.4.2_01/plugin/i386/ns610-gcc32/libjavaplugin_oji.so

only1gameguru 10-24-2003 07:51 PM

thanks but how would i get it into opera that file path doesnt work with opera

megaspaz 10-24-2003 08:23 PM

in opera you set the path in File > Preferences > Multimedia. set the path in the Java path text box underneath the Enable Java button. but the path to the java plugin is not used by opera and will not validate. try a path like this:

/usr/java/j2re1.4.2_01/lib/i386

only1gameguru 10-25-2003 02:09 PM

that did not work either hmm...

does the opera require the java SDK or JRE and if JRE is required it tells me that "bash: {insertname}: Permission denied

chmod777 (filename) worked with SDK but not JRE

megaspaz 10-25-2003 02:13 PM

what version of opera? the version 7's have a browse button where you can specify the java path it's looking for and you can validate that path with the validate button. 7.11 has a bug where even if you set a valid path, about > opera shows that java environment not installed. that's fixed in version 7.21. if you're browser plugins path in opera includes the plugins directory where you have a link to the javaplugin in your java install, then you should be fine.


All times are GMT -5. The time now is 06:33 AM.