LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Java 1.5 in mandrake 10.1 (https://www.linuxquestions.org/questions/linux-software-2/java-1-5-in-mandrake-10-1-a-295314/)

goofy871 02-26-2005 10:09 PM

Java 1.5 in mandrake 10.1
 
I have recently installed mandrake linux 10.1, and i am trying to get java 1.5 to work. I followed the instructions for installation, but whenever i try to run a java program, it says that the "java" command cannot be found. Can anyone help me with this issue? It would be greatly appreciated!

reddazz 02-28-2005 04:21 AM

What package did you install the jre or jdk and also is it an rpm or bin file you used. If its the rpm and you installed the jdk rpm, then add the lines below to you .bash_profile, lo out and back in again and java should now be found,

export PATH=$PATH:/usr/java/jdk1.5.0_01/bin
export PATH=$PATH:/usr/java/jdk1.5.0_01/jre/bin


If you installed the jre rpm then you add the following line

export PATH=$PATH:/usr/java/jre1.5.0_01/bin

If your version of java is slightly different from mine, just adjust the paths to suite the one installed on your system.

goofy871 02-28-2005 10:10 PM

I tried what you said, and it still doesn't work. Whenever i try to run jgrasp, i still reciver the error: command "java" not found

reddazz 03-01-2005 01:25 AM

What version exactly and package type did you install?

Beeker 03-10-2005 02:32 PM

Rather than post a new thread...

I am having the same problems as goofy871 in regards to getting jGRASP to work.

Unfortunately, I am in more dire straits as far as knowing my way around linux in general, so I could not even find my .bash_profile file in order to add the lines suggested.

OS- Red Hat v9 (shrike)
Java- jdk-1_5_0_01
jGRASP- 1.8.0 beta

While typing this I realized the problem might be that I am using the 'beta' version of jGRASP, but I can not find anything in the documentation to indicate this is a known problem, so I will assume it is not for the moment.

If I could get a brief lesson in how to change my .bash_profile I would like to try that first, but since that did not seem to help goofy871 I'd love any other suggestions you can come up with.

(Please be sure to explain everything as if you were talking to a three-year-old, as I am very new to the linux interface)

Thanks in advance!

goofy871 03-11-2005 09:26 AM

hey, i figured out what the problem was. When installing java, you have to do it from a command line as super user so try this.

su
"type password"
type "rpm -iv 'filename'"

tell me if this helps you

Beeker 03-15-2005 01:26 PM

Unfortunately, java itself is installed properly, I did it as /root.

Right now I am in contact with the project leader who has instructed me to adjust my bash_profile, but I am having problems with that, actually, come to think of it I believe I will post a seperate thread asking for help with that.

Thanks.


All times are GMT -5. The time now is 11:48 AM.