LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-10-2004, 07:22 AM   #1
jinksys
Member
 
Registered: Aug 2003
Location: 63123
Distribution: OpenSuSE/Ubuntu
Posts: 419

Rep: Reputation: 35
Japanese Support in Linux


Simple question, Ive been able to add japanese support to my suse box by installing the kinput and canna packages and by changing my LC_CTYPE variable to ja_JP.UTF-8. But for some reason limewire starts up in japanese now, and its the only program that does it! Everything else acts normal and uses english. Any one have a similar problem?
 
Old 10-11-2004, 01:24 PM   #2
quatsch
LQ Addict
 
Registered: Aug 2003
Location: New York, NY
Distribution: gentoo, gentooPPC
Posts: 1,661

Rep: Reputation: 48
that can happen. Different programs look at different environment variables to figure out which language to use. I guess limewire looks at LC_CTYPE and decides to start in japanese. If you don't need to use japanese with limewire, you can start it with
env LC_ALL=en_US limewire

You can make approariate changes to the menu if you start it from the menus.
 
Old 10-11-2004, 03:25 PM   #3
jinksys
Member
 
Registered: Aug 2003
Location: 63123
Distribution: OpenSuSE/Ubuntu
Posts: 419

Original Poster
Rep: Reputation: 35
Thanks! That worked!
 
Old 10-11-2004, 03:54 PM   #4
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 14.04 LTS
Posts: 915

Rep: Reputation: 34
Re: Japanese Support in Linux

Quote:
Originally posted by jinksys
Simple question, Ive been able to add japanese support to my suse box by installing the kinput and canna packages and by changing my LC_CTYPE variable to ja_JP.UTF-8. But for some reason limewire starts up in japanese now, and its the only program that does it! Everything else acts normal and uses english. Any one have a similar problem?
Just curious, which desktop environment are you using? If you're using Gnome, did your change make Gnome start in Japanese mode at all?
 
Old 10-11-2004, 04:19 PM   #5
jinksys
Member
 
Registered: Aug 2003
Location: 63123
Distribution: OpenSuSE/Ubuntu
Posts: 419

Original Poster
Rep: Reputation: 35
Im using KDE. Everything works fine now, with the system using english but allowing me to write in japanese with CTRL-SPACE.
 
Old 10-11-2004, 10:22 PM   #6
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 14.04 LTS
Posts: 915

Rep: Reputation: 34
Quote:
Originally posted by jinksys
Im using KDE. Everything works fine now, with the system using english but allowing me to write in japanese with CTRL-SPACE.
I see. That sounds very good. I've always wanted to use the English system with just the Japanese language input support, but I've never been able to configure the system that way without making the default language Japanese at the install time.

So all you did was install SuSE with English as the primary language, and then install kinput2 and Canna (plus setting the environment variable)?

Thanks again,
Dai
 
Old 10-11-2004, 11:36 PM   #7
jinksys
Member
 
Registered: Aug 2003
Location: 63123
Distribution: OpenSuSE/Ubuntu
Posts: 419

Original Poster
Rep: Reputation: 35
Yes, all I needed was the ability to input and view japanese text and it was pretty easy to do.
I installed the kinput2 and canna packages in Yast2, then I went into the sysconfig editor and
set LC_CTYPE to ja_JP.UTF-8 . I believe its in environment->language. After that I could press
SHIFT-SPACE to start up the conversion program. I later changed the button sequence since
SHIFT-SPACE got on my nerves.
 
Old 10-12-2004, 11:03 PM   #8
daihard
Member
 
Registered: Jul 2003
Location: Seattle, WA
Distribution: Kubuntu 14.04 LTS
Posts: 915

Rep: Reputation: 34
Quote:
Originally posted by jinksys
Yes, all I needed was the ability to input and view japanese text and it was pretty easy to do.
I installed the kinput2 and canna packages in Yast2, then I went into the sysconfig editor and
set LC_CTYPE to ja_JP.UTF-8 . I believe its in environment->language.
Excellent! Thank you much for the detailed information. I will try that once I get a hold of SuSE, which I've been wanting to use but holding off.

I owe you one!
Dai
 
Old 10-25-2004, 02:31 PM   #9
migero
LQ Newbie
 
Registered: Oct 2004
Distribution: suse linux 9.1
Posts: 5

Rep: Reputation: 0
Question japanese support on suse

hi there my first post here and new to suse
i have read this post and install all the rpms using yast -i pack name
but when i go to suseconfig RC_LC_CTYPE and type it says " config.. error
HELP ME

Last edited by migero; 10-25-2004 at 02:33 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Japanese support slack 10.1 - kterm Cuz Slackware 1 09-13-2005 06:20 AM
WINE and Japanese support d00msweek Slackware 2 04-15-2005 06:08 PM
RH7 Install only gives Japanese Support cory4780 Linux - Software 1 03-28-2005 04:05 AM
japanese support on suse linux usham Linux - Software 0 11-06-2004 06:16 AM
.htaccess Japanese Apache support? ohlssonvox Linux - Newbie 5 08-02-2003 04:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration