LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-22-2004, 04:50 PM   #1
bootsy
LQ Newbie
 
Registered: Jan 2004
Location: Sydney, Aust
Distribution: Suse 9.1
Posts: 27

Rep: Reputation: 15
Jack or alsa issue - direct access to soundcard not possible


Hi all

Am setting up a fresh install of Suse 9.1 with the aim of running a range of music apps like ardour, hydrogen and others. The install of Suse was a dream and I have updated everything, now running kernel 2.6.5-7.108.

Have installed qjackctl, but can't get it to start, I get a pop-up error saying "Could not start jack. Sorry" - and the log output for qjackctl is as follows

07:39:06.580 Startup script...
07:39:06.581 artsshell -q terminate
sound server terminated
07:39:06.839 Startup script terminated successfully.
07:39:06.839 JACK is starting...
07:39:06.840 jackstart -R -dalsa -dhw:0 -r48000 -p1024 -n2
07:39:06.844 Could not start JACK. Sorry.
07:39:54.636 JACK was stopped successfully.

So then I tried to start jack through the console by entering "jackd -d alsa -d hw:0"

This seems to start jack - provides the following output:

jackd 0.99.0
Copyright 2001-2003 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details

loading driver ..
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 48000Hz, period = 1024 frames, buffer = 2 periods

However if I then try to start Ardour for example I get an pop-up error message saying
"Direct access to soundcard not possible.
No Soundcard available or sound support not configured yet. However, the application uses or requires sound support. Continue or Abort".

I re-ran alsaconf just to check if it was a configuration problem with the soundcard and all seemed to be fine and dandy.

If anyone can point me in the right direction, a slightly frustrated muso who's loving the move to linux would be v.v.v.v.v. happy!

Thanks in advance
 
Old 10-22-2004, 07:47 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
when you start up qjackctl
click the settup button then under server path choose jackd instead of startjack
1'st problem solved.

now try in the home directory of the user running the two
a .asoundc file
Code:
pcm.jackplug {
	        type plug
	        slave { pcm "jack" }
	}

	pcm.jack {
	        type jack
	        playback_ports {
 	               0 alsa_pcm:playback_1
 	               1 alsa_pcm:playback_2
 	       }
 	       	capture_ports {
 	               0 alsa_pcm:capture_1
                	1 alsa_pcm:capture_2
        	}
	}
and see if that helps

having these sound programs for Linux is SOOOOOO COOOOOOOL
 
Old 10-22-2004, 10:11 PM   #3
bootsy
LQ Newbie
 
Registered: Jan 2004
Location: Sydney, Aust
Distribution: Suse 9.1
Posts: 27

Original Poster
Rep: Reputation: 15
Ta FooBarFoo

the change to jackd worked a treat - I can get qjackctl to start jack now.

Sorry, a serious question tho' - what exactly do you mean by

Quote:
now try in the home directory of the user running the two
a .asoundc file

code:

pcm.jackplug {
type plug
slave { pcm "jack" }
}

pcm.jack {
type jack
playback_ports {
0 alsa_pcmlayback_1
1 alsa_pcmlayback_2
}
capture_ports {
0 alsa_pcm:capture_1
1 alsa_pcm:capture_2
}
}
Is this an file existing file I should edit/create or a command to run in a terminal? I couldn't find any file named asoundc. I'm performing all my musical work as root as I'd read that was the best way to go.

And yeah - having all these music apps on Linux absolutely rocks!

Thanks again
 
Old 10-22-2004, 10:49 PM   #4
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
yea just make a new file named ".asoundrc"
note the dot at the beginning
and put it in /root or wherever roots $HOME is there
and put that stuff in it.
alsa looks for that file and reads it if it's there.

when you are root you can play sound yes ??
aplay test.wav
from the command line works ?
and mixer apps like kmix or alsamixerGUI connect ok ?
or do they give you that same can't connect stuff ?
 
Old 10-23-2004, 12:04 AM   #5
bootsy
LQ Newbie
 
Registered: Jan 2004
Location: Sydney, Aust
Distribution: Suse 9.1
Posts: 27

Original Poster
Rep: Reputation: 15
Ta Foo Bar Foo

Ok, I created the .asoundc file and saved it in /root. qjackctl is running fine now and it's message log shows
14:41:07.924 Statistics reset.
JACK compiled with System V SHM support
14:41:08.032 MIDI connection graph change.
14:41:08.130 MIDI connection change.
14:41:11.857 Startup script...
14:41:11.858 artsshell -q terminate
sound server terminated
14:41:12.120 Startup script terminated successfully.
14:41:12.120 JACK is starting...
14:41:12.122 /usr/local/bin/jackd -R -dalsa -dhw:0 -r48000 -p1024 -n2
14:41:12.154 JACK was started with PID=5871 (0x16ef).
jackd 0.99.0
Copyright 2001-2003 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
loading driver ..
apparent rate = 48000
creating alsa driver ... hw:0|hw:0|1024|2|48000|0|0|nomon|swmeter|-|32bit
control device hw:0
configuring for 48000Hz, period = 1024 frames, buffer = 2 periods
14:41:14.166 Server configuration saved to "/root/.jackdrc".
14:41:14.167 Statistics reset.
14:41:14.222 Client activated.
14:41:14.224 Audio connection change.
14:41:14.226 Audio connection graph change.
**** alsa_pcm: xrun of at least 68.805 msecs
14:41:31.790 XRUN callback (1).
**** alsa_pcm: xrun of at least 100.816 msecs
14:42:27.433 XRUN callback (2).
**** alsa_pcm: xrun of at least 325.287 msecs
14:42:42.897 XRUN callback (3).
**** alsa_pcm: xrun of at least 247.332 msecs
14:42:48.230 XRUN callback (4).
**** alsa_pcm: xrun of at least 89.589 msecs
14:42:58.420 XRUN callback (5).

I thought sound was going ok because I get the login and logoff system sounds. I tried KAMix as you suggested - gives me the same error as Ardour "Direct access to soundcard not possible".

I also tested my cd player (which is actually a cd & dvd writer) and can't get sound out of it either. KsCD runs and plays the disc but no sound is coming out. Couldn't hear aplay test.wav either.

I went into YAST to test the soundcard was properly installed and tested the volume - all went well.

I can choose the 'continue' option on an app like hydrogen when I get the "Direct access to soundcard not possible" pop-up and don't seem to have a problem with hearing drum sounds.

Thanks for your persistence Foo Bar Foo
 
Old 10-23-2004, 01:48 PM   #6
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
ok you got some kind of a permision problem most likely in the /dev directory
my guess is some rocket scientist for suse decided root somehow shouldn't play sound
(some evil cracker might be listening)
im not really sure how root could be locked out of anything though ????????
are you logged in as root or just starting stuff as su from a use account ??
check permissions on /dev/dsp0 what does that say ?? (ls -l /dev/dsp0)
 
Old 10-23-2004, 06:50 PM   #7
bootsy
LQ Newbie
 
Registered: Jan 2004
Location: Sydney, Aust
Distribution: Suse 9.1
Posts: 27

Original Poster
Rep: Reputation: 15
Thank again Foo Bar Foo (if you are in Australia or ever visit, I owe you a couple of beers)

I have been logged in as root, and have tried this morning doing all the same logged on as SU IN a user account. Notably I can't start qjackctl logged in as a user, but I can if logged in as root.

Output of ls - l /dev/dsp0 is

crw------- 1 bootsy audio 14, 3 2004-04-06 23:27 /dev/dsp0

not that I am really sure what that means.
 
Old 10-23-2004, 07:31 PM   #8
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
yep that's the trouble


no need to change permissions for links
*slightly tedious task ahead*
you need to make everything in /dev and subdirectories
that has that same group "audio"
including the stuff in /dev/snd
crw-rw---- 1 root audio

the command to do that:
cd /dev
su to root
chown root dsp0
chmod 660 dsp0

so on and so forth

then to keep sound working for your user account
in the file /etc/group
put "bootsy" at the end of the audio group
example:
audio:x:11:bootsy

might need to reboot for that to take effect ?? not sure

now sound works WOO HOO

another trick -- won't work for ardour or anything gtk+
so you can do some stuff as user
i do this and run qjackctl/jackd/ladccad/muse
and it seems to work fine
set uid root for those executables
go to where they are
su to root
chmod u+s qjackctl
chmod u+s jackd
and like that
then they will work as regular user
edit#2: and still work fine as root as well
if you do this to something and it complains or you just want to undo it just
chmod u-s
will undo it

happy tunes !

edit: might want to copy that .asoundrc to your /home/bootsy folder as well

Last edited by foo_bar_foo; 10-23-2004 at 07:36 PM.
 
Old 10-26-2004, 04:38 AM   #9
bootsy
LQ Newbie
 
Registered: Jan 2004
Location: Sydney, Aust
Distribution: Suse 9.1
Posts: 27

Original Poster
Rep: Reputation: 15
hmmmm...

Still not recognising the sound card in Ardour... Just to make sure I have done this correctly, after changing permissions so that root has read and write access pretty much everything in /dev/.

ls -l /dev/dsp0 now shows
crw-rw---- 1 root audio 14, 3 Apr 6 2004 /dev/dsp0

and /etc/groups already had
audio:x:17:bootsy

yet I'm still getting the same error message and can't hear audio from a CD using KsCD
 
Old 11-16-2004, 10:26 PM   #10
MrVorik
LQ Newbie
 
Registered: Jul 2004
Posts: 3

Rep: Reputation: 0
Bootsy,

Your problem on not being able to hear cd's is simple. You don't have a cable between your cd-rom and your soundcard. By default, SuSE want's to play CD's via analog (aka your cable). You can configure xmms to play CD's via the digital method in the "Play Options -> Digital Audio Extraction" (default mode in Windows XP). This should fix your problem. Also, you can use xine to play cd's digitally.

Regards....
PS. If you figure out the midi "no sound" problem. Do tell. I'm having the same frustration.
 
Old 11-18-2004, 02:14 AM   #11
bootsy
LQ Newbie
 
Registered: Jan 2004
Location: Sydney, Aust
Distribution: Suse 9.1
Posts: 27

Original Poster
Rep: Reputation: 15
Thanks MrVorik

I do have a cable from my DVD-rom connected, but it's not to my soundcard - so you may be onto something here. My soundcard - M-Audio Audiophile 2496 doesn't have anywhere for that cable to go into - the audio cable acutally goes into the mother board at the moment.

Not sure what I am supposed to do in this circumstance?
 
Old 01-24-2005, 08:04 PM   #12
rhythmking
Member
 
Registered: Dec 2003
Posts: 54

Rep: Reputation: 15
alsamixer?

Have you tried running alsamixer from a shell?
Set the levels with arrow keys, mute with m key and capture with space.
then exit with esc and type alsactl store and hit enter.
Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
JACK, Ardour ALSA - Mandrake 10.1 trey85stang Linux - Software 2 05-22-2005 08:30 AM
issues setting up rosegarden/JACK/ALSA jgams Linux - Software 7 04-20-2005 01:42 AM
alsa/jack/ardour foo_bar_foo Linux - Software 1 10-20-2004 04:43 AM
JACK, ALSA and a Creative Audigy Platinum breakerfall Linux - Software 1 02-13-2004 10:37 AM
JACK doesn't detect ALSA disciple061 Linux - Software 0 07-31-2003 07:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration