-   Linux - Software (
-   -   jack("jackd") doesn't work, have tried EVERYTHING! (

Hoff123 03-19-2012 12:52 PM

jack("jackd") doesn't work, have tried EVERYTHING!

I am trying to run jack(or "jackd") and it won't start. I have tried both QjackCtl and via the terminal. I have tried both jack1 and jack2. I have done everything possible I can do with PulseAudio(I even tried to uninstall it, didn't help at all). I even installed Ubuntu Studio(which had a real time kernel). Yes I did install it via VirtualBox(if it makes any difference). I suspect I have to get a new REAL sound card(I am using an integrated one).

I am using Arch Linux 64 bit. And installed Ubuntu Studio 64 bit via VirtualBox(inside Arch Linux).

The motherboard:

Jack error:
Could not connect to JACK server as client.
-Overal operation failed.
-Unable to connect to server.
Please check the messages window for more info.

Messages window:
18:32:47.642 Patchbay deactivated.
18:32:47.642 Statistics reset.
18:32:47.708 ALSA connection change.
18:32:47.717 ALSA connection graph change.
18:32:54.323 JACK is starting...
18:32:54.323 /usr/bin/jackd -p128 -dalsa -dhw:0 -r44100 -p64 -n2 -S
18:32:54.346 JACK was started with PID=2326.
18:32:54.538 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.
18:47:28.393 JACK is stopping...

Should I get a new, REAL sound card?

Roken 03-21-2012 05:45 AM

I had no end of problems with jack and pulseaudio. I removed pulse and reverted to oss4, and can now start and stop jack at a whim without issue. Also on Arch.

If you go this route the only thing worth noting is that you will have to reinstall oss after each kernel upgrade:


sudo pacman -S oss
You may also need to install esd for full system sounds with oss and add esd and oss to your modules array in /etc/rc.conf

Hoff123 03-21-2012 02:44 PM

Thank you, but unfortunately it didn't work.

But I noticed something very strange, when I choose "net" instead of alsa(or oss) in QjackCtl(Setup>Driver) it seems to work???
I tried all the options and only "net" seems to work? isn't that the thing called "netjack" or something? And that isn't really the right way to start jack is it?

Anyway when I run ZynAddSubFX there is no sound, so should I get a new sound card(already asked that I now)?
I tried an old sound card(it was called something like "c-media...something...rev 10", lol). But I couldn't get the sound(normal sound with ALSA and PulseAudio) to work with that.

All times are GMT -5. The time now is 08:10 PM.