-   Linux - Software (
-   -   Jack audio connection kit not working with kernel? (

linuxpyro 04-08-2004 01:20 PM

Jack audio connection kit not working with kernel?
I'm trying to get Ardour working on my Redhat 9 box, and so need to install Jack. It installed alright, but when I try to run it with jackstart -R -d alsa -d hw -r 44100 I get this error:

jackstart: cannot get realtime capabilities, current capabilities are:
=ep cap_setpcap-ep
probably running under a kernel with capabilities disabled,
a suitable kernel would have printed something like "=eip"

My soundcard seems to be configured fine, but what needs to be tweaked in the kernel to get this going?

mikshaw 04-08-2004 02:11 PM

You need to be root to run JACK in that manner, and as a consequence you'll need to also run Ardour as root.

linuxpyro 04-08-2004 04:17 PM

I tried it under root, but got the same message.

mikshaw 04-08-2004 07:04 PM

When I first installed I tried what was suggested in the install notes and it didn't work, but using
"jackd -d alsa" or "jackd -d alsa -d hw:0" works fine.
Looking at your command, I also use "-r 44100" without trouble.
All I can add is maybe try jackd instead of jackstart

All times are GMT -5. The time now is 07:19 PM.