-   Linux - Software (
-   -   JACK audio connection kit (

storyteller 11-22-2003 08:47 PM

JACK audio connection kit
I'm curious why no one has replaced jack with something that works.
I've been on linux for about 6 months, and my primary purpose for owning a pc is recording music. In that time the only program I've gotten to record is audacity (Which was rectified when mandrake 9.2 rendered it completely nonfunctional).
Rosegarden4 looks like a beautiful program, as do ardour and hydrogen, but for some reason all of the decent recording programs rely on jack, whose lack of functionality rivals that of micro$oft.
I've looked up jack on every search engine in the known universe, and have yet to read anything but complaints. Not one instance of "Jack is great, it works like a charm".
Qjackctl was a great way of giving jack a gui, so you can see just how mad you've really become, and somehow it got jack to start on my pc :eek: : once.
Repeating the exact steps (after aborting jacks multiheaded offspring with kde system guards rusty coathanger utility) failed, leaving me back at the drawing board. Even the one time it worked hydrogen cound not use it, saying that it could not access pcm 1.

After 6 months of tightly gripping my rosary beads and singing incantations to various pagan gods, all I've gotten from jack is what the name implies.

So the question I have is:
Are there currently any projects in the works to replace jack? I would be happy to contribute to the cause, and I am sure I'm not alone.

Thanks in advance.

r_jensen11 11-22-2003 10:51 PM

What version of Jack did you try using? There are many types of programs called Jack out there. One is version 3.0 is out now, which is a CD ripper, or so it says. Not sure what you were trying to use before. Sourceforge has 0.9, which looks more like what you're describing what you need... I'll look around and see what I can dig up.

storyteller 11-22-2003 11:39 PM

Sorry, I guess I could've been more clear. The newest package I installed, (The only one I've seen run after trying several) is : jackit-0.75.0-1mdk.i586.rpm
I appreciate the help.
I see no alternative to using this program, but I find it strange that you have to tweak so many dials to make it function. Even after it's initial configuration you can't count on it's settings to work.
The gui was certainly a step in the right direction (Though I am certainly not averse to learning new commands), giving ease of experimentation. If I could program my way out of a paper bag I would certainly attempt to build some ease of configuration tools into the prog itself, but alas I caught a bad case of windoze when I was young and it stunted my growth.

I'm still lost on mandrake, but already thinking of jumping feet first into gentoo :-)

r_jensen11 11-23-2003 09:53 AM

Try using the .tar.gz instead of the RPM. That's all I can suggest for right now....

storyteller 11-23-2003 01:35 PM

I got jack to work by installing the cvs version, but nothing will link to it. Hydrogen won't install from rpm because it refuses to see jack if it's installed from source. Trying to install hydrogen from source tells me it can't find jack.pc even though it's in I've tried running ldconfig but that changes nothing. I tried PATH=$PATH /usr/local/lib, but again no change. If I force the rpm to install: rpm -i --nodep hydrogen ..etc., It installs, but will not connect to jack. jack sees it as a possible souce of input, but will not link returning the error: hydrogen cound not start jack client.

After vistiting the jack site, I've found that others have reported trouble with my sound card, so I'm trying to install a sound blaster. Hopfully that solves the issue.

Thanks for the help.

All times are GMT -5. The time now is 02:10 PM.