-   Linux - Software (
-   -   Issues w/ firefox (

blackdragonblood 05-18-2005 06:20 PM

Issues w/ firefox
I'm a linux newb running FC3. I'm trying to install firefox 1.0.4. I followed the instructions on the web page. Then when I tried running fx the old .1PR opened. I read the web page some ore and find that I need to install the rpm (btw: what is an rpm anyway?). I installed that and am still having issues. I trashed the mozilla folder and tried installing fx again. At the end of installation I get an error message about not being able to run because of a shared object file.

reddazz 05-18-2005 07:45 PM

Fedora Core 3 has firefox in its updates repository. All you need to do is as root, run

#yum update
All packages whichcan be updated will then be updated. To update just one package you could do something like,

#yum update firefox

blackdragonblood 05-18-2005 08:20 PM

Issues w/ yum
I tried that and I get "Error: Missing Dependency: is needed by package gnome-vfs2"

craigevil 05-18-2005 09:09 PM

Try one of the RPMs here: RPM resource Firefox

blackdragonblood 05-18-2005 09:32 PM

I tried that and I get an error message saying "The file"/tmp/firefox-" is a source RPM which connot be installed with system-config-packages."

detpenguin 05-18-2005 09:36 PM

have you tried downloading the tar.gz and unzipping it in your home directory? once it's unzipped, open the folder and click on the firefox-installer icon and it will install for you. thats how i use it. it's all kind of self-contained in the one folder, and includes a run script to run from the folder, or do like me, i made a soft link to it using

ln -s /home/jk/firefox-installer/firefox /usr/bin/firefox

once you do that, you need only type firefox in a run command to launch it, or if you use kde or gnome, you can create an icon on your desktop.

Brian1 05-18-2005 09:44 PM

Did you use the source file for your install. Then where did you install the 1.0.4 version? If you are clicking on the icon then the properties of the icon need to be updated to point to the new firefox-1.0.4 location. If in KDE and clicking on the Icon in the Taskbar then you will need to run kmenu and edit the properties of the web browser and then remove the one from the taskbar and add the new updated one.

Linux the Google way at ' '

blackdragonblood 05-18-2005 10:11 PM

I got the install from FC3 says I have 198 updates, but when I try to update it says my system is fully updated. I tryed doing all the updates at once a few times and ended up rebooting everytime. Is it possible I corrupted something? Also, If I'm not mistaken, I'm running GNOME.

reddazz 05-19-2005 06:52 AM

Firefox 1.0.4 is among those updates. Did you try

#yum update
Its supposed to install all updates and resolve any dependencies automatically. If that doesn't work, try geting apt and synaptic from fedoraproject in the Extras repository for FC3. Once you have installed them (apt first), do as root,

#apt-get mirror-select
#apt-get update

Once thats done, run Synpatic (gui frontend for apt). You can use this to check available updates and pick the ones you want to upgrade (or upgrade them all). Select "smart upgrade" if asked what type of upgrade you want. Hope it works out for you.

blackdragonblood 05-19-2005 10:16 PM

I reinstalled linux and that has appeared to fix all my update issues. Big thx for your help.

reddazz 05-20-2005 12:55 AM

Its obviously a waste of peoples time if we give you the solutions to your problem and you just go do something else. Linux is not windoze where most problems are resolved by reinstalling. Its better to resolve a problem just in case it happens again in the future. Its just my :twocents:

blackdragonblood 05-20-2005 01:06 AM

You make a vaild and interesting point. I'm sorry.

Simon Bridge 05-29-2005 03:20 AM

Actually, I'd defend blackdragonblood on his decision to reinstall at the point in which he did. The previous install attempts (of f-fox) had clearly botched something he has not the experience or knowhow to work out and explain to us ... so we really needed to be sitting at his computer and looking at his logs.

Remember, we're talking about someone who didn't know what an rpm was - hopefully he does now :)

After the yum problem (100's of updates but completely updated?) my instinct was to advise a reinstall of FC. Now he's less confused, and staring with a clean slate, he can actually get something done. It's a bummer when you stuff up so early on.

And far from ignoring the suggestions, he followed every one. None of them would work because we had not the right information to make those suggestions. Once he reinstalled, he used the yum update suggestion again - successfully this time - and then thanked everyone for their time.

It would be nice if more newbies would behave so well.

The point about working through problems, for the experience and education, is OK for people with some basic problem solving behind them. And lets remember, that the same point could be made in connection with the old: "this app dosn't work for you, then install another one ... it's different" approach. Why not work through to fix the first app - after all, you may need the experience in case such a thing happens again?

But lets not expect folk to run the 500m hurdles before they can crawl huh? Most of us broke our teeth on simpler and less subtle issues than the ones described her

reddazz 05-29-2005 04:32 AM

On reflection, I probably was a bit harsh. As a newbie, I can understand that if things go wrong, sometimes its difficult to diagnose and troubleshoot the problem, so reinstalling can be the only option. It is vital though not to get sucked into the windoze trap where everything is resoved by reinstalling. ;)

blackdragonblood 05-29-2005 12:32 PM

I also found that 32-bit runs A LOT better. I bought a book that is explaining a lot more about how to do stuff. Again thanks for your time. To other newbies that may be reading this. Stick to 32-bit for now.

All times are GMT -5. The time now is 06:58 AM.