LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 07-23-2004, 07:44 PM   #1
ValidiusMaximus
Member
 
Registered: Mar 2004
Distribution: Debian Sarge
Posts: 169

Rep: Reputation: 30
Issue with XFree86 finding display.


Hi all, i have a Debian Sarge box and i cant get X to work right. Here si teh debug file:

[start]

XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-4 20040529113443 root@cyberhq.internal.cyberhqz.com)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.6-rc3-bk9 i686 [ELF]
Build Date: 29 May 2004
Before reporting problems, check http://www.XFree86.Org/
to make sure that you have the latest version.
Module Loader present
OS Kernel: Linux version 2.4.18-bf2.4 (root@zombie) (gcc version 2.95.4 20011002 (Debian prerelease)) #1 Son Apr 14 09:53:28 CEST 2002
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.0.log", Time: Fri Jul 23 15:44:37 2004
(==) Using config file: "/etc/X11/XF86Config-4"
(==) ServerLayout "Default Layout"
(**) |-->Screen "Default Screen" (0)
(**) | |-->Monitor "Generic Monitor"
(**) | |-->Device "Generic Video Card"
(**) |-->Input Device "Generic Keyboard"
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) XKB: model: "pc104"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(**) |-->Input Device "Configured Mouse"
(**) |-->Input Device "Generic Mouse"
(WW) The directory "/usr/lib/X11/fonts/misc" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/100dpi/" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/75dpi/" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/Type1" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/CID" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/Speedo" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/100dpi" does not exist.
Entry deleted from font path.
(WW) The directory "/usr/lib/X11/fonts/75dpi" does not exist.
Entry deleted from font path.
(**) FontPath set to "unix/:7100"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(WW) Open APM failed (/dev/apm_bios) (No such file or directory)
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.2
XFree86 Video Driver: 0.6
XFree86 XInput driver : 0.4
XFree86 Server Extension : 0.2
XFree86 Font Renderer : 0.4
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x80000058, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,7190 card 0000,0000 rev 03 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 8086,7191 card 0000,0000 rev 03 class 06,04,00 hdr 01
(II) PCI: 00:07:0: chip 8086,7110 card 0000,0000 rev 02 class 06,01,00 hdr 80
(II) PCI: 00:07:1: chip 8086,7111 card 0000,0000 rev 01 class 01,01,80 hdr 00
(II) PCI: 00:07:2: chip 8086,7112 card 0000,0000 rev 01 class 0c,03,00 hdr 00
(II) PCI: 00:07:3: chip 8086,7113 card 0000,0000 rev 02 class 06,80,00 hdr 00
(II) PCI: 00:0d:0: chip 125d,1968 card 1042,0737 rev 00 class 04,01,00 hdr 00
(II) PCI: 00:11:0: chip 10ec,8139 card 10ec,8139 rev 10 class 02,00,00 hdr 00
(II) PCI: 01:00:0: chip 12d2,0018 card 1042,0737 rev 22 class 03,00,00 hdr 00
(II) PCI: End of PCI scan
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (0,0,1), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x0088 (VGA_EN is set)
(II) Bus 1 I/O range:
[0] -1 0 0x0000d000 - 0x0000dfff (0x1000) IX[B]
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xe4000000 - 0xe5ffffff (0x2000000) MX[B]
(II) Bus 1 prefetchable memory range:
[0] -1 0 0xe6000000 - 0xe6ffffff (0x1000000) MX[B]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:7:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(--) PCI:*(1:0:0) NVidia / SGS Thomson (Joint Venture) Riva128 rev 34, Mem @ 0xe4000000/24, 0xe6000000/24
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) PCI Memory resource overlap reduced 0xe0000000 from 0xe3ffffff to 0xdfffffff
(II) Active PCI resource ranges:
[0] -1 0 0xe7000000 - 0xe70000ff (0x100) MX[B]
[1] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[2] -1 0 0xe6000000 - 0xe6ffffff (0x1000000) MX[B](B)
[3] -1 0 0xe4000000 - 0xe4ffffff (0x1000000) MX[B](B)
[4] -1 0 0x0000e800 - 0x0000e8ff (0x100) IX[B]
[5] -1 0 0x0000e400 - 0x0000e4ff (0x100) IX[B]
[6] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[B]
[7] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[B]
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0xe7000000 - 0xe70000ff (0x100) MX[B]
[1] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[2] -1 0 0xe6000000 - 0xe6ffffff (0x1000000) MX[B](B)
[3] -1 0 0xe4000000 - 0xe4ffffff (0x1000000) MX[B](B)
[4] -1 0 0x0000e800 - 0x0000e8ff (0x100) IX[B]
[5] -1 0 0x0000e400 - 0x0000e4ff (0x100) IX[B]
[6] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[B]
[7] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[B]
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xe7000000 - 0xe70000ff (0x100) MX[B]
[6] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[7] -1 0 0xe6000000 - 0xe6ffffff (0x1000000) MX[B](B)
[8] -1 0 0xe4000000 - 0xe4ffffff (0x1000000) MX[B](B)
[9] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[10] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[11] -1 0 0x0000e800 - 0x0000e8ff (0x100) IX[B]
[12] -1 0 0x0000e400 - 0x0000e4ff (0x100) IX[B]
[13] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[B]
[14] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[B]
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_clip.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_norm.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_xform.o": No symbols found
Skipping "/usr/X11R6/lib/modules/extensions/libGLcore.a:m_debug_vertex.o": No symbols found
(II) Module GLcore: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) LoadModule: "bitmap"
(II) Reloading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Loading font Bitmap
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "dri"
(II) Loading /usr/X11R6/lib/modules/extensions/libdri.a
(II) Module dri: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "drm"
(II) LoadModule: "drm"
(II) Loading /usr/X11R6/lib/modules/linux/libdrm.a
(II) Module drm: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension XFree86-DRI
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 2.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Server Extension, version 0.2
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Reloading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Loading extension GLX
(II) LoadModule: "int10"
(II) Loading /usr/X11R6/lib/modules/linux/libint10.a
(II) Module int10: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.13.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.2
(II) Loading extension RECORD
(II) LoadModule: "speedo"
(II) Loading /usr/X11R6/lib/modules/fonts/libspeedo.a
Skipping "/usr/X11R6/lib/modules/fonts/libspeedo.a:spencode.o": No symbols found
(II) Module speedo: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.1
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Speedo
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.2
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.4
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "vbe"
(II) Loading /usr/X11R6/lib/modules/libvbe.a
(II) Module vbe: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.1.0
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "nv"
(II) Loading /usr/X11R6/lib/modules/drivers/nv_drv.o
(II) Module nv: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.1
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.6
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.4
(II) NV: driver for NVIDIA chipsets: RIVA 128, RIVA TNT, RIVA TNT2, Vanta,
RIVA TNT2 Ultra, RIVA TNT2 Model 64, Aladdin TNT2, GeForce 256,
GeForce DDR, Quadro, GeForce2 MX/MX 400, GeForce2 MX 100/200,
GeForce2 Go, Quadro2 MXR/EX/Go, GeForce2 Integrated GPU,
GeForce2 GTS, GeForce2 Ti, GeForce2 Ultra, Quadro2 Pro,
GeForce4 MX 460, GeForce4 MX 440, GeForce4 MX 420,
GeForce4 MX 440-SE, GeForce4 440 Go, GeForce4 420 Go,
GeForce4 420 Go 32M, GeForce4 460 Go, GeForce4 440 Go 64M,
GeForce4 410 Go 16M, Quadro4 500 GoGL, Quadro4 550 XGL, Quadro4 NVS,
GeForce4 MX 440 with AGP8X, GeForce4 MX 440SE with AGP8X,
GeForce4 MX 420 with AGP8X, GeForce4 448 Go, GeForce4 488 Go,
Quadro4 580 XGL, Quadro4 280 NVS, Quadro4 380 XGL,
GeForce4 MX Integrated GPU, GeForce3, GeForce3 Ti 200,
GeForce3 Ti 500, Quadro DCC, GeForce4 Ti 4600, GeForce4 Ti 4400,
0x0252, GeForce4 Ti 4200, Quadro4 900 XGL, Quadro4 750 XGL,
Quadro4 700 XGL, GeForce4 Ti 4800, GeForce4 Ti 4200 with AGP8X,
GeForce4 Ti 4800 SE, GeForce4 4200 Go, Quadro4 700 GoGL,
Quadro4 980 XGL, Quadro4 780 XGL, 0x0300, GeForce FX 5800 Ultra,
GeForce FX 5800, Quadro FX 2000, Quadro FX 1000,
GeForce FX 5600 Ultra, GeForce FX 5600, 0x0316, 0x0317, 0x0318,
0x0319, 0x031A, 0x031B, 0x031C, 0x031D, 0x031E, 0x031F,
GeForce FX 5200 Ultra, GeForce FX 5200, 0x0323, GeForce FX Go5200,
GeForce FX Go5250, 0x032A, Quadro FX 500, 0x032C, 0x032D, 0x032F
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset RIVA 128 found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xe7000000 - 0xe70000ff (0x100) MX[B]
[6] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[7] -1 0 0xe6000000 - 0xe6ffffff (0x1000000) MX[B](B)
[8] -1 0 0xe4000000 - 0xe4ffffff (0x1000000) MX[B](B)
[9] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[10] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[11] -1 0 0x0000e800 - 0x0000e8ff (0x100) IX[B]
[12] -1 0 0x0000e400 - 0x0000e4ff (0x100) IX[B]
[13] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[B]
[14] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[B]
(II) resource ranges after probing:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xe7000000 - 0xe70000ff (0x100) MX[B]
[6] -1 0 0xe0000000 - 0xdfffffff (0x0) MX[B]O
[7] -1 0 0xe6000000 - 0xe6ffffff (0x1000000) MX[B](B)
[8] -1 0 0xe4000000 - 0xe4ffffff (0x1000000) MX[B](B)
[9] 0 0 0x000a0000 - 0x000affff (0x10000) MS[B]
[10] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[B]
[11] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[B]
[12] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[13] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[14] -1 0 0x0000e800 - 0x0000e8ff (0x100) IX[B]
[15] -1 0 0x0000e400 - 0x0000e4ff (0x100) IX[B]
[16] -1 0 0x0000e000 - 0x0000e01f (0x20) IX[B]
[17] -1 0 0x0000f000 - 0x0000f00f (0x10) IX[B]
[18] 0 0 0x000003b0 - 0x000003bb (0xc) IS[B]
[19] 0 0 0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga for screen 0.
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Reloading /usr/X11R6/lib/modules/linux/libint10.a
(II) NV(0): Initializing int10
(II) NV(0): Primary V_BIOS segment is: 0xc000
(--) NV(0): Chipset: "RIVA 128"
(**) NV(0): Depth 15, (--) framebuffer bpp 16
(==) NV(0): RGB weight 555
(==) NV(0): Default visual is TrueColor
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(**) NV(0): Option "UseFBDev" "true"
(==) NV(0): Using HW cursor
(**) NV(0): Using framebuffer device
(II) Loading sub module "fbdevhw"
(II) LoadModule: "fbdevhw"
(II) Loading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) Module fbdevhw: vendor="The XFree86 Project"
compiled for 4.3.0.1, module version = 0.0.2
ABI class: XFree86 Video Driver, version 0.6
(WW) open /dev/fb1: No such device
(WW) open /dev/fb2: No such device
(WW) open /dev/fb3: No such device
(WW) open /dev/fb4: No such device
(WW) open /dev/fb5: No such device
(WW) open /dev/fb6: No such device
(WW) open /dev/fb7: No such device
(EE) Unable to find a valid framebuffer device
(EE) NV(0): Failed to open framebuffer device, consult warnings and/or errors abov
for possible reasons
(you may have to look at the server log to see warnings)
(II) UnloadModule: "nv"
(II) UnloadModule: "fbdevhw"
(II) Unloading /usr/X11R6/lib/modules/linux/libfbdevhw.a
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(II) UnloadModule: "int10"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to submit@bugs.debian.org.


[end]

Anyone have any ideas?
 
Old 07-24-2004, 12:28 PM   #2
idaho
Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: RedHat, Libranet
Posts: 438

Rep: Reputation: 30
The key to interpreting your XFree86 log file is given at the top of the file. Each line will have a prefix as listed in this key:
~~~~~~~~~~~~~~~~~~~~~~~~~
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
~~~~~~~~~~~~~~~~~~~~~~~~~

When things are not working, it is useful to look for any error related messages, i.e., lines that start with a "EE". Here are the lines from your listing with an "EE" prefix:
~~~~~~~~~~~~~~~~~~~~~~~~~
(EE) Unable to find a valid framebuffer device
(EE) NV(0): Failed to open framebuffer device, consult warnings and/or errors abov
for possible reasons
(you may have to look at the server log to see warnings)
...
(EE) Screen(s) found, but none have a usable configuration.
~~~~~~~~~~~~~~~~~~~~~~~~~

I interpret these error messages to mean that your nv (Nvidia) driver is not happy with your your hardware.
 
Old 07-24-2004, 12:59 PM   #3
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 53
Quote:
(**) NV(0): Option "UseFBDev" "true"
i think this is the problem
try setting that in the config to false
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Finding version of XFree86 i.of.the.storm Linux - Newbie 6 08-31-2005 09:21 PM
Yum Issue finding gpg key cuco76 Linux - Software 1 11-08-2004 03:14 PM
XFree86 Display Issue zizdodrian Debian 16 07-24-2004 06:15 PM
XFree86 display driver ValidiusMaximus Linux - Software 4 07-21-2004 01:11 PM
"extension "XFree86-DRI" missing on display" upgrading XFree86 to 4.3.0 on Sarge Moloko Debian 5 03-31-2004 05:06 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration