LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-12-2009, 10:28 AM   #1
tech_paul
LQ Newbie
 
Registered: Apr 2009
Posts: 17

Rep: Reputation: 0
ISPConfig 2 + CentOS 3


Hi,

I am trying to install ISPConfig version 2 on CentOS 5.3 and when I finish the installation the ispconfig_server service is not found under /etc/init.d/ispconfig_server!

I all get the below error at the final steps of the installation:

./setup2: line 1189: cd: /tmp/install_ispconfig/compile_aps/../..: No such file or directory

I also get the following before the above error:

./setup2: line 1090: mysql_config: No such file or directory
./setup2: line 1091: httpd: No such file or directory
./setup2: line 1092: httpd2: No such file or directory
./setup2: line 1093: httpd2: No such file or directory
./setup2: line 1103: ip_addresses: No such file or directory
./setup2: line 1105: /root/ispconfig/php/php: No such file or directory
./setup2: line 1106: /root/ispconfig/dist.info: No such file or directory
chmod: cannot access `/home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper': No such file or directory
./setup2: line 1119: /home/admispconfig/ispconfig/sysconf.txt: No such file or directory
./setup2: line 1120: /home/admispconfig/ispconfig/sysconf.txt: No such file or directory
Restarting some services...
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
[Sun Apr 12 09:57:44 2009] [error] VirtualHost 192.168.5.20:0 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Sun Apr 12 09:57:44 2009] [error] VirtualHost 192.168.5.20:0 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Shutting down sm-client: [ OK ]
Shutting down sendmail: [ OK ]
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Starting sendmail: make: getcwd: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
[ OK ]
Starting sm-client: shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
[ OK ]
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Shutting down proftpd: [ OK ]
Starting proftpd: shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
[ OK ]
./setup2: line 1163: /etc/rc.d/init.d/ispconfig_server: No such file or directory


Do anyone have any ideas please?
(N.B. I have used the The Perfect Server - CentOS tutorial. Any help should be useful...
 
Old 04-13-2009, 06:55 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,523

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
it is looking like mysql,php,apache,... are not installed
-- or --
you did not edit the ./setup2 script to point to there locations hence
Code:
/setup2: line 1090: mysql_config: No such file or directory
./setup2: line 1091: httpd: No such file or directory
./setup2: line 1092: httpd2: No such file or directory
./setup2: line 1093: httpd2: No such file or directory
./setup2: line 1103: ip_addresses: No such file or directory
./setup2: line 1105: /root/ispconfig/php/php: No such file or directory
./setup2: line 1106: /root/ispconfig/dist.info: No such file or directory
also you appear to be running the install / setup script as a regular user and nor as root
Code:
/setup2: line 1119: /home/admispconfig/ispconfig/sysconf.txt: No such file or directory
 
Old 04-16-2009, 02:36 AM   #3
tech_paul
LQ Newbie
 
Registered: Apr 2009
Posts: 17

Original Poster
Rep: Reputation: 0
Thanks John. I have reinstalled everything from scratch and everything is back to working now
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: The Perfect Server - CentOS 5.2 [ISPConfig 3] LXer Syndicated Linux News 0 03-26-2009 05:00 PM
webmail on ISPConfig snares Linux - Server 3 07-01-2008 01:41 PM
Ports for ISPConfig songeek Linux - Server 3 02-05-2008 10:30 PM
LXer: CentOS 4.6 Server Setup: LAMP, Email, DNS, FTP, ISPConfig LXer Syndicated Linux News 0 01-10-2008 03:40 PM
LXer: CentOS 5.1 Server Setup: LAMP, Email, DNS, FTP, ISPConfig LXer Syndicated Linux News 0 12-06-2007 03:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration