LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   iSCSI initiator grief- 64bit RHEL4 (https://www.linuxquestions.org/questions/linux-software-2/iscsi-initiator-grief-64bit-rhel4-416507/)

RedHatCat 02-17-2006 10:26 AM

iSCSI initiator grief- 64bit RHEL4
 
Hi all,

Thanks in advance for any advice you can give me with this problem, I've hit a brick wall and need help!

This is the test setup:

--iSCSI target/server: Sharing 400GB raid1 via iSCSI, using an Open-E module.
--Laptop: WindowsXP and MS iSCSI initiator (driver), works flawlessy. Drive was mapped and formatted in minutes.
--1u Server: RHEL 4u1 64bit, tried a variety of initiators, none even come close to compiling properly.

Initiators I've tried:

--linux-iscsi : Compilation failed - reason still unknown
--Open-iscsi: Compilation failed - requires kernel 2.6.11-x, I have 2.6.9-11.
--UNH-iscsi: Compilation failed - x86_64 platform unknown, despite the fact I have all 32bit compat libraries installed.

Now if my clients servers were xp/w2k3 then there wouldn't be a problem (I hate it when MS get it right), but they have RHEL 64bit servers. I really need to find an initiator that will compile and function properly in RHEL 4u1. The problem with a few of the compilations seems to point towards incompatibilty with x86_64 architecture or kernel version; but I have all the compat/32 bit libraries and apps installed that I can find, and I dont know where to start to upgrade the kernel past 2.6.9-x.

Is there anything I can do to find out if 32-bit compatibility is available on my OS, and will kick in when required?
Does anyone have any pointers regarding compilation of 32 bit apps for 64 bit OS'?
Anyone have any tips for setting up an iSCSI environment?

Thanks again,

Jim

imemyself 02-19-2006 01:53 AM

Have you tried the packages included with RHEL? I think its something like iscsi-initiator-utils. I've run in CentOS 4 in VMware(32 bit) and it worked fine for my (extremely small and simple) tests. And CentOS's website shows there as being a package for x86_64. Here's a readme thing for it:
http://people.redhat.com/mchristi/is...EL4/doc/readme

and here's where I saw the x86_64 RPM for it(if RH doesn't have one for some odd reason)
http://mirror.stanford.edu/yum/pub/c...4/CentOS/RPMS/

And I'm not sure how well running any of the iSCSI stuff as 32 bit on a 64 bit OS would work. I'm thinking that they use some kernel modules so I would almost presume that it probably wouldn't work too well, but I don't know that for sure.

RedHatCat 02-20-2006 04:43 AM

Thanks for the pointers imemyself, will have a look into that now :)

Jim

RedHatCat 02-20-2006 11:03 AM

I did a fresh install of 4u2 and found the iscsi-initiator-tools, which has done the business, after a little tweaking. I never noticed the option to install the tools when installing RHEL 4 or 4u1, but I might do an install just to check at some point. New rpm for 4u2?

If I install the initiator (plus dependancies) on a complete 4u1 machine, with the RPMs from Redhat, it has problems finding a module of some kind and cant start up. But maybe the best option is to update any 4u1 machines to 4u2, and try to add the iscsi-initiator-tools as part of the update...testing req'd I think.

Thanks again for the tip imemyself.


All times are GMT -5. The time now is 10:01 PM.