LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-27-2014, 11:28 PM   #1
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Mint 17.1 KDE on workstation, CentOS 6.x on servers
Posts: 1,145

Rep: Reputation: 47
Is there a way to get Supermicro IPMI to work in Linux?


I really don't want to have to setup a XP VM and have to rely on Windows to use IPMI. Is there a way to make this work in Linux?

When I try to load the console it asks to install Java, but nothing happens when I click on the button. I know that I already do have Java because I play Minecraft sometimes, but it's probably a different version that it wants.

Is there any way to make this work?
 
Old 05-28-2014, 04:02 PM   #2
potato_farmer
Member
 
Registered: May 2014
Posts: 55

Rep: Reputation: Disabled
Your browser may not have the JAVA Plugin. Assuming you use Firefox, you will need to add a symbolic link to libnpjp2.so in your Firefox plugins directory.

You may want to try this:
oracle.com/technetwork/java/javase/manual-plugin-install-linux-136395.html

Once the plugin is recognized by Firefox, you should be able to access the IPMI.

Good luck.
 
Old 05-28-2014, 06:40 PM   #3
jefro
Moderator
 
Registered: Mar 2008
Posts: 19,398

Rep: Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992
I'd agree with above as first guess. Sometimes you may have to have a specific version so double check on that. Might also be some network/port issue. Might need webstart. Might get any of the window stuff to work in wine or even dosbox. Might need to look at other vendor implementations. Supermicro has a ipmi sol app that may even work.
 
Old 05-28-2014, 07:07 PM   #4
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Mint 17.1 KDE on workstation, CentOS 6.x on servers
Posts: 1,145

Original Poster
Rep: Reputation: 47
Not working, the plugin does not even show up under Firefox. Did I do this right?

Code:
root@falcon:/usr/lib/mozilla/plugins# ln -s /usr/java/jre1.7.0_40/lib/i386/libnpjp2.so
root@falcon:/usr/lib/mozilla/plugins# dir
total 0
0 lrwxrwxrwx 1 root root 37 Apr 29 01:40 flashplugin-alternative.so -> /etc/alternatives/mozilla-flashplugin
0 lrwxrwxrwx 1 root root 42 May 28 19:04 libnpjp2.so -> /usr/java/jre1.7.0_40/lib/i386/libnpjp2.so
root@falcon:/usr/lib/mozilla/plugins#

Is there any other paths I need to do? I just googled to find out where the plugins folder is and that's what I found.
 
Old 05-29-2014, 12:13 AM   #5
potato_farmer
Member
 
Registered: May 2014
Posts: 55

Rep: Reputation: Disabled
Yeah, that looks correct. Make sure you completely close out of Firefox and launch it again so it picks up the plugin. Also, I noticed you are linking to 32-bit JRE. Are you running 32-bit Firefox?
 
Old 05-29-2014, 12:14 AM   #6
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Mint 17.1 KDE on workstation, CentOS 6.x on servers
Posts: 1,145

Original Poster
Rep: Reputation: 47
Yeah closed right out of it. As far as I know I am running 32bit. I never did anything special when installing it, just did apt-get install firefox or w/e. So I'm assuming this is the 32 bit version. Is there a way to find out?
 
Old 05-29-2014, 12:36 AM   #7
potato_farmer
Member
 
Registered: May 2014
Posts: 55

Rep: Reputation: Disabled
You can run "apt list --installed firefox" to see what the arch is. If it shows amd64, then you have 64-bit Firefox and you will need to get 64-bit Java.

Go here:
http://www.oracle.com/technetwork/ja...s-1880260.html

Download:
jdk-7u60-linux-x64.tar.gz

Extract to:
/usr/java/

Link to Firefox:
cd /usr/lib/mozilla/plugins
sudo ln -s /usr/java/jdk1.7.0_60/jre/lib/amd64/libnpjp2.so .

Close all running instances of Firefox.
Open Firefox.

Last edited by potato_farmer; 05-29-2014 at 12:40 AM.
 
Old 05-29-2014, 01:31 AM   #8
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Mint 17.1 KDE on workstation, CentOS 6.x on servers
Posts: 1,145

Original Poster
Rep: Reputation: 47
apt command does not work on my system (other commands like apt-get and apt-cache do though).

I got the amd64 version just to see if it would work. Java now shows up as a plugin, but now when it goes to launch the redirect console it's just asking me what I want to open it with. How am I suppose to know? So what do I do?

I wish they would automate some of this stuff like they do in windows. I don't know how they expect people to just know you're suppose to copy all these files and do these odd steps. It's this kind of stuff that turns people away from Linux. In Windows you just click next and it does it all for you. Without you telling me I would have no idea that I have to copy those files around.
 
Old 05-29-2014, 01:45 AM   #9
Red Squirrel
Senior Member
 
Registered: Dec 2003
Distribution: Mint 17.1 KDE on workstation, CentOS 6.x on servers
Posts: 1,145

Original Poster
Rep: Reputation: 47
Ok by brute force I managed to find that I use /usr/java/jdk1.7.0_60/bin/javaws to open it. It loads the java splash screen but then I get a box that says "your security settings have blocked a self-signed application from running". Huh? What security settings? I don't see anything in Firefox about Java.

I found something on Google about using the Java Control Panel but I have no idea how I'd even get to that. In windows it would probably be under Control Panel. I'm guessing in Linux it's some random binary somewhere I have to just know where it is.

Edit: YAY got it to work. What a pain though. After more research I managed to find the control panel. It's /usr/java/jdk1.7.0_60/bin/jcontrol.

Now why can't they make better installs for these things, with actual icons and start menu entries? Pain in the ass that everything has to be googled instead of actually being in front of you and available.

Last edited by Red Squirrel; 05-29-2014 at 01:56 AM.
 
Old 05-29-2014, 01:59 AM   #10
potato_farmer
Member
 
Registered: May 2014
Posts: 55

Rep: Reputation: Disabled
I agree that it can be frustrating at times, but I am glad you got it working.
 
Old 05-29-2014, 05:19 PM   #11
jefro
Moderator
 
Registered: Mar 2008
Posts: 19,398

Rep: Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992Reputation: 2992
The self signed deal is supermicro issue and has many complaints about it.

Glad you got it figured out.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Password setting for IPMI in Linux zama Linux - Hardware 0 02-03-2013 11:44 AM
SuperMicro IPMI nima0102 Linux - Hardware 2 02-01-2011 04:09 AM
Knoppix Live Boot CD wont work on Supermicro Board abefroman Linux - Server 2 08-19-2008 04:50 AM
Writing own Linux ipmi driver Yoga Bharathi Linux - Newbie 2 01-25-2008 08:15 AM
Linux Support for IPMI Kamesh69 Linux - General 0 08-07-2003 10:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration