LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-03-2004, 07:14 PM   #16
wirawan0
Member
 
Registered: Aug 2003
Location: Virginia, USA
Distribution: Mandrake 9.1, SuSE 9.2, Ubuntu 7.04-10.04, Sabayon 5, Debian 6
Posts: 64

Rep: Reputation: 18

You may not have installed the powernow-k7 module. Try `modprobe powernow-k7' command if you haven't done that since the last time your machine booted up. If you have, try to see if the module is indeed loaded using command: `/sbin/lsmod'. If you're puzzled, please post the output of that command in this forum.

As for powernowd, it seemed to me that it was looking for the sysfs interface of the powernow-k7 module I mentioned above. Try modprobe-ing the module then re-run the daemon. But again, the daemon doesn't look that essential to me. But I may be wrong...

Wirawan
 
Old 08-04-2004, 08:27 AM   #17
Vandaahl
LQ Newbie
 
Registered: Jul 2004
Location: Netherlands
Distribution: Mandrake 10
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks alot for your help, wariwan0! It finally works. Being the Linux n00b that I am, I didn't figure out that you need to manually load the CPUfreq module everytime you boot. Bytheway, you do need a daemon, because CPUFreq alone doesn't do anything when I enable it. The CPU speed only goes down dynamically when I start Powernowd.

Here my next related question: I try to put in that extra line in /etc/rc.d/rc.local, but I can't, probably because I don't have the root rights (I'm logged in as a user). How can I set the right rights for doing this? On a previous Mandrake install, I could chose between logging in as a user or as root, but this time around, I can only log in as a user (I tried to add root to the user profiles, but when I put in the name and password of root, it told me that user allready exists, but it's not available in the boot userlist).
 
Old 08-04-2004, 11:05 AM   #18
wirawan0
Member
 
Registered: Aug 2003
Location: Virginia, USA
Distribution: Mandrake 9.1, SuSE 9.2, Ubuntu 7.04-10.04, Sabayon 5, Debian 6
Posts: 64

Rep: Reputation: 18
Thanks. I will take a look at powernowd later. AFAIK it seemed to me that a similar functionality like powernowd is built into the powernow-k7 driver already (i.e. using the CPU's built-in control, although this has a very limited user control, as far as I can tell). Powernowd seemed to be more controllable/customizable. I think someone else needs to give more opinion on this. I'm not a kernel expert.

Now for root user. A user called "root" (with UID=0) have always been set up every time you install linux. You know your root password, don't you? :-) Linux users don't usually log in as root unless it's absolutely necessary. It is strongly recommended that you follow this practice to avoid making damaging mistakes (such as executing shell command `rm *' in your /bin directory). BY the same token we don't usually log on to an X session as root. Now how do we switch into root when needed? Open your terminal window, and type `su'. This will ask for the root password. Type in the password, and now you are root! :-) Then go to /etc/rc.d and edit the file rc.local with your favorite editor (gedit, or emacs, vi, kwrite, kate, or whatever).

Just be careful when editing those things as root. It is always a good practice to back things up in case you make a mess and you don't know how to revert it. Let me give you a concrete example. The root's home directory is located at `/root' instead of `/home/root'. Make a subdirectory called `/root/backup'. Copy the file you want to backup to that directory, then make the necessary modification. If you use emacs, then here's the sequence:

# mkdir /root/backup
# cp -a /etc/rc.d/rc.local /root/backup
# emacs /etc/rc.d/rc.local
(then edit the file)

Different people have different way of making backup. I don't usually do it this way. My way is usually like this:

# cp -a /etc/rc.d/rc.local /etc/rc.d/rc.local.good

That is, I "save" the good configuration in the same subdir. But in certain subdirectories (such as /etc/cron.*/), you don't want extraneous files to float around there. That's why I use the /root/backup trick. Anyway, try it. And enjoy your early days with Linux!

Last edited by wirawan0; 08-04-2004 at 11:11 AM.
 
Old 08-04-2004, 11:43 AM   #19
Vandaahl
LQ Newbie
 
Registered: Jul 2004
Location: Netherlands
Distribution: Mandrake 10
Posts: 15

Original Poster
Rep: Reputation: 0
Well you see, I can't edit the rc.local file, I can only read it, even when in a terminal I'm logged in as a 'su'. After becoming a su I browse to the file, open it, but when I want to edit it, I get a message that says I don't have the rights to edit the file
 
Old 08-23-2004, 11:46 PM   #20
belcampo
LQ Newbie
 
Registered: Apr 2004
Distribution: mandrake
Posts: 3

Rep: Reputation: 0
Hi Vandaal,

If you normally login as say pieter your prompt looks like
pieter@yourmachinename directory
If you issue the 'su' command you become SuperUser and the name of the su is root.
Your prompt then looks like
root@yourmachinename directory

Then you can edit your /etc/rc.local file.
At the end of the file add
modprobe .....
and save the file
type exit <enter> to become pieter again. Next time you boot the extra command will be executed.

Belcampo from The Netherlands
 
Old 08-24-2004, 04:31 PM   #21
wirawan0
Member
 
Registered: Aug 2003
Location: Virginia, USA
Distribution: Mandrake 9.1, SuSE 9.2, Ubuntu 7.04-10.04, Sabayon 5, Debian 6
Posts: 64

Rep: Reputation: 18
I think I know what the problem is. You opened a shell, then type `su' and put in the password and entered the super-user shell. But then you might have opened the editor from the GNOME/KDE menu. Of course the editor was not opened in the super-user mode, since it was invoked from the GNOME/KDE menu, which runs on user privilege, not super-user. To edit the file, you need to run the editor FROM the super-user shell itself. From the shell, type:

# emacs /etc/rc.d/rc.local

That should do it. (Remember NOT to type in the `#' character. It's just a reminder that it is a superuser shell, not an ordinary user shell).
 
Old 09-10-2004, 03:10 AM   #22
rick6655
LQ Newbie
 
Registered: Sep 2004
Distribution: gentoo
Posts: 2

Rep: Reputation: 0
modprobe powernow_k7 not -k7

You could also try the following, the kernel may need to be recompiled - set them as modules.
cpufreq_userspace
cpufreq_powersave
powernow_k7
freq_table
thermal
processor
fan
button
battery
ac

I run Gentoo and have the above in my /etc/modules.autoload.d/kernel2.6 file
If you use cpufreq and 2.6 kernel, modify /etc/cpufreq.conf
cpufreqd should be started during boot


Rick
 
Old 09-10-2004, 10:08 AM   #23
wirawan0
Member
 
Registered: Aug 2003
Location: Virginia, USA
Distribution: Mandrake 9.1, SuSE 9.2, Ubuntu 7.04-10.04, Sabayon 5, Debian 6
Posts: 64

Rep: Reputation: 18
The name powernow-k7 was correct for Mandrake 10.0. It may vary across different distros. Just to clarify. Here's the location of my module:

/lib/modules/2.6.3-16mdk/kernel/arch/i386/kernel/cpu/cpufreq/powernow-k7.ko.gz
 
Old 09-11-2004, 05:11 AM   #24
rick6655
LQ Newbie
 
Registered: Sep 2004
Distribution: gentoo
Posts: 2

Rep: Reputation: 0
Check your kernel.
The following represents my setup
Power management options (ACPI, APM)
CPU Frequency scaling ---> [*] CPU Frequency scaling
<M> 'powersave' governor
<M> 'userspace' governor for userspace frequency scaling
<M> CPU frequency table helpers
<M> AMD Mobile Athlon/Duron PowerNow!



Rick
 
Old 09-20-2004, 07:48 AM   #25
apeekaboo
Member
 
Registered: Apr 2003
Location: Stockholm/Sweden
Distribution: Kubuntu, Debian, Slax
Posts: 91

Rep: Reputation: 16
How do I know if my cpu supports this?
I have an Athlon XP 2200+ and fail to get cpu-freq working.
Is this just for mobile Athlon's?
Does this require some feature to be enabled in bios as well? My mainboard is a VIA FX41 (Shuttle mini-ITX)
Code:
[eek@apeekaboo bin]$ uname -a && cat /proc/cpuinfo
Linux apeekaboo 2.6.8.1 #24 Mon Sep 20 13:35:28 CEST 2004 i686 GNU/Linux
processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 8
model name      : AMD Athlon(tm) XP 2200+
stepping        : 0
cpu MHz         : 1802.609
cache size      : 256 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow
bogomips        : 3555.3
This is what I've enabled in the kernel:
Code:
# CPU Frequency scaling
#
CONFIG_CPU_FREQ=y
# CONFIG_CPU_FREQ_PROC_INTF is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE=y
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=y
CONFIG_CPU_FREQ_GOV_USERSPACE=y
# CONFIG_CPU_FREQ_24_API is not set
CONFIG_CPU_FREQ_TABLE=y

#
# CPUFreq processor drivers
#
CONFIG_X86_ACPI_CPUFREQ=m
# CONFIG_X86_ACPI_CPUFREQ_PROC_INTF is not set
# CONFIG_X86_POWERNOW_K6 is not set
CONFIG_X86_POWERNOW_K7=m
CONFIG_X86_POWERNOW_K8=m
# CONFIG_X86_GX_SUSPMOD is not set
# CONFIG_X86_SPEEDSTEP_CENTRINO is not set
# CONFIG_X86_SPEEDSTEP_ICH is not set
# CONFIG_X86_SPEEDSTEP_SMI is not set
# CONFIG_X86_P4_CLOCKMOD is not set
# CONFIG_X86_LONGRUN is not set
# CONFIG_X86_LONGHAUL is not set
I get 'no such device' when I'm modprobing:
Code:
[root@apeekaboo linux]$ modprobe powernow-k7
FATAL: Error inserting powernow_k7 (/lib/modules/2.6.8.1/kernel/arch/i386/kernel/cpu/cpufreq/powernow-k7.ko): No such device
[root@apeekaboo linux]$ modprobe powernow-k8
FATAL: Error inserting powernow_k8 (/lib/modules/2.6.8.1/kernel/arch/i386/kernel/cpu/cpufreq/powernow-k8.ko): No such device
[root@apeekaboo linux]$ modprobe acpi
FATAL: Error inserting acpi (/lib/modules/2.6.8.1/kernel/arch/i386/kernel/cpu/cpufreq/acpi.ko): No such device
Does anyone have any suggestions?
 
Old 09-20-2004, 11:50 AM   #26
wirawan0
Member
 
Registered: Aug 2003
Location: Virginia, USA
Distribution: Mandrake 9.1, SuSE 9.2, Ubuntu 7.04-10.04, Sabayon 5, Debian 6
Posts: 64

Rep: Reputation: 18
I think you are correct. It is not for the "regular" Athlon/XP CPUs. AMD only made PowerNOW! technology available in its mobile CPUs and the new AMD Athlon64 (and 64FX?) chips. For others, correct me if I'm wrong.
 
Old 09-20-2004, 12:33 PM   #27
apeekaboo
Member
 
Registered: Apr 2003
Location: Stockholm/Sweden
Distribution: Kubuntu, Debian, Slax
Posts: 91

Rep: Reputation: 16
Well, that's a pity then...

It would be interesting to see if /proc/cpuinfo show this feature.
Could anyone with an Athlon mobile or Athlon64 confirm this?
 
Old 09-21-2004, 11:20 AM   #28
wirawan0
Member
 
Registered: Aug 2003
Location: Virginia, USA
Distribution: Mandrake 9.1, SuSE 9.2, Ubuntu 7.04-10.04, Sabayon 5, Debian 6
Posts: 64

Rep: Reputation: 18
I don't think so. Yesterday I looked into mine, here is it:

Code:
~ $ cat /proc/cpuinfo 
processor	: 0
vendor_id	: AuthenticAMD
cpu family	: 6
model		: 8
model name	: mobile AMD Athlon(tm) XP 1400+  
stepping	: 0
cpu MHz		: 1200.365
cache size	: 256 KB
fdiv_bug	: no
hlt_bug		: no
f00f_bug	: no
coma_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 1
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mp mmxext 3dnowext 3dnow
bogomips	: 2375.68
Oh...let's see... there is no such thing as "powernow!" in the flag list. Unfortunately...
 
Old 09-21-2004, 11:22 AM   #29
wirawan0
Member
 
Registered: Aug 2003
Location: Virginia, USA
Distribution: Mandrake 9.1, SuSE 9.2, Ubuntu 7.04-10.04, Sabayon 5, Debian 6
Posts: 64

Rep: Reputation: 18
Oh. Forgot one thing. For your non-mobile CPU, can you use vcool utility?

http://vcool.occludo.net/

I tried in the past, but not put too much effort into it. There are a few good comments I heard about it, though. Give it a try and let us know!

Unfortunately the application is originally written for Windows. But the author has a mini Linux version of it:

http://vcool.occludo.net/VC_Linux.html

I hope it's an easy install.

Last edited by wirawan0; 09-21-2004 at 11:24 AM.
 
Old 09-21-2004, 11:51 AM   #30
apeekaboo
Member
 
Registered: Apr 2003
Location: Stockholm/Sweden
Distribution: Kubuntu, Debian, Slax
Posts: 91

Rep: Reputation: 16
Quote:
Originally posted by wirawan0
Oh. Forgot one thing. For your non-mobile CPU, can you use vcool utility?
I tried the Linux version of lvcool some year ago, and it worked 'half decent'.
'Half decent' in the sense of going into a low power state, but not being able to return from it, leaving me with poor performance.

The good news is I ditched lvcool in favor of a Debian package called athcool which does what lvcool does, but it's fully working on my system.
I just thought I would be a cool thing to mess with the cpu frequency as well...
Unfortunately I don't know where to find athcool for non-Debin users.

Oh, by the way.
I compared your output from /proc/cpuinfo with mine, and you have en extra flag called 'mp' which my cpu is lacking.
Don't know if this could in any way the related to the powernow feature.

Thanks anyway!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
kernel-source-2.6.5-7.src.rpm requires kernel-dummy to build!? fizzdandantilus SUSE / openSUSE 5 12-02-2004 12:48 PM
New FAQ topic: Should I edit my kernel configuration?/Should I build a custom kernel? chort *BSD 10 09-10-2004 11:15 PM
Unable to build NVIDIA kernel module / determin kernel version Night Ink Fedora 2 05-31-2004 04:54 PM
2.6 Kernel on Dell 5150, cpufreq throttling issues Neo8234 Linux - Software 2 02-09-2004 06:43 PM
cdrom and cpufreq on kernel 2.6.0 navarre9 Linux - Laptop and Netbook 1 01-14-2004 01:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:33 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration