-   Linux - Software (
-   -   ipod/ipod shuffle woes (lack of permissions to edit files) (

Lechium 04-13-2005 03:42 PM

ipod/ipod shuffle woes (lack of permissions to edit files)

I have an issue with ipod and ipod shuffle... for some reason the iTunes_Info directory on both of them is marked as read only and I cannot write files to it even as root!

When i tried showning the directory where shuffle is being mounted to user i got following situation:
# chown lechium shuffle/
chown: changing ownership of `shuffle/': Operation not permitted

Moreso while I can run gtkpod as root and remove/add songs upon removal I cannot use ipod/shuffle normally. Also the files I had removed from them before using gtkpod (and they do not show up anymore) are still physically on the drives...

Did anybody encounter similar problems or has a solution?

P.S. I followed the instuctions on gentoo wiki, so no need to redirect me there =)

P.P.S. I am running Gentoo, with latest kernel, and have all required kernel mods compiled in.

HalfDiminished 04-13-2005 04:14 PM

Well, I ran into a similar issue. What happened was I had transfered a mp3 from my linux mp3 library to my iPS that had a filename that was incompatible with the iPS' FAT file system. I use ripperX to convert my CDs to mp3s and it includes characters like '[' ']' and '?' (from cddb) which the FAT fs has problems with. Also, the filenames can be too long. Then I couldn't remove them in either Linux of W2K.
The way I solved it was to use the old DOS command line chkdsk /F. Yeah, this is totally lame, but it was the only thing I could figure out. There MUST be a way in Linux, maybe reformatting??? But this works.
Once you get that working, you may want to use gtkpod to manage your mp3s and make your playlist(s). Just remember, after you sync in gtkpod, exit gtkpod, run mktunes -m /mnt/ipod and umount the ipod. This looks like a hassle, but the commands can be scripted into a icon on your desktop. I have one icon that is a drawer that contains a gtkpod icon and a mktunes icon that I click after I close gtkpod. Make sure you're using the latest version of gnupod.

Hope that made sense and maybe even helped.

All times are GMT -5. The time now is 09:40 PM.