LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-15-2009, 04:11 PM   #1
striker
LQ Newbie
 
Registered: Aug 2009
Posts: 11

Rep: Reputation: 0
Iperf CPU usage at 100%


Hi,

I use Iperf for network benchmark, both tcp and udp, but while running udp tests the CPU gets 100% usage. My OS is centos 5.3 x64 and the iperf is 2.0.4-1.el5. The CPU are 2x Intel(R) Xeon(TM) CPU 3.20GHz in a HP Proliant G3.

Can you help me?

Thanks
 
Old 08-15-2009, 05:46 PM   #2
paulsm4
LQ Guru
 
Registered: Mar 2004
Distribution: SusE 8.2
Posts: 5,863
Blog Entries: 1

Rep: Reputation: Disabled
Sounds like a pretty intense benchmark test ;-)

I'd be curious to compare the results on a different machine. Specifically:

1. Does CPU go to 100% on the other platform?
<= Remember "High utilization" is *not* necessarily a bad thing: it might just mean you're doing a lot of work!

2. Is the UDP throughput as high (or higher)? Or a lot lower?

Just curious .. PSM
 
Old 08-16-2009, 05:14 AM   #3
striker
LQ Newbie
 
Registered: Aug 2009
Posts: 11

Original Poster
Rep: Reputation: 0
1. If i do the same test with a Windows machine, the cpu usage is normal.
2. The highest throughput that i use is 8Mbps. Sometimes i also test with 4Mbps, 2Mbps and 400Kbps.
I think is bug...
 
Old 08-17-2009, 03:20 PM   #4
striker
LQ Newbie
 
Registered: Aug 2009
Posts: 11

Original Poster
Rep: Reputation: 0
Does anyone has the same problem?
 
Old 05-10-2013, 06:44 PM   #5
rururudy
LQ Newbie
 
Registered: Feb 2007
Posts: 5

Rep: Reputation: 0
Quote:
Originally Posted by striker View Post
Does anyone has the same problem?
Yep, when I leave iperf running in daemon mode, it hogs up all the CPU (even with no active clients).

Scenario, I run 'iperf -s -D' on an internal server, go to other machines, test a few times, then forget about it. Later, the server machine is locked up at a load of 6.00 and iperf is at 100% CPU. The test server has nothing else active on it...

iperf version 2.0.5
platforms: FreeBSD 8.4 and 9.1

If i run 'truss' on the PID, nothing is returned, yet iperf is still churing away at 100% CPU. How is this possible?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kubuntu 9 cpu usage 100% vmelkon Ubuntu 3 05-04-2009 10:24 AM
FF 2.0 100% CPU Usage cexshun Slackware 12 04-05-2007 01:11 AM
CPU Usage goes to 100% when pthread_cond_wait is being used zen_buddha Linux - Software 4 10-19-2005 04:28 PM
CPU usage 100% ecsfan Red Hat 17 11-19-2003 03:06 PM
100 % CPU usage ???? rolandi Linux - Newbie 1 10-07-2003 11:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration