-   Linux - Software (
-   -   Internet explorer on linux or a free virtual machine? (

zahadumy 12-16-2006 04:37 AM

Internet explorer on linux or a free virtual machine?
My online banking works only with Internet Explorer. Is there any way to make IE work on linux? I guess not... So I think the only way to access my online banking from linux is to install a virtual machine and put Windows on it. Do you know any free one? I used only VMWare before and I know there are a lot, but not all of them are reliable. Did you try any virtual machine?

patrickvk 12-16-2006 07:02 AM

What about this: (IE on linux with the help of wine

budword 12-16-2006 07:13 AM

You can get ie to work under wine.

Here is a link to a firefox plugin that might come in handy.

There might be other solutions too. I think you can change what your browser identifies itself as. So firefox would tell that website that IT is IE. Here is a link. (I think this might best suit your needs.)

As far as a vm goes, I've only used vmware server. It works fine, but to just browse one site, a vm seems like overkill. There are better solutions.

Best of luck....
Let us know which solution works best in your situation.


lebabyg 12-16-2006 07:48 AM

Lots of websites only work in IE. Have you tried using konqueror and then in tools > browser identification > configure setting your banking site as a special option then setting IE in windows XP as the setting for it?? This should work. Alternatively try Crossover office, or VMWare. Both are non-free software but can probably be found on bittorrent if you do enough digging.

budword 12-16-2006 08:20 AM

Vmware server is free(as in beer), and works just fine as a desktop too, with windows, linux, reactOS, all the BSD's, even OLTPC's sugar will work. You don't have to download it on bitorrent. I think Ubuntu will install it for you, if your repos's are set up right. (It's been a while since I installed it, all I remember is that it was easier than I thought it would be. Once you have a linux box set up well, you don't ever need to do anything more than once, and it was a while ago.)

In any event, I don't think he needs a vm just to check his bank online. There are simpler solutions I think.

Best of luck...


macemoneta 12-16-2006 09:44 AM

I had the problem where my bank also "only works with IE". I installed the Firefox User Agent Switcher plugin, and I could use my online banking with no problem. I also notified my bank that the test in their web code was invalid since Firefox worked correctly, and they eventually removed it (it took them about 6 months).

zahadumy 12-16-2006 02:03 PM

I tried those plug-ins for Firefox and it didn't work for me. When I was in US, my online banking only needed an user and a password and worked with any browser I guess... Here I need a certificate and I can't get it even though I set Firefox to identify itself as IE. Maybe it would let me log in, but without that certificate I have no chance.
I tried to do the same thing with konqueror, that didn't work either.

I will try wine tomorrow, because I have to go out tonight. :) I heard about it but never used it. But if this doesn't work either, I will have to install a VM, right? And if I do, someone said it's free, because I remember I googled after a crack when I was using Windows and playing with virtual machines, that's why I asked for a free one. I don't want to install any cracked software, for some reason. :)
Anyway, does it take so much hard disk space for a minimal Windows install? Because I don't need anything but IE.

Off topic (if anyone knows): why some sites can't be accesed only through IE? And when we're talking about online banking, are there any security issues about this? What's wrong in accessing your online account with Firefox or any other browser? Because as far as I know, IE has more security holes than any other browser, right?

Thank you all for your suggestions.

macemoneta 12-16-2006 02:16 PM

Firefox handles the same certificates that IE does - obviously, or it couldn't do SSL. Go to Edit->Preferences, then Advanced. Make sure "Use SSL 2.0", "Use TLS 1.0" and "Use SSL 3.0" are all checked. In the lower section, select "Select one automatically".

If it's still not working... are you sure you are at your bank, and not a spoofed URL?

zahadumy 12-16-2006 07:02 PM

Ok... I installed User Agent Switcher. I guess the way to set Firefox to identify itself as IE is go to the plugin's properties, click "User agents", select "Internet Explorer 6 (Windows XP)" and click "ok". I'm not sure about one thing though: If I click "view default" I get for user agent this: "Mozilla/5.0 (X11; U; Linux i686; en-US; rv: Gecko/20061107 Fedora/ Firefox/". Am I doing something wrong?
I checked the options mentioned by you and they were already like you said they should be.
And yes, I'm sure it's my bank's site, this works just fine from my desktop computer (which has a Windows XP for this only reason).
Thank you.

macemoneta 12-16-2006 07:52 PM

The plugin adds a "User Agent Switcher" menu item to the Tools menu. You can select how you want your browser to identify itself from there.

lebabyg 12-16-2006 07:52 PM

Not too sure if firefox has the what konqueror has, i think that it always defines itself as netscape. Have you tried konqueror?? I bank with a bit of an annoying bank and they let me on, also a website told me that it was only viewable in IE a few hours ago (can't remember which one) so i changed my konqueror profile to IE and Kerching. I guess being on Fedora you're using Gnome. Have a go with Konqueror and see what happens. Yum install konqueror maybe??

zahadumy 12-16-2006 08:12 PM

Oka... Thank you macemoneta. That didn't work though for some reason... I get "This page has not finished loading yet. Please wait a few seconds and try again." when I try to get the certificate.
lebabyg: I use gnome, but I have a lot of kde software installed too. I tried it with konqueror but the page doesn't even display correctly, maybe it would work to get the certificate if I could enter the information needed in order to get it.

I installed IE with wine like here: but I get this error message: "An unexpected error (0x800700EA) occurred while getting the CSP list.". Do you have any idea how to fix this? Thank you.

jlinkels 12-17-2006 06:09 AM

Banks.... my bank (Postbank in the Netherlands) specifies a list of allowed browsers:

- IE on Windows 98 SE
- IE on Windows ME
- IE on Windows 2000

I have tried user agent switcher in Mozilla, and the most aggressive setting for mimicking as IE in Opera, but still the pages do not display. No, I don't mean on-line banking, but information like calculation of IBAN numbers.

For that moment I solved the problem by VNC-ing to a machine running W2k, but that was only a temporary solution.

I have been using Wine (minimal results on Debian Sarge) and Crossover office (worked quite well, including IE) The reason that I quit using these libraries was that I have one ancient schematic drawing 16-bit program which would not run in Wine.

Last week I eventually installed VWware server. There is little to say about that. It runs Windows and all the Windows apps flawlessy. I installed it on one machine and I can access it from all my other machines. If you don't need the virtual machine you suspend it. It is free and can be installed legally. No installation problems on Debian Etch.

But somehow I feel like a vegetarian eating a salad with slices of smoked ham mixed in...


timdsmith 12-17-2006 06:24 AM

Why not try this?

I use it for testing purposes when designing web pages. Works great.

zahadumy 12-17-2006 06:25 AM

Got your point. I didn't know that VMWare is free. I'll install it today and see what I can do. That's why I asked if it's possible to install IE only, because like budword said before, it's not really worthed to install a VM just to use it once in a few days on average... But what else you can do? :)

The error I mentioned above is not solved yet, looks like it's a wine issue, but I didn't find any solution to it anywhere, not even on ies4linux official forum.

Thank you.

All times are GMT -5. The time now is 01:56 PM.