-   Linux - Software (
-   -   Internet connection drops out with Ubuntu 12.04 (

John_Kyatt 07-30-2012 05:53 AM

Internet connection drops out with Ubuntu 12.04
I'd been holding on to Ubuntu 10.04 LTS until last week. With that version my wireless connections were quite solid. Since installing 12.04 LTS (32 bit) I've been experiencing intermittent drop-outs, usually when downloading large updates. I've been going through the solutions recommended in the Ubuntu forums, but so far these haven't worked. Most solutions involved downloading drivers, but this shouldn't be necessary when a previous Ubuntu version didn't require specific drivers. The error messages given are the standard 'Firefox cannot connect to ...' and 'cannot connect to SMTP server ...' That is always the first time I know that the connection has been lost. There is no warning that the connection is dropping out. A temporary workaround has been to switch over to a mobile broadband modem, but that connection usually fails as well without warning. The fact that two wireless connections fail makes me think that this is a fault with the recent Network Manager module. This 6yo laptop running Linux Mint 12 doesn't have any problems. Neither do the Windows XP and 7 machines in the family. Interestingly, when running Linux Mint Debian Edition on this laptop, it had similar (but not identical) problems with the internet connection not being able to 'authenticate'.

ilesterg 07-31-2012 09:50 PM

This is just weird. Since switching to another physical medium such as mobile broadband modem (hence another driver) gives the same issue, I suppose it's a problem with Ubuntu's TCP/IP?

John_Kyatt 08-13-2012 12:55 AM

Problem solved?
I think I've solved the problem. Upgrading the wireless card seems to have done the trick. I saw on one Ubuntu forum where Ralink RT2800 chipsets don't like loads greater than 'g' speeds. Slowing down the router from 'n' to 'g' would have solved the problem, but the other machines in the household mightn't have liked that. I bought a TP-Link card with an Atheros AR9287 chip, and that seems to be working. I'll keep my fingers crossed that the problem has gone away.

All times are GMT -5. The time now is 11:02 PM.